Link to home
Start Free TrialLog in
Avatar of Michael Belletty
Michael Belletty

asked on

updating HP Laptop Firmware when no Windows Install present.

i have a HP 15 Laptop Model Number 4NR56PA#ABG.
I can see the Firmware is version F.10
The HP website shows the latest version is F.34.

The laptop was not working well and blue sceeening.  Also it was stuck on version 1903 and would not upgrade to the master versions of Windows 10 either through Windows Update or through the Windows Update Assistant.   I thought it was Windows 10 corrupted OS and recovery system.

I have now formatted the Hard Drive and tried to install Windows 10 cleanly.
The first attempt had it coming up with errors when going through the setup process from the USB drive.

I formatted the USB drive and created new media.
Now it runs through the setup fully then restarts to go through the initial Windows 10 setup process.
issue now is I am unable to type anything in to create a new Local Admin user. The laptop keyboard will not type letters and this also happens if I try to use the on screen keyboard.  I cannot type letters therefore cannot setup the first user. so am stuck to start Windows.

If I enter the recovery system I can use the keyboard and type things in.

so I presume it is the Firmware or lack of firmware updates that is causing this.

anyone know how to update the Firmware without a Windows OS operational?
Avatar of arnold
Flag of United States of America image

Often, you can update the bios from the bios.
But need the firmware expanded on a USB.
Check the hp bios update guides.
Possibly they have a bootable firmware update option that needs a USB/cd/DVD ...
Avatar of Michael Belletty
Michael Belletty


I found this page,it%20on%20the%20original%20computer.

but I am stuck at step 3 point 2.  when I enter the system diagnostics menu there is no firmware update option. only:
memory test
hardware check
The issue might be the bios version is way off 10 vs 34
Use the USB method that will boot the system and deploy the update.
can anyone tell me how to use the USB method?

I have downloaded the BIOS update file from HP website.  I then ran it on another computer.  I created a USB drive to update another computer.

I am now stuck on what to do next.  there is no option in the BIOS to update that I can see.
the USB contains 2 folders called:

how do I run anything in these folders when there is no working Windows OS on that computer???
is there a way of downloading Windows 10 version 1903  and installing it on the laptop. Maybe if I can get that working I can then update the BIOS in Windows??
You would use the USB you created to boot the laptop.
Insert the USB, powerup the laptop
F12 or ESC f11 whichever brings up a boot manager, select USB as the boot device
The link includes the options once you boot via USB what and how to perform the update.

In reference , did you delete all the partitions on the existing drive?
Possible options to get a revovery media.

Or try
I did delete all original partitions on the HDD.

pressing F12 does nothing.
pressing esc gets into the startup menu.  F11 is system recovery and I don't think that helps with BIOS update.  
F9 is boot device options.  but it doesn't recognise the USB as  boot device as it is not setup as a boot device..  it only has the 2 folders as mentioned above on the USB.

I will have a look at those links now.
In the quickglance, thought the USB is a bootable option.

a secondary review it points that it loads the BIOS onto the USB and you have to boot and get into the bios to deploy the update from the USB.

The item covers the process, during bootup hit F2 and go through the Diagnostic UEFI boot.

Possible variation is that you have to get into the BIOS and switch it to UEFI if it is not what it is set to....

If memory serves, the firmware updates have had several options.

BIOS based. boot media with a flashing utility and from within windows.

Which system was on there before?
Consider getting windows 8.1
To load on the system if the prior with windows 10 19xx is not a viable option nor is the HP recovery option.

install windows 8
update the firmware
try the windows 10 reinstall.
If there was a flashing utility then that would be great. but I don't think there is.

Just downloaded 8.1 and created bootable USB.  comes up with an error during setup.

UEFI is set by default in BIOS in that Legacy boot is disabled.

F2 does not provide a BIOS firmware update option as HP support suggests it should.

so I cannot find any way of updating BIOS outside of Windows...

Just trying to download Windows 1903 ( I think it is that version anyway).  it will take some time to download but that's my last option at the moment.  

I don't think dodgy RAM would create this issue would it??
allow keyboard to work in Bios and Windows bootable Drive initial setup but not in any Windows screens??
Ok. I just ran a Memory Test and the quick check failed.......
how much memory does the system have, often there could be two modules. one on the bottom, and one under the keyboard The bottom is a quick access,
Check the spec of your laptop if it has a built-in memory.

It is good that you discovered the memory issue now, versus while you were applying the update when it might trigger a failure/reboot.
I need to open up the laptop.  hp website suggests it is 1 X 8GB DDR4
Unfortunately, in ypur situation, memory is not customer accessible.

How long ago did you get it?
Access to a professional HP repair who might take care of it under warranty?
It's not under warranty.... I know how to open the laptop and replace the RAM
How are you with a screw driver possibly if you were looking to add faster nvme m.2 storage...

You could take this opportunity to achieve ....
Ddr4-2400 2x8Gb upto 16Gb
You could upgrade the processor
you posted "Now it runs through the setup fully then restarts to go through the initial Windows 10 setup process. "
did you remove the usb stick?  if not - it is normal behavior
Avatar of Michael Belletty
Michael Belletty

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
A faulty module within a ram sodimm would work fine until memory used triggers a write to the faulty module, on error, the system resets kernel panic/bugcheck.
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: 'Michael Belletty' (https:#a43282599)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

Experts-Exchange Cleanup Volunteer