troubleshooting Question

TempDB won't shrink on SQL Server 2014

Avatar of Jim Youmans
Jim YoumansFlag for United States of America asked on
Microsoft SQL ServerAzure
8 Comments1 Solution43 ViewsLast Modified:
I was helping a friend with a TempDB problem.  He is running SQL Server 2014 on Azure VM and it is part of an always on group.  The problem is that TempDB grew to fill up the drive and when we tried to shrink it, nothing worked.  We did the DBCC FREESYSTEMCACHE('ALL')  and shrink. We did alter TempDB size.  We did everything we could think of and nothing worked.  We finally failed the database over to secondary server and stopped and restarted the SQL instance to reset TempDB on the primary server.  That worked.

Has anyone come across a problem like this and if so how did you handle it?

Thanks!
Jim
ASKER CERTIFIED SOLUTION
lcohan
Database Analyst
Log in to continue reading
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform for $9.99/mo
View membership options
Unlock 1 Answer and 8 Comments.
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
The Value of Experts Exchange in My Daily IT Life

Experts Exchange (EE) has become my company's go-to resource to get answers. I've used EE to make decisions, solve problems and even save customers. OutagesIO has been a challenging project and... Keep reading >>

Mike

Owner of Outages.IO
Phoenix, Arizona, United States
Member Since 2016
Join a full scale community that combines the best parts of other tools into one platform.
Unlock 1 Answer and 8 Comments.
View membership options
“All of life is about relationships, and EE has made a virtual community a real community. It lifts everyone's boat.”
William Peck

Member since 2004