Link to home
Start Free TrialLog in
Avatar of Bill Park
Bill ParkFlag for United States of America

asked on

SSIS project runs OK within Visual Studio, fails using DTExecUI

This is my first attempt at a Visual Studio SSIS project.
It works OK and produces the expected output to SQL tables when I run within Visual Studio.
It fails without any output to SQL tables when I run the dtsx from DTExecUI.
How should I approach this?
Visual Studio Enterprise 2019
DTExecUI Version 2.0
SQL Server Microsoft SQL Server 2019 (RTM-GDR) (KB4583458) - 15.0.2080.9 (X64)   Nov  6 2020 16:50:01   Copyright (C) 2019 Microsoft Corporation  Developer Edition (64-bit) on Windows 10 Pro 10.0 <X64> (Build 19042: ) (Hypervisor)
 
I've attached a screenshot of the Package Execution Progress from DTExecUI.
The debug output from Visual Studio,
and the dtsx file.

Thank you.

Transform3.dtsx
OutputfromDTEXECUI.png
User generated image
Avatar of Raja Jegan R
Raja Jegan R
Flag of India image

I've encountered this error before when using Visual Studio 2019 and using SQL Server 2016.
If there is a difference between Visual Studio and SQL Server version, then the package will run from SSDT or Visual Studio but won't execute as a Job or from outside and the solution to fix this is to change the Target Server version property in SSIS by following the steps below: (Don't have access to SSDT and hence guessing the steps)
1. In SSDT or Visual Studio, open your Solution and Right Click on your project and choose Properties.
2. Under Configuration properties, you can see a property named TargetServerVersion and change it to match your SQL Server version like 2014 or 2016 or 2017 and your package execution would work fine.
Avatar of Bill Park

ASKER

Thank you but no, the TargetServerVersion was set to SQL Server 2019.
ASKER CERTIFIED SOLUTION
Avatar of Bill Park
Bill Park
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Glad to hear you have resolved it out..
Error message you raised in the question and the one in screenshot seems different.
Yes, to resolve the error in the snapshot "the runtime connection manager with the id cannot be found" you would need to map all the connection managers properly as you have exlained..