troubleshooting Question

Clear Cached Credentials of another user?

Avatar of Travis Clodd
Travis CloddFlag for Canada asked on
Remote AccessWindows Server 2016Microsoft OfficeMicrosoft 365Windows OS
1 Comment1 Solution17 ViewsLast Modified:
I have an RDS server that shares a virtual app which my users connect to so they can use our ERP. Our ERP also transfers data directly to Excel so on this server I have Office365 installed and all my users have E3 licences. When the user first opens excel it asks for their credentials and picks up the licence. This has always worked flawlessly but recently some of my users are reporting that the O365 apps are now saying:

"Sorry, another account from your organization is already signed in on this computer."

I have admin credentials so I connected directly to the server, opened Excel, and my account was giving the same error. I did a little research on technet and found that I needed to do two things to fix the error:

1. Delete a registry key:
  • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity\Identities
2. Clear the windows credentials cache in Credential Manager.

On my local admin account I deleted the registry key and I cleared all the stored credentials in the Credential Manager. This fixed the issue for my account.

Now, for the remote users I can clear the registry key but I cannot find a way to clear their credential manager without opening it directly in their account. My problem is the users do not have access to the Credential Manager via Control Panel because this is a virtual app server, so I was hoping I might be able to locate the folder in windows that stores the user credentials?  Is this even possible?

A few other things I have tried:
  1. I looked in the C:\users\%USERNAME%\appdata\roaming\microsoft\credentials folder but it is empty for all users, including me (I also checked the local folder and same thing).
  2. I found a powershell script that does this as the local user. The script worked on my local account so i tried putting this in the users startup folder but it didn't work.
    $targets = (cmdkey /list | Select-String -Pattern "target") -split "Target: "
    foreach($t in $targets){ 
               & cmdkey.exe /delete:$t 
    }

If anyone could point me in the right direction I would greatly appreciate it.
ASKER CERTIFIED SOLUTION
Join our community to see this answer!
Unlock 1 Answer and 1 Comment.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 1 Comment.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros