troubleshooting Question

Windows 10 PIN and Fingerprint login are broken, Password login is missing

Avatar of Gary Benjamin
Gary BenjaminFlag for Canada asked on
Windows 10Windows OS
11 Comments1 Solution26 ViewsLast Modified:
I encountered a Windows 10 login problem while trying to fix another problem. While I have been able to fix my login problem the solution was cumbersome. I was hoping the Windows Experts on EE might have some insight into a better way to resolve this issue, and why certain things that I tried did not work.
 
My other problem, which still hasn’t been resolved, is that when I click on “Run as administrator” in the context menu for a shortcut, nothing happens. I have a similar issue if use the Search on the task bar to search for Cmd and then click on “Run as administrator”. Perhaps a related issue is that the links to open a “New window” and “New incognito window” on the Chrome taskbar button don’t work either. There are many web pages with solutions to these two problems, which I am in the process of trying, so I will not re-ask about them here at EE unless I don’t find solutions that work. I only mention them since they are relatively new problems that coincide with my login problem, so might be related.
 
While trying one of these solutions, it recommended using MSConfig to stop all non-Microsoft services from running at bootup to see if one of the services was interfering with the Run as administrator context menu option. The page instructed me to “Hide all Microsoft services” on the Services tab of MSConfig, “Disable all” the ones that remained, and reboot. Instead of following the instructions to-the-letter I chose “Diagnostic startup” on the General tab and rebooted.
 
Keep in mind that my usual login is using a PIN, so after Windows rebooted I was presented with the error “Something happened and your PIN isn't available. Click to set up your PIN again.” Clicking on the provided link the first time just gave the same message. Clicking it a second time said you can’t reset the PIN without first downloading an (unspecified) application, and asked if you want to search for it. If you choose to not search then you are presented with the same unavailable PIN error message, and if you choose to do the search there doesn’t appear to be any searching taking place nor any feedback about a search success or failure, and then you get the same unavailable PIN error message.
 
Since the PIN wasn’t working, I wanted to sign in using my password. On the signin page my link for “Sign in options” used to have three options for Password, PIN or Fingerprint. In retrospect, I now realize that when Windows recommended that I turn on the option to “Require Windows Hello sign-in for Microsoft accounts” to increase my security, I inadvertently turned off the option to sign in using my MS Account password. So now I had only two options for signing in: Fingerprint and PIN. Choosing Fingerprint didn’t work, since Windows didn’t seem to react to scanning my finger, probably because the required service wasn’t running. Since none of the available options were working I couldn’t log in.
 
I decided to use safe mode to see if I could resolve my issue. I used shift-click on the Restart option available on the login screen to reboot into safe mode. I chose Startup Repair, which did not fix my login issue. I chose to Change Windows startup behaviour, and upon reboot was presented with a login screen (not the usual Windows login) which prompted me to select one of the two MS Accounts which were used in the past to log into Windows, followed by a prompt for my password. I then opened a Command Prompt in safe mode. I ran SFC which did a scan (100% without reporting any errors), but then claimed it couldn’t complete properly; I think it had an insufficient privileges error. I then tried to run DISM, but that program isn’t available in safe mode. I navigated to C:\Windows\System32 and tried to run it from there, and got an error like I couldn’t run it using the online parameter. I tried to run MSConfig, but found out I wasn’t an Administrator and couldn’t run it. Using SET, I found that I was logged in using System, even though I had provided the credentials for my (Admin) user to set up safe mode (albeit, the system rebooted between then and offering me the safe mode options). I also tried opening various Windows Setup forms for Users and Sign-in options, but couldn’t open them as a non-Administrator.
 
I then tried to Enable Safe Mode and Enable Safe Mode with networking, and was prevented from signing in because only the PIN and Fingerprint options were available, and neither worked.
 
I tried to use RDP to log in remotely, only to be told that my computer was off-line, probably because RDP doesn’t run in MSConfig Diagnostic mode.
 
My convoluted solution to this problem was to open a Command Prompt in Safe Mode, navigate to C:\Windows\System32, rename Utilman.exe to Utilman.exe.original, and copy Cmd.exe to Utilman.exe. Then, on the regular Windows login screen, I clicked on the “Ease of Access” icon on the bottom right, which opened a Cmd prompt. From there I started MSConfig. MSConfig issued a lack of sufficient resources error, but opened anyway. Surprisingly, Windows did not complain about a lack of permissions even though I wasn’t logged in. Using MSConfig I set the system back to Normal bootup, rebooted, and logged in using my PIN. I was able to rename the fake Utilman.exe to Utilman.exe.Copy of Cmd.exe. The system wouldn’t let me rename Utilman.exe.original back to Utilman.exe, but it did let me copy it. I then opened the Sign-in options in Windows Settings and turned off Require Windows Hello sign-in for Microsoft accounts.
 
As I stated in the outset, I wonder if there was an easier solution to this login issue. For example, it would be nice to know how to run MSConfig using the Safe Mode Command Prompt. I have not tried to run SFC and DISM from the Safe Mode Command Prompt after restoring all the services, but am I supposed to be able to run these two utilities in Safe Mode, and if so, I think that I need to use different parameters for DISM so it repairs the Windows image on the C: drive instead of the Safe Mode Windows on the X: drive? Another possible solution might have been to turn off the option to Require Windows Hello for sign-in using a registry hack from the Command Prompt in Safe Mode (assuming that I could run regedit, which I might not be able to as System user),
 
Also, I can’t imagine that Microsoft allows MSConfig to turn off a service that is essential to logging in, and that this service stays off even in Safe mode. Since I assume that many people use Microsoft Accounts and have turned on the option to Require Windows Hello for sign-in, they would also be stuck if they used MSConfig for a Diagnostic startup. This problem would be too common to be left unfixed, so I have to guess that there is something else in my Windows setup that caused my login problem. While I think it is unlikely, perhaps whatever caused my login problem also is causing my problem with being unable to use the context menu to run programs as an Administrator.
 
Any insights would be appreciated.

ASKER CERTIFIED SOLUTION
Gary Benjamin
Business Analyst

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 11 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 11 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros