troubleshooting Question

RDP SHADOW FAILURE: RPC SERVER NOT AVAILABLE.

Avatar of Mike Jacobs
Mike JacobsFlag for United Kingdom of Great Britain and Northern Ireland asked on
Windows 10* RDP
23 Comments1 Solution26 ViewsLast Modified:
Following McKnife's extremely helpful guidance a few months back, I had almost no problem setting up 2 machines on my LAN for RDP shadowing

Have just replaced one of those machines and although I believe I've jumped through all the same hoops I did last time, I cannot connect to the new workstation.

I can ping it by both name and ip address, but when I run qwinsta /server:[machine name]

I get

Error [1722] The RPC Servier is Unavailable.

So I searched online for what that meant and followed the guidance I found on multiple pages, all saying much the same thing.

This page is an example

Essentially, I've been through all the advice there and confirmed that my machine was already set up exactly as advised.

Furthermore, thinking it might be a problem with that specific machine (which was identical to the one it replaced), I happened to take delivery of another exact copy a couple of days ago and decided to try RDP Shadowing that one instead. Set up as advised, Results Identical.

I should add that, in order to rule out 3rd party interference or my personal preferences, I conducted these tests in the immediate post installation phase, with windows set up just as Microsoft would like. I even rebuilt the first machine twice; on the second occasion, to eliminate the possibility that it was being caused by some undocumented change within 20H2. Both the new machines arrived with that version of W10 installed, whereas the machines I setup under McKnife's guidance were both v2004. So I rebuilt it to that version. No change.

To summarise:

What I described as remarkably simple for two machines back in January has proved remarkably difficult to repeat with two identical new machines today. I should also point out that one of the two original machines is still linked and remains fully accessible, without any issues (proving that nothing significant has changed on the LAN overall or my main workstation, from which I issue the calls).

Remote Desktop Connection has been allowed

The Policy/Rule under Remote Desktop Services\Remote Desktop Session Host\Connections\Set Rules for remote control (etc) has been set to "Full Control Without Users Permission"

The Firewall shows all apt RDP Rules set to Allow and Enabled

I had changed the RDP port to 40000 but have reverted to the default 3389. (will worry about changing it again, once we get the damn thing working on defaults)

The Registry settings for RpcSs, DcomLaunch and RpcEptMapp were already set to 2 and remain so.

The relevant services (RPC Call) and RDP are running and set to Automatic.

the settings have been tried and failed in both W10 recent flavours (2004 and 20H2)

I've run out of things to check...

Suggestions?













Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 23 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 23 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros