troubleshooting Question

Direct map of SATA disk in ESX 7

Avatar of Alexandre Takacs
Alexandre TakacsFlag for Switzerland asked on
VMwareVirtualization* ESXi 7.0
6 Comments1 Solution18 ViewsLast Modified:
I'm having a weird issue with this procedure under ESX 7.0u2 to directly connect SATA drives to a VM.
I manage to present the pass-through disks following the instructions but after a few disks (I have 10 physical 2Tb SSD devices I want to pass-through to a VM) I get the dreaded "Incompatible device backing specified for device (device number)" error.
By few I mean it is a random number. I always manage to connect 2 disks but after that it is a random process... sometimes I manage more, sometimes not ! It seems to be a bug as I eventually, by keeping trying, managed to connect up to 8 disks. Once they are declared everything seems to work absolutely fine (did some pretty involved stress testing and it seems rock solid).
  • Tried SCSI or SATA controller - no difference
  • Tried to manually edit the VMX file but it does not seem to work (at all)
  • Tried to have the vmdk files in a different storage - doesn't help
What seems to work best it not to connect the drives into contiguous controller ports - say connect 0:1 then 0:5 then 0:10 etc... seems to be the best way to achieve something... I know it is more black magic than anything else but it worked !
If anyone has further comments I am most interested !
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 6 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 6 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros