Avatar of ir829
 asked on

Unable to Print from remote computer using RDC. The remote printer is listed but get error

How would you summarize the issue?
The printer shows on the remote computer but an error occurs when trying to print a test page.

After connecting to the remote computer Windows 10.  Attempting to print to the remote printer generates an error.
When did it begin and how often does it occur?
Start Early May

What errors do you see?
When attempting to print test page from printer in manager in settings.
Operation could not be completed (error 0x0000007e). The specified Module could not be found.

When attempting to print a test page from printer properties
Test page failed to print.  Would you like to view the printer troubleshooter for assistance?  The specified module could not be found.

What's the environment and are there recent changes?
There have been no recent changes.  Remote from a windows 10 computer at home via vpn into a computer in the office windows 10.  It just stopped working.

What have you tried to troubleshoot this?
Tried the troubleshooter Goes threw the processes but nothing gets fixed.
Remove printer and drivers. Reinstalled printer drivers.
sfc /scannow came up clean.
Dism /Online /Cleanup-Image /RestoreHealth came up clean
I check for a restore point but the system restore was disabled.

Remote AccessPrinters and ScannersWindows 10* RDC

Avatar of undefined
Last Comment

8/22/2022 - Mon

Missing driver?

OS on the office windows 10, changes to the GPO policy?
Compare office OS build to the OS build of your home system.

Do you have rights on the office win10 to update the drivers for your printer. Likely it is not an HP printer as those drivers are commonly included in the OS.
which printer?

Try updating your home system's printer drivers to universal ones if available.

The error might deal with the spooler. see if the Print spool service is running on the work system.

Sorry for my delayed response.
I am in the process of trying 2 computers with the same operating system build.
This happens with any printer from several different computers that I have tried.  An HP, Epson, Canon
The one thing I have noticed is that the remote driver is remote desktop easy print.  I change the group policy to disable Use Remote Desktop Easy Print printer driver first.  But the computer still uses it.
The spooler is running because I can print from the local printer.

I used the local gpedit to disable use remote desktop easy print and I get the same error.  The driver is still the remote desktop easy print.  The epson driver is the universal print driver.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.

So I was able to install my canon driver by running the install software and use it to manually adding it to the remote port.  It now loads the driver each time and prints.