troubleshooting Question

Trying to Update a different record from point of focus but always get ERR=3218 Could not update; currently locked

Avatar of Pamela Brooker
Pamela BrookerFlag for Australia asked on
Microsoft Access
5 Comments2 Solutions9 ViewsLast Modified:
[First EE question here - so hoping the below is clear enough]

Wondered why no update was happening from a rather simple update statement in my variable: vMySQL.
Printed out the contents of vMySQL and applied the same update statement directly to the database - and it worked perfectly, so there is nothing wrong with the statement
 Found the error using the below.
 db.Execute vMySQL, dbSeeChanges + dbFailOnError

Have tried repair database, turning pc off and on, various lock settings in "Tools>>Options>>Advanced Tab", putting DBEngine.Idle dbFreeLocks just before the execute statement but nothing changes. Always get this error.  

Any ideas from anyone?  Any help would be much appreciated
ASKER CERTIFIED SOLUTION
Join our community to see this answer!
Unlock 2 Answers and 5 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 2 Answers and 5 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros