Link to home
Start Free TrialLog in
Avatar of jnordeng
jnordeng

asked on

Upgraded from XenApp 7.15 CU5 to CU7 - Director Fails

Hi, upgrading from XenApp 7.15 CU5 to CU7 on my Windows 2016 Servers.  All worked fine except Director.  Director fails with error 1603.  Digging around, trying to figure out why.  I did unbind my port 443- Certificate and reset back to port 80, but that didn't help.

Thoughts?  

Thanks in advance.


Avatar of Sam Jacobs
Sam Jacobs
Flag of United States of America image

I came across this old KB article ... have you seen it?
https://support.citrix.com/article/CTX132117
Avatar of jnordeng
jnordeng

ASKER

Hello Sam.  Yes, I ran through the steps earlier, didn't make a difference.
Hello,

Please check the following link:

https://support.citrix.com/article/CTX126640

In the same way, if you can upload the log file, to review it.

Regards.
This is a broad stroke but without error logs it's hard to determine at what stage of the upgrade it is failing, would you be able to produce these, redact any information you would not like shared,

How to Troubleshoot XenApp and XenDesktop MSI Installation or Upgrade Errors (citrix.com) 
I wasn't able to run the analyzer but am getting an error code if trying to hit Director within IIS Console.  Error code is 
  • 403.18 - Cannot execute requested URL in the current application pool.

Not sure exactly what that means, but this seems to be my issue.

Thanks
I have noticed something, though ASP.Net is installed after the upgrade to Directory within IIS on the Virtual App for Director, the ASP.Net section is missing in IIS.  So my guess is needs something here and errors so removes it or corrupts it.  Also noticed the Director Apppool goes missing. So seems that this particular build is buggy. or maybe no longer needed, but found interesting.
Putting the apppool back seemed to fix it, so weird.  I can only assume that the ASP.Net section is no longer needed perhaps.  .Looking at the version text file in Director though and verified in the Director portal, seems this only repaired it back to what it was before for CU5 and didn't actually upgrade.
You didn't mentioned if your Director was on a virtualized server, but if it is I would take a snapshot at this point in time (or if you can backup the server by some other means), uninstall Director component and attempt a re-install.

Prior to re-installation I would perform aspnet_regiis -ir from Windows\Microsoft.NET\Framework64\v4.0.30319
and
Verify your .Net installation within Programs and Features (Add/Remove Programs) is version 4.5.2 (required) or higher, I usually install 4.7.2 if supported by the O/S, but I've stayed far from 4.8 using offline installer, (haven't had issues when Windows Update does it, but using the offline installer seems buggy thus far).
Director is installed on the Delivery Controller's which yes, the entire farm are VM's.  I don't have access to the VM side of things to take snapshots (Corporate does that) so looking to see other things that can be done, otherwise, it will suffice to leave Director on 3.15.5000
I attempted to update another Delivery Controller, all works well but Director.  Same deal, afterwards, had to re-add the apppool in IIS and is still considered 7.15.5000.   Here is the log:

15:14:38.5541       : XenDesktopSetup:InstallComponent: Installed component 'Studio'
15:14:38.5541 PROC  : XenDesktopSetup:InstallComponent: Exit (return True)
15:14:38.5541 PROC  : XenDesktopSetup:InstallComponent: Entry, component name = 'Director'
15:14:38.5541       : XenDesktopSetup:InstallComponent: About to install component 'Director'
15:14:38.5541       : XenDesktopSetup:VerifyCDRoot: Found MediaID file at 'E:\x64'
15:14:38.5541       : XenDesktopSetup:VerifyCDRoot: Found MediaID file at 'E:\x64'
15:14:38.5541       : XenDesktopSetup:Media found, Continuing.
15:14:38.5541       : XenDesktopSetup:CheckRegKeyExists: RegKey SOFTWARE\Citrix\Citrix Desktop Delivery Controller\NeedsUpgrading: Opened Registry Key successfully.
15:14:38.5551       : XenDesktopSetup:SetRegValue: Registry value 1 set successfully SOFTWARE\Citrix\Citrix Desktop Delivery Controller\NeedsUpgrading Director
15:14:38.5551       : XenDesktopSetup:About to install MSI File 'E:\x64\DesktopDirector\DesktopDirector.msi' using params 'INSTALLLOCATION="D:\Program Files\Citrix" ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="1" MSIRMSHUTDOWN="2" METAINSTALLER="1"' log file is 'C:\Users\username\AppData\Local\Temp\3\Citrix\XenDesktop Installer\MSI Log Files\DesktopDirector1730035762.txt'
15:14:38.5551       : XenDesktopSetup:Starting synchronous process 'msiexec' with args '/i "E:\x64\DesktopDirector\DesktopDirector.msi" /lv "C:\Users\username\AppData\Local\Temp\3\Citrix\XenDesktop Installer\MSI Log Files\DesktopDirector1730035762.txt" /quiet INSTALLLOCATION="D:\Program Files\Citrix" ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="1" MSIRMSHUTDOWN="2" METAINSTALLER="1" REBOOT=ReallySuppress'
15:15:02.2026       : XenDesktopSetup:Process completed with error code 0x00000643
15:15:02.2036 $ERR$ : XenDesktopSetup:Installation of MSI File 'DesktopDirector.msi' failed with code 'InstallFailure' (1603).
15:15:02.2086       : XenDesktopSetup:CheckRegKeyExists: RegKey Software\Citrix\MetaInstall: Opened Registry Key successfully.
15:15:02.2086       : XenDesktopSetup:AppendToMultiString: Registry value System.String[] set successfully Software\Citrix\MetaInstall FailedLogs
15:15:02.2086       : XenDesktopSetup:Starting synchronous process 'E:\x64\XenDesktop Setup\CitrixMsiLogAnalyzer.exe' with args '-msilogfile "C:\Users\username\AppData\Local\Temp\3\Citrix\XenDesktop Installer\MSI Log Files\DesktopDirector1730035762.txt" -mode 1 -sessionid 50ec14bf-71a4-4b91-90d4-9507751bd2fe'
15:15:04.9758       : XenDesktopSetup:Process completed with error code 0x00000000
15:15:04.9758       : XenDesktopSetup:CheckRegKeyExists: RegKey Software\Citrix\MetaInstall: Opened Registry Key successfully.
15:15:04.9769       : XenDesktopSetup:AppendToMultiString: Registry value System.String[] set successfully Software\Citrix\MetaInstall FailedLogs
15:15:04.9978 $ERR$ : XenDesktopSetup:Citrix Director failed to install, with internal error code -2147024894, failing action was "WriteIIS7ConfigChanges", on operation "WriteIIS7ConfigChanges".
15:15:04.9978 $ERR$ : XenDesktopSetup:
Recommended Resolution: https://support.citrix.com/article/CTX226932?CitrixMSILogAnalyzer
15:15:04.9988 $ERR$ : XenDesktopSetup:InstallComponent: Failed to install component 'Director'. Installation of MSI File 'DesktopDirector.msi' failed with code 'InstallFailure' (1603).
15:15:04.9998 $ERR$ : XenDesktopSetup:Recording installation failure. Installation of the Director failed with error code 1603. Log Path: C:\Users\username\AppData\Local\Temp\3\Citrix\XenDesktop Installer\MSI Log Files\DesktopDirector1730035762.txt
15:15:04.9998 PROC  : XenDesktopSetup:InstallComponent: Exit
15:15:04.9998       : XenDesktopSetup:Install tasks for this session have finished.
15:15:04.9998       : XenDesktopSetup:Installation failed
15:15:05.0008       : XenDesktopSetup:InstallationManager returned FailureAndRebootNeeded
15:15:05.1619       : XenDesktopSetup:Found installed MSI product upgrade code'{76A0BDF3-8A8E-47D2-8E42-B2BF255CFCC8}', product code {51BF7950-7DC1-4B03-BC34-BFEAD28200C4}, version '3.16.0'
15:15:05.2049       : XenDesktopSetup:Windows Service CitrixTelemetryService is not  running.
15:15:10.2798       : XenDesktopSetup:MetaInstaller terminating
What type of account do you use for installation eg. Local or Domain. Do you runas Administrator, is the account at minimum a local administrator on the intended server?
I'm a domain admin, so haven't run as anything by my own user account.
Common misconception, though I would find it odd since it already installed most other things, IIS is tricky sometimes though with regards to permissions (I suspect this may be the issue), I always for enterprise level software, runas Administrator, unless the software suite specifically states otherwise.
Thanks for your input, but for some reason this tool doesn't allow me to elevate to run as administrator.  I simply have the option to install, repair or uninstall.

Thanks
Your installing director from the MSI file and not through the XenDesktop and XenApp installation wizard?
I tried that since it failed through the wizard.
ASKER CERTIFIED SOLUTION
Avatar of jnordeng
jnordeng

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial