Avatar of Dan
DanFlag for United States of America

asked on 

iphone email client keeps asking for my exchange credentials every few days

I am using Chuck iphone email client.  I have configured my exchange email account with the app.  I use exchange 2019, I was using exchange 2016 and upgraded 4 months ago.
Ever since I upgraded exchange from 2016 to 2019, the app now keeps on prompting me to log in again, to enter the user/pass and the smtp/imap info every few days.  It's so frustrating.
My gmail and other email accounts are fine, they are not prompting me to log in again.

Is there a  config setting in exchange that is doing this?  I have emailed chuck email support on 2 separate occasions, and they said there is nothing they can do, that it's nothing on their end doing this.
The exact error message is "invalid credentials, can't connect to mail.mydomain.com"

Does anyone know if there's some setting in exchange causing this to happen?

Any help is greatly appreciated.  
iOSEmail ClientsExchangeiPhoneApple Hardware

Avatar of undefined
Last Comment
Dan
Avatar of Saif Shaikh
Saif Shaikh
Flag of India image

Is it only happening to your Iphone or all users?

Is this issue reproducible on another IPhone"

Was there any software updates?

Remove all active sync profiles from the affected Iphone and configure a fresh profile with exchange account first and then gmail or any other.

Follow instructions in below article and see if this helps.

https://www.imobie.com/support/iphone-ipad-keeps-asking-for-password.htm


Avatar of Ian Pattison
Ian Pattison
Flag of United Kingdom of Great Britain and Northern Ireland image

So… since you upgraded this happens.

Did you forget to configure your internal and external URIs correctly, especially for autodiscover? Do these have a matching certificate?
Avatar of Dan
Dan
Flag of United States of America image

ASKER

Ian - it seems that everything is working fine, no complaints besides this email iphone issue.
In looking at my URI's, send/receive connectors, everything seems to be fine.

So the built in apple mail app works fine, outlook iphone app works fine, no other email client prompts me for to log into the mail app, except chuck.  When I talked to them, they said they are very secure, so I don't know if it's their app or if I have an issue somewhere?

I did notice that when I do the test-outlookwebservices, I get a failure for the audodiscover.
I worked with a consultant, but he couldn't fix this issue.  Not sure if this is related, but maybe?


User generated image
Avatar of Dan
Dan
Flag of United States of America image

ASKER

Saif -
Is it only happening to your Iphone or all users?   - I'm the only one that is using this app.  I have asked two of my coworkers to download and install the app, so starting today, If they get the same issue, I will find out.

Is this issue reproducible on another IPhone"  -  Not sure yet, I will find out, as I have asked 2 of my coworkers to install the app and test for me.

Was there any software updates?  I also install software updates on my exchange, and on my iphone as well.  This was happening on the prior IOS version of iphone and currently on the newest version as well.

Remove all active sync profiles from the affected Iphone and configure a fresh profile with exchange account first and then gmail or any other.  - Yes, I tried that, I delete the app altogether and tried that, same issue.

Follow instructions in below article and see if this helps. - I will try to follow the instructions below.

https://www.imobie.com/support/iphone-ipad-keeps-asking-for-password.htm 
Avatar of Dan
Dan
Flag of United States of America image

ASKER

Saif - that article was for apple ID, and by the way, I did most of those recommendations, the first 3 for sure.
 I didn't reset my apple ID since I know what is.
Avatar of Dan
Dan
Flag of United States of America image

ASKER

This is funny, I tried to add a calendar invite to my calendar, but I got this error message.
Maybe there is a problem, but not sure to identify the issue.

User generated image
SOLUTION
Avatar of Jackie Man
Jackie Man
Flag of Hong Kong image

Blurred text
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Avatar of Dan
Dan
Flag of United States of America image

ASKER

Hello Jackie Man,

That sounds like the problem.  I've sent Chuck support numerous emails, but they didn't help me.

So is there a way to configure Exchange 2019 to allow more streams, to increase the threashold?
Or even is there  away to disable the lock feature?
ASKER CERTIFIED SOLUTION
Avatar of Ian Pattison
Ian Pattison
Flag of United Kingdom of Great Britain and Northern Ireland image

Blurred text
THIS SOLUTION IS ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
Avatar of Dan
Dan
Flag of United States of America image

ASKER

I made the change yesterday, added a new throttling policy with some unlimited settings.  Applied it to my profile and now I'm just waiting and testing the app to see if it still occurs again.

I'll know within a few days if it's going to work or not, so I'll update everyone as soon as I know.
Avatar of Jackie Man
Jackie Man
Flag of Hong Kong image

Any update?
Avatar of Dan
Dan
Flag of United States of America image

ASKER

it still failed on the 5th day. so on the 5th day it prompted me to reconnect, so it seemed like it helped a little as it was asking to re-enter credentials after 24 hours, I'll see how long I can go on the second stretch until it prompts me again.
Avatar of Jackie Man
Jackie Man
Flag of Hong Kong image

Any update?
Avatar of Dan
Dan
Flag of United States of America image

ASKER

Since then, so the last 7 days, it's been fine, it has not prompted me.    So that's interesting, Since I setup the account, it only prompted me once in the last 12-13 days or so.  All my other accounts, hotmail, gmail, etc... they have not prompted me at all.   But before changing the paramaters, as mentioned above, it was prompting me literally every 1-2 days.

Avatar of Ian Pattison
Ian Pattison
Flag of United Kingdom of Great Britain and Northern Ireland image

That definitely sounds like the mail client is using too many connections to your exchange server.

This also regularly happens if a user has lots of different email accounts linked to outlook, and the client throttling settings are the way to solve it.

If it prompts you again, it may be worth having a dive into the exchange logs to see if you can find a specific setting that is tripping out.

Good you’re making progress though :-)
Avatar of Dan
Dan
Flag of United States of America image

ASKER

Yes, it was the throttling!!!
Avatar of Dan
Dan
Flag of United States of America image

ASKER

I discovered a problem since I made those changes, so I'm able to receive email, but I can't send any emails from my domain account using chuck.  if I go to OWA, log in or from my desktop, I can email just fine.
In the app, chuch, I can send from gmail and all my other email clients.

I have relogged in, but still can't send emails, and there's no error messages, very strange.

Any thoughts why?
Avatar of Jackie Man
Jackie Man
Flag of Hong Kong image

The major feature of Chuck app is to mass delete the emails on your mailbox, i.e. receive emails and not to send emails.

It is an apple to orange comparison if you want to compare Exchange 2019 and free GMail service.

Besides, Chuck is using a proxy server to connect to Exchange 2019 and it is common sense to me Exchange 2019 will NOT allow you to initialize a send mail command from a proxy server instead of an email client app. The only exception for sending emails via a proxy server is the use case of anti-spam proxy to filter spam emails before the emails are actually sent.
Avatar of Dan
Dan
Flag of United States of America image

ASKER

Well, but when I first added the account, it worked fine, I was able to send emails.
Avatar of Dan
Dan
Flag of United States of America image

ASKER

I sent an email to their support, but they don't do anything, they always blame the issue on the customers side.
Avatar of Jackie Man
Jackie Man
Flag of Hong Kong image

You can do the test below.

Remove the Chuck app and setup the Exchange mailbox on reinstall of Chuck app.

You should be able to send emails before you sync the Exchange mailbox.
Avatar of Dan
Dan
Flag of United States of America image

ASKER

I deleted my exchange account in Chuck, readded it and still does not work.
I don't really want to delete the chuch app, as I have 5 acocunts and I would have to manually add them back.

I will use the built in apple mail app and see if I can send from there.
Exchange
Exchange

Exchange is the server side of a collaborative application product that is part of the Microsoft Server infrastructure. Exchange's major features include email, calendaring, contacts and tasks, support for mobile and web-based access to information, and support for data storage.

213K
Questions
--
Followers
--
Top Experts
Get a personalized solution from industry experts
Ask the experts
Read over 600 more reviews

TRUSTED BY

IBM logoIntel logoMicrosoft logoUbisoft logoSAP logo
Qualcomm logoCitrix Systems logoWorkday logoErnst & Young logo
High performer badgeUsers love us badge
LinkedIn logoFacebook logoX logoInstagram logoTikTok logoYouTube logo