Link to home
Start Free TrialLog in
Avatar of K A
K AFlag for United States of America

asked on

New Linksys EA6350: Internet keeps disconnecting about every 3 minutes

Short Version:  Would an incorrect MTU setting cause very frequent internet disconnects?  (Almost certainly so, yes?)

Longer Version:  We're replacing an old Linksys E1200 wireless router with a newer Linksys EA6350 (AC1200+) router.  It has the latest firmware.  This is at a remote location.

Before shipping it out, we configured all the settings the same as the old Linksys, then shipped it.  The end-user connected it, and it worked beautifully... for about 15 minutes.  Then it started losing internet connectivity about every two or three minutes.  It would connect, then disconnect repeatedly.

Its MTU was set to Automatic, so thinking that was the culprit, I set it to 1492 and restarted the router.  From that point on, the disconnections slowed way down... but then I was unable to view the "Connectivity" and "Troubleshooting" screens... they were just blank.  In any event, at that point we reset the router to factory defaults, after which I was unable to connect remotely at all.  So we reinstalled the old router and it's working smoothly (but at 100Mbps) speeds.  The old router, now in place, has MTU set to Auto.

Here are the results of various ping tests with the old old router in place:
ping www.yahoo.com :  4 good replies
ping www.yahoo.com -f -l 1500 : Packet needs to be fragmented but DF set.
ping www.yahoo.com -f -l 1492 : Packet needs to be fragmented but DF set.
ping www.yahoo.com -f -l 1473 : Packet needs to be fragmented but DF set.
ping www.yahoo.com -f -l 1472 : 4 good replies

Frankly, I think me setting the MTU to 1492 on the new router is what messed us up.  But why didn't "Auto" work well?

I know there are all kinds a caveats, but would this imply I should set the router MTU to 1472, or add 28 and set it to 1500?  (But that would seem to contradict the 1500 ping test...?)

Thank you - 
ASKER CERTIFIED SOLUTION
Avatar of Dr. Klahn
Dr. Klahn

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Who is the ISP or what type of internet?

DSL using PPPoE requires the MTU be 1492.  Auto should still handle this.  The MTU of the WAN has nothing to do with the MTU of the LAN.  I have only seen this happen once on DSL after upgrading a router (Centurylink > Centurytel at the time) and the same problem you describe.  Lowering the MTU while troubleshooting with their tech support found a fairly stable connection.  But the end result was Centurylink having the repair the line.  After that 1492 had to be set in the Linksys router (Not auto > Per Linksys tech support solution) for it to work.
Avatar of K A

ASKER

Apologies for the delay in responding to your comments.  Thank you very much for your tips and advice.
Avatar of K A

ASKER

All good.  Thanks both.