Link to home
Start Free TrialLog in
Avatar of Dan
DanFlag for United States of America

asked on

can't print using Big Sur

I have 2 MACs that upgraded to big sur and now both are getting the error "hold for authentication" when printing to different printers.

All my printers are installed on a windows print server.   So far, I tested a mac laptop with Mojave with two different printers and it prints fine.

Is this a known bug with big sur, or is there an easy fix I can do?

I went through multiple articles online, and nothing fixed it.   Any suggestions?
Avatar of Jazz Marie Kaur
Jazz Marie Kaur
Flag of United States of America image

Hi Dan,

I have seen it happen quite a bit for Mac OS X workstations in general no matter the version of the OS.

  • What have you tried thus far? You don't have to list it, but curious and it may help other Certified Expert's isolate it or not suggest the same repeated steps taken already.
  • Did these users change their passwords recently? 
  • Usually even if it prompted most of the time I ran into that I was able to refresh spin icon from the print queue job and re-enter the credentials of the user and have it remember the login via the checkbox - a lot of employees would forget it.
  • I recall we had this a lot at the walkup TechBar with Mac's, it was primarily an issue with their password not syncing properly or an issue pertaining to keychain entries or keychain problems. We had to remove the keychain entry tied to the printer I believe or ensure there were not duplicate entries if I recall, but the name was odd under the keychain and you can usually search a keyword such as print.
  • Sometimes I believe user keychains were completely broken or damaged as well, we had to setup a fresh user profile once. 
  • They were super sensitive to their drivers overall.
  • At times Mac's had trouble communicating with printers and we had to remove and rejoin them back to the domain if I recall. We also had to try removing and re-adding the printers.
  • Are you using PaperCut in the environment, that's what we used at a past workplace but the interface and perhaps, PaperCut now has a KB with some new tips I myself was unaware of:pertaining the force acceptance of authentication:
Did you try to remove the printer and then add it again? You would need to enter (Windows) credentials when adding the printer.

Go to System Preferences, select one of the printers, remove it by clicking the minus sign below the printer list. Then use the plus sign to add the printer again.
Avatar of Dan


Gerwin, tried that, didn't work.

Avatar of Dan
Flag of United States of America image

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Glad I could help! :) Keychains always act up now and then. Interesting about them not being on domain-based accounts. Thanks for sharing!
​>> didn't work.
Ok thanks for the feedback. Good to hear it’s working again.