Avatar of jkirman
jkirmanFlag for United States of America asked on

Getting Outlook 2010 error 0x8004010F object cannot be found when updating OAB on Exchange 2013

Greetings.

This started showing up earlier today.  Looks like I'm having issues with the Exchange 2013 OAB,  I needed to change the name and email address for a user on the Exchange 2013 server.  Used the EAC, renamed the user, and added a new default email address.  Simple enough, done it many time before.  Connected to an Outlook 2010 client machine, loaded Outlook, hit F9 to update the OAB, and got the following error:

  Task 'user@domain' reported error 0x8004010F  the operation failed.  An object cannot be found

I figured I needed to rebuild the OAB on the server, so I went into Powershell on the server, and ran the following command:

[PS]>  update-offlineaddressbook -identity "Default Offline address book"

Per another doc I was referring to, I also ran the GAL update, as per the following command:

[PS]>  Update-GlobalAddressList -Identity "Default Global Address List"

I received no errors after running the above commands.  Went back to the PC w/Outlook 2010, reran the F9 to update the OAB, still got the same error 0x8004010F  

Note that when I remove cached mode for Outlook on that PC and run it in online mode it works, and I can see the latest updates to the GAL.

Went to another PC and looked at the contents of the folder:

 c:\users\%userprofile%\appdata\local\microsoft\outlook\Offline Address Books

The files were all dated 2/21/2021 (!)

I closed Outlook on the 2nd PC, renamed the Offline Address Books folder, restarted Outlook, and then ran F9.  Nothing happened, so I looked at the newly created Offline Address Books folder, and it was blank.  I then clicked on File / Account Settings in Outlook, selected Download Address Book,and ultimately received the same error 0x8004010F.

I checked on a 2nd PC on the same network, and saw that the files in the Offline Address Books folder were also dated 2/21/201.

So apparently this OAB issue has been going on for a while.  In hindsight, there have been no personnel changes at this client for a while, so the situation to add/change users didn't come up until now, which brought the issue into view.

If I can't immediately resolve the OAB update issue, 2 temporary workarounds (I think) for this are either:

a) run Outlook in pure online mode (not preferred, as it makes the server labor more)

  OR

b) close Outlook on all PC's, rename the Offline Address Books folder, restart Outlook, and have Outlook go directly off the GAL while remaining in cached mode for all other operations.

There are a total of 12 PC's on the network, so the prospect of working directly off the server for online mode and/or direct GAL access should not bring on performance issues.

Any thoughts on how to resolve the error 0x8004010F.?  It seems that the OAB can't properly rebuild on the server through the usual means.

Thanks in advance for your assistance.

jkirman

Exchange* OABOutlook

Avatar of undefined
Last Comment
jkirman

8/22/2022 - Mon
Seth Simmons

make sure your autodiscover URLs are configured correctly; that is usually the biggest reason for that error code when downloading the address book

Configure External and Internal URL in Exchange 2013

https://www.mustbegeek.com/configure-external-and-internal-url-in-exchange-2013/
ASKER
jkirman


thanks Seth the autodiscover internal URL for the OAB virtual directory is set to:

   https://exchangeserver.domain.com/OAB

I just ran an autodiscover test from Outlook, and it found the server OK.

On a different note, I checked the contents of the physical OAB folder on the server, which is:

  E:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\OAB

I am wondering if the contents of this folder would reveal anything, as I see the following files (summarized):

a)     oab.xml dated 8/18/2021 8:45 pm, which I believe is the last time I ran the command

   "update-offlineaddressbook -identity "Default Offline Address Book"

b)  c. 70 files with names similar to:
 
     254df77d-8a27-45bb-a36e-e745c9eef118-mac8411-29.lzx

c) c. 50 files with names similar to:

    254df77d-8a27-45bb-a36e-e745c9eef118-lng8411-29.lzx

d) 2 files with names similar to:

    254df77d-8a27-45bb-a36e-e745c9eef118-data-29.lzx

e) 254df77d-8a27-45bb-a36e-e745c9eef118-binpatch-29.lzx

The above files are all dated 8/18/21 and 6:09 pm, except for the oab.xml file.  I believe 6:09 pm is the first time I ran the command

      "update-offlineaddressbook -identity "Default Offline Address Book"

though I can't be sure on the timing.

thanks.

Seth Simmons

any errors with this test?

https://testconnectivity.microsoft.com/
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ASKER
jkirman

Seth,

I ran the connectivity analyzer for Outlook to connect to Exchange.  It passed all tests until it came to the one that said:

  Attempting to ping RPC proxy web1.domain.com.
RPC Proxy can't be pinged.

FYI web1.domain.com (I'm of course masking the real domain) is both the internal and the external DNS name for the Exchange 2013 server.  The company website is e.g. www.domain.com.  OWA users use web1.domain,com in their URL e.g. https://web1.domain.com/owa to access the server when outside the office, and iphone users use the same URL when inside the office and communicating to the server via local wifi.  I set up the internal DNS so that we can use the same URL for accessing the server internally as well as externally.

 The actual server AD DNS name is something like exchange1.ADnetworkdomain.com.

For the Connectivity analyzer, I used web1.domain.com. for both the name of the Exchange server and the name of the RPC Proxy server in the Connectivity analyzer.

Here is the full output log (with actual names scrubbed):

Testing Outlook connectivity.
The Outlook connectivity test failed.
Collapse
Test Steps

Testing RPC over HTTP connectivity to server web1.domain.com
RPC over HTTP connectivity failed.
Collapse
Test Steps

Attempting to resolve the host name web1.domain.com in DNS.
The host name resolved successfully.
Additional Details

Testing TCP port 443 on host web1.domain z.com to ensure it's listening and open.
The port was opened successfully.

Testing the SSL certificate to make sure it's valid.
The certificate passed all validation requirements.
Test Steps

Checking the IIS configuration for client certificate authentication.
Client certificate authentication wasn't detected.
Expand
Additional Details

Testing HTTP Authentication Methods for URL https://web1.domain.com/rpc/rpcproxy.dll?web1.domain.com:6002.
The HTTP authentication methods are correct.
Expand
Additional Details

Attempting to ping RPC proxy web1.domain .com.
RPC Proxy can't be pinged.
Additional Details
An unexpected network-level exception was encountered. Exception details:
Message: The remote server returned an error: (404) Not Found.
Type: Microsoft.Exchange.Tools.ExRca.Extensions.MapiTransportException
Stack trace:
at Microsoft.Exchange.Tools.ExRca.Extensions.MapiRpcTestClient.PingProtocolProxy(String endpointIdentifier)
at Microsoft.M365.RCA.ConnectivityTests.MapiPingProxyTest.PerformTestReally() in d:\dbs\sh\nibr\0816_143552_0\cmd\5\sources\dev\m365rca\src\connectivitytests\Mapi\MapiPingProxyTest.cs:line 60
Exception details:
Message: The remote server returned an error: (404) Not Found.
Type: System.Net.WebException
Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at RpcPingLib.RpcPing.PingProxy(String internalServerFqdn, String endpoint)
at Microsoft.Exchange.Tools.ExRca.Extensions.MapiRpcTestClient.PingProtocolProxy(String endpointIdentifier)

Strange regarding the error that it couldn't ping the RPC server.  When I go to a command prompt on the PC and run the command

   ping web1.domain.com

it comes back as successful, i.e. Ping'g web1.domain.com,

Reply from 192.168.1.1, bytes = 32, time = 1 ms, TTL = 128
Reply from 192.168.1.1, bytes = 32, time = 1 ms, TTL = 128
Reply from 192.168.1.1, bytes = 32, time = 1 ms, TTL = 128

Other than that, the connectivity test seems to have come through as OK.

Any thoughts on why the RPC ping failed?

Thanks.

ASKER CERTIFIED SOLUTION
M A

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
jkirman

Thank you MAS.  Apologies for the delay in responding.  Will test out your suggestions tonight or tomorrow.  For the moment, I used a very basic workaround of renaming the local Offline Address Books folder under the Appdata\Local\Microsoft\Outlook folder, and all Outlook sessions are accessing the GAL directly.


M A

Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
jkirman

MAS,

I think I found the issue, thanks to one of your articles, which referenced certificates as a potential cause of the problem. Looks like I'm guilty of improper housekeeping, as in checking the certificates for the server, I see that have an expired certificate still listed in the EAC associated with the IIS, SMTP, POP and IMAP services.  The new cert went into effect around the same time as the OAB stopped updating, so it makes sense that the 2 events are linked.  Although it's probably a no-brainer to remove the expired cert and then restart IIS, sheer paranoia tells me that I'd rather remove the old cert and then restart IIS during the weekend, e.g. Sat night c. 10 pm when no one is using the system.  Will remove the cert and then let you know if that solves the issue.

Thanks

M A

Glad to know you sorted out and my comments helped you.
Cheers :))
MAS
ASKER
jkirman

MAS.

Unfortunately removing the old expired certificates via the EAC did not address the issue.  I initially ran IISRESET after removing the certificates and tested that out in Outlook, but the error persisted when trying to download the OAB.  I then rebooted the server to see if that would do the trick, but no luck there as well.  So I will continue to review the articles you provided over the next few days and will keep you posted on results.

Thanks.

Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy