Avatar of Ted Fines
Ted FinesFlag for Vanuatu

asked on 

Outlook won't properly connect to Exchange, while OWA works fine.

Having trouble with an account using Outlook 2013 connected to Our Exchange 2016 server.

I can logon to the account from a workstation, to an RDP server, and using OWA.  All normal, no issues.

But I can't logon using Outlook (2013).

Outlook prompts for a password but won't accept the password.  In the LR corner of Outlook it shows "NEED PASSWORD".  The account did work previously, is years old.

I've tried logging on from Outlook from 3 different computers, so it isn't a problem with the Outlook install.

Ctrl+Right-Click on Outlook icon in taskbar, and checked "Connection Status" and "Test Email Autoconfiguration" and both came back all successful.

I tried creating new profiles which didn't help then deleted the account completely and recreated it via ECP on the Exchange server.  

Same problem.  Also, new email appears in the inbox, and I get the taskbar notifications when new mail arrives.  So it is actually connected to some extent, yet it keeps asking for a password and shows "NEED PASSWORD" in Outlook.  There are messages in the Outbox that won't go, so that part of the connection isn't working.

The Exchange server, DC and workstation all have correct time and are in sync.

Please advise, Thank you.


Avatar of undefined
Last Comment
Jazz Marie Kaur
Avatar of Jazz Marie Kaur
Jazz Marie Kaur
Flag of United States of America image

Hi Ted,

See my below EE troubleshooting article. In the past when that happened it was due to the version of Office or Credential Manager, please take some time to go through the tips and hopefully it helps. You may want to also try Microsoft's diagnostic tool. Once with 365 we had users try swapping computers and it followed but once we changed the version\build install they were on it was fine. We have seen odd issues also with OS updates on EE and Outlook password's unsure if you're on the latest across those stations.

Avatar of Ted Fines
Ted Fines
Flag of Vanuatu image


I already did the 'LAST resort' option in section 3, as I deleted and re-created the account completely.  That would have cleared anything in credential manager, cache, profile, etc.  I'll try updating office, and if that doesn't work I'll try an office scrub/reinstall, then after that a new version of office entirely.

But it seems to me this problem is more likely on the server side.

Avatar of Ted Fines
Ted Fines
Flag of Vanuatu image

Blurred text
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Glad to hear you got it working! Sometimes another issue for other EE members has been modern authentication hiccups but I  never had to resort to upgrades or registry modifications to address the message so the article covers the most common causes and methods to troubleshoot. The needs password message is notorious for returning and being difficult to suppress and isolate in general. That may be a definitely good tip for others in our community also to leverage, I'll keep that in mind if I see more community members bring it up as a solution for 2013 or others versions thank you for sharing what resolved it and glad its stopped.

Exchange is the server side of a collaborative application product that is part of the Microsoft Server infrastructure. Exchange's major features include email, calendaring, contacts and tasks, support for mobile and web-based access to information, and support for data storage.

Top Experts
Get a personalized solution from industry experts
Ask the experts
Read over 600 more reviews


IBM logoIntel logoMicrosoft logoUbisoft logoSAP logo
Qualcomm logoCitrix Systems logoWorkday logoErnst & Young logo
High performer badgeUsers love us badge
LinkedIn logoFacebook logoX logoInstagram logoTikTok logoYouTube logo