Link to home
Create AccountLog in
Avatar of Mark
MarkFlag for United States of America

asked on

Having issues mapping a drive only on one device.

Windows 2016 server attempting to map drives to another server. We use logon scripts to map drives and the creds are in the script. I have two mapped drives that go to a hosted server over a VPN these drives will not map, I get a system error 86 The specified network password is not correct.. When the same script runs on any other workstation or server the drives map.. I have tried to manually map the drive on the problem server and it wont map, I can manually map on different workstations and servers. When I'm testing this it does lock the user account I'm using to map the drive on the remote server. I have logged onto the server with a different account and tried to map the drives and I get the same error so it doesn't appear to be user specific. I have dumped all the creds from the credential manager it didn't make a difference and I didn't see the account in question in there anyways.. I have tried to manually map the drive on the server using a different letter for the drive it still wouldn't map..  Any ideas? 

Avatar of arnold
arnold
Flag of United States of America image

Was the drive mapped successfully previously?
Check stale sessions on the server where the share is.
Presumably, if you try to map the same resource byIP the mapping shoukd succeed.
Avatar of Hello There
Hello There

If they are not in the same domain (for instance the server is in a workgroup and tries to connect to a domain server or vice versa), verify you use the correct for of the username (domain\username or computername\username)
Avatar of Mark

ASKER

arnold- yes they have mapped previously in the past but it appears to have broken several months ago, I actually map this drive via IP\share. What are you referring to as "Stale sessions"?

Hello- They are not on the same domain, when I use the scripts on other devices it maps and the creds are in the map drive bat, I also manually mapped the drives on a different server and workstation with no issues and I was unable to on the server in question.  
A stale session is when the server reflects a connection to the share for a user, but the connection on the workstation and the user is non existent including post workstation restart.

The user on workstation initiates mapping, the server does not complete the mapping because according to the share sessions, a connection is already present.

Look on the server when the user/computer is off and close the session if present.

Note: IP\sharename is different from servername\sharename


Much depends on whether you can reboot the server or go through share session and close connections for this user.
Avatar of Mark

ASKER

Ok that is a tough one because I cant shut down the server during the day and the server is hosted by a provider. 
Check the session of shares look at duration and idle. Especially for the user having this issue.

Clear the share session on the server.

Using the command window
Net use x: \\ip\sharename /user:.....

Could help.identify the issue based on the error
Avatar of Mark

ASKER

I have tested with multiple users on the server to map that drive both by script and by manually adding a mapped drive and I cant get it to map with any users I have tested on the server.
I can however logon to a different device with the users that failed to map on the server and the drives map with no issues.

The error I get is a password fail and it does lock out the account  on the remote server. It makes no sense the domain accounts I'm using use the same logon script regardless of which device I logon to.  
Check the user's keymgr.dll
Saved credentials control panel...

Control keymgr.dll the user may have stored older credentials that are being submitted.

Using the command line on the system in question

To map the drive

net use x: \\ip\sharename /user:username@domain and see if the mapping succeeds after the password is provided.
Avatar of Mark

ASKER

I have removed the saved creds in users profile in control panel previously and that didn't make a difference. Is there anything else you know that I can try as far as the keymgr.dll.. 
Need the error code when you map the drive.

if you try from the command window, and provide the correct username@domain and password. ...


on the server the servername or domain is implied.
when you are on a system connecting to another remote system, the credentials to login into the local system is relayed to the remote
local system workstationA username password
when accessing the remote serverA
the credentials that get passed are workstationsA\username password.
one thing to make sure what systemname\username or addomain\username and password needs to be used.
Similarly situated users have no issues, just this user has an issue.

You're the only one that can determine why any other user on this system is not having an issue, and this user on any other system is not having an issue....

determining the cause if one option, the other is to get users to switch workstations...
ASKER CERTIFIED SOLUTION
Avatar of Mark
Mark
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account