Link to home
Start Free TrialLog in
Avatar of Jeff Shanahan
Jeff Shanahan

asked on

Any ideas on why Enterprise Chrome policies are not being applied even though it shows that they were?

Have been trying to deploy Enterprise Chrome computer policy via GPO. I went through their deployment guide to make this happen. Our DC is a 2012r2 server and workstations are windows 10. The following is what I have done so far based on their guide.

1. Download the Chrome Enterprise Bundle.

2. Create a share on the server for the Chrome msi install package

3. Applied the Google Chrome ADMX templates.

3. Create a Test OU in AD.

4. Identify a clean PC to test. Un-install Chrome.

5. Place the test pc in the test OU.

6. Create a Chrome GPO. Modified some preferences. Applied the Chrome install package.

7. Place the GPO in the test container.

8. Run gpupdate /force on the the test PC.

9. Saw that Chrome was installed after reboot.

10. In Chrome, run chrome//:policy. Saw that policies were applied.

11. One policy was to add a startup page other than the default page.

12. Another policy was to make Chrome the default browser.

13. There were another two or three just for testing purposes.

14. The problem is that although policies were applied, the actual policies did not activate (ex..the home page was still the default). This was true with the other policies.

15. Had un-installed Chrome and started over. No luck.

16. Had suspected it was the version of windows 10. On the initial test, it was 20H2. I ran an update as well as a feature update to 21H1 to no avail.


Avatar of Michael Pfister
Michael Pfister
Flag of Germany image

Just a guess: mix between user and computer policies? If you have user policies you'll have to move the user object in AD to the test OU as well.
Avatar of Jeff Shanahan
Jeff Shanahan

ASKER

Thanks Scott!

Michael,
No. Its just a machine policy. Although, I did try to use a user policy as well and that didn't work either. Today, I did a wipe and reload of W10 on the PC. This time, it seems a few of the policy settings from the Chrome GPO worked. The setting to show the bookmark bar and home page (other than google.com) do not work.
User generated image
Don't know how to help here. From the screenshot it looks the machine GPO gets applied but Chrome simply ignores it.
You could check this again by running a Resultant Set of Policy (RSoP) report remotely via GPMC to the test PC/test user and veriify the GPO settings get applied to it and if there are other policies interfering..

Back to our list:
3. Applied the Google Chrome ADMX templates.

So you copied the ADMX files to  \\YOURDOMAIN\SYSVOL\<domain_fqdn>\Policies\PolicyDefinitions and the ADML files to their corresponfing language subfolders? They replicated fine to the other DCs in your domain?
Michael,
Yes. I copied the files as instructed in the guide. So I figured out the home page issue. It was a setting I overlooked...'URLs to open on startup'. I've also tested a few of the policies that were applied and they worked as well. The only setting that I need to figure out is getting Chrome to be the default browser and having the bookmark bar to show automatically. That part I can tackle on my own. Other than that, I think I'm good. So, this issue can be closed.
ASKER CERTIFIED SOLUTION
Avatar of Jeff Shanahan
Jeff Shanahan

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial