troubleshooting Question

Windows Server 2016 Refuses To Take Any Cumulative Updates But Takes All Other Updates Fine

Avatar of squimby
squimby asked on
Windows OSWindows 10AzureWindows Server 2016
25 Comments1 Solution47 ViewsLast Modified:

I have a server that was a clean build in May of 2021.  It is server 2016 1607 running SQL 2016.  This server refuses to do *any* Microsoft Cumulative Updates.   It will do *any* other relevant Microsoft Update to this box via Windows Update without issue.   Each month the same pattern repeats on the next cumulative update.


It says it is needed.  It downloads.  It installs.  It reboots and somewhere in the boot cycle during the blue pre-desktop load when the update is working it just decides without error to return to the desktop and say that it couldn't be installed.   


I have no errors that I can find.  It just does the update, says it is done and rebooting, and then goes into that in-between state and comes out without visible errors and returns to Windows without explanation.   Everything else that either proceeded or was after it on the update list goes absolutely fine whether it needs reboots or not.   Going through May, June, July, and August it is pretty obvious that this cumulative update unable to install is a pattern and not a one-off event.   I have tried disabling SentinelOne and that did nothing.  The machine is clean of any viruses per Windows Defender/SCCM Endpoint and SentinelOne.   I have disabled all unnecessary services.  I have run a SFC/SCANNOW and it runs clean.  I have run a DISM /ONLINE /CLEANUP-IMAGE /SCANHEALTH and it runs clean.   I have blown up and re-installed Windows Update including clearing out the software database and that does nothing.   I have tried downloading cumulative updates from the Microsoft Catalog and manually applying them for a couple of months and that does nothing.  


Everything is fine except this server can't take a cumulative update.   Due to the nature of this server taking it off-line for an extended period of time is painful.  However, I am about to try an in-place upgrade to 2019 and then a clean build migration if I can't come up with what the issue is.


Any ideas as to what is going on?


Thanks so much!

ASKER CERTIFIED SOLUTION
Join our community to see this answer!
Unlock 1 Answer and 25 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 25 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros