Avatar of WellingtonIS
WellingtonIS asked on

FTP Error

I have an FTP server.  I can't seem to suddenly connect even though the user has full control this is my error:

Command:    USER corp\Wrmreproute
Response:    331 Password required
Command:    PASS ***********
Response:    530 User cannot log in, home directory inaccessible.
Error:    Critical error: Could not connect to server

FTP

Avatar of undefined
Last Comment
WellingtonIS

8/22/2022 - Mon
David Johnson, CD

many possible reasons
this article covers the majority https://techcommunity.microsoft.com/t5/iis-support-blog/ftp-530-user-cannot-log-in-error-and-solution/ba-p/364570


I don't use IIS FTP but Filezilla FTP Server instead.
Dr. Klahn

Check to see that the FTP server is running with administrative credentials.  If this is not the case, then the server cannot override file protection to get at user home directories.  "home directory inaccessible" then becomes a possibility.
David Johnson, CD

Note: the User Home Directory is the FTP User Home Directory and not the c:\users\username directory.
 530 User cannot log in, home directory inaccessible.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Craig Beck

Check the permissions on the folder that is set as the user's home directory.
David Favor

Error seems clear.

Something has changed on the server side.

Permissions... User deleted... something...

First step will be to contact someone with admin rights on the FTP server machine + have them tell you what's changed.

Said differently, it's unlikely you can fix this, only an admin on the server machine can fix this.
ASKER
WellingtonIS

OK the user name for the FTP has full control over that share - the root and the folder.  I gave the account admin rights on the FTP server as well. So it's can't be permissions.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
David Johnson, CD

you say that they have permissions for the SHARE..

I think you are confusing the users HOME folder and the FtpUSers Home folder

Here is how to setup User Isolation for IIS FTP
https://docs.microsoft.com/en-us/iis/publish/using-the-ftp-service/configuring-ftp-user-isolation-in-iis-7

If you want to use the home folder as defined in active directory then use this guide
https://docs.microsoft.com/en-us/iis/configuration/system.applicationhost/sites/site/ftpserver/userisolation/activedirectory
ASKER
WellingtonIS

OK heres the permissions:  This is a vitrual directory on another server:
ftp1.PNG
ftp2.PNG
David Johnson, CD

does the application pool that IIS is using for FTP also have permissions on this folder?

Workgroup or Domain?
Your help has saved me hundreds of hours of internet surfing.
fblack61
Craig Beck

ASKER
WellingtonIS

I check all the 530 errors and nothing is wrong - There's also no application pool associated with this FtP
Craig Beck

Disable Anonymous authentication and try it.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
WellingtonIS

This is the config file and the user has permission
<virtualDirectory path="/PowerInsight" physicalPath="\\wrmsfs01\FTP\PowerInsight" userName="corp\Wrmreproute" password="[enc:IISCngProvider:3Z+NJcVU38GL7ogQFzOaXmCKoB+ZrtvVjRymE6wtDscsSR2knnGOlVHx9QxUWZUs6sWpGtCgDj6jY7342Tfxtz52OGugEdNBLh57aKdx2sU=:enc]" />
Craig Beck

The physical path is a share. You need to make sure the user has permissions at both the share level and the NTFS level.

Also, did you disable anonymous auth?
ASKER
WellingtonIS

No actually I enabled it.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Craig Beck

You need to disable it if you're using basic auth.
ASKER
WellingtonIS

At the root level?
Craig Beck

Yes, at the FTP site level
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
WellingtonIS

This is what I'm getting.
ftp.PNG
Craig Beck

Have you disabled anonymous auth now?
ASKER
WellingtonIS

You're not going to believe this but I fixed it...  FTP authorization rules I needed to add the user there!  As soon as I did it, it worked.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
ASKER CERTIFIED SOLUTION
WellingtonIS

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question