Link to home
Start Free TrialLog in
Avatar of WellingtonIS
WellingtonIS

asked on

FTP Error

I have an FTP server.  I can't seem to suddenly connect even though the user has full control this is my error:

Command:    USER corp\Wrmreproute
Response:    331 Password required
Command:    PASS ***********
Response:    530 User cannot log in, home directory inaccessible.
Error:    Critical error: Could not connect to server

Avatar of David Johnson, CD
David Johnson, CD
Flag of Canada image

many possible reasons
this article covers the majority https://techcommunity.microsoft.com/t5/iis-support-blog/ftp-530-user-cannot-log-in-error-and-solution/ba-p/364570


I don't use IIS FTP but Filezilla FTP Server instead.
Avatar of Dr. Klahn
Dr. Klahn

Check to see that the FTP server is running with administrative credentials.  If this is not the case, then the server cannot override file protection to get at user home directories.  "home directory inaccessible" then becomes a possibility.
Note: the User Home Directory is the FTP User Home Directory and not the c:\users\username directory.
 530 User cannot log in, home directory inaccessible.
Check the permissions on the folder that is set as the user's home directory.
Error seems clear.

Something has changed on the server side.

Permissions... User deleted... something...

First step will be to contact someone with admin rights on the FTP server machine + have them tell you what's changed.

Said differently, it's unlikely you can fix this, only an admin on the server machine can fix this.
Avatar of WellingtonIS

ASKER

OK the user name for the FTP has full control over that share - the root and the folder.  I gave the account admin rights on the FTP server as well. So it's can't be permissions.
you say that they have permissions for the SHARE..

I think you are confusing the users HOME folder and the FtpUSers Home folder

Here is how to setup User Isolation for IIS FTP
https://docs.microsoft.com/en-us/iis/publish/using-the-ftp-service/configuring-ftp-user-isolation-in-iis-7

If you want to use the home folder as defined in active directory then use this guide
https://docs.microsoft.com/en-us/iis/configuration/system.applicationhost/sites/site/ftpserver/userisolation/activedirectory
OK heres the permissions:  This is a vitrual directory on another server:
ftp1.PNG
ftp2.PNG
does the application pool that IIS is using for FTP also have permissions on this folder?

Workgroup or Domain?
I check all the 530 errors and nothing is wrong - There's also no application pool associated with this FtP
Disable Anonymous authentication and try it.
This is the config file and the user has permission
<virtualDirectory path="/PowerInsight" physicalPath="\\wrmsfs01\FTP\PowerInsight" userName="corp\Wrmreproute" password="[enc:IISCngProvider:3Z+NJcVU38GL7ogQFzOaXmCKoB+ZrtvVjRymE6wtDscsSR2knnGOlVHx9QxUWZUs6sWpGtCgDj6jY7342Tfxtz52OGugEdNBLh57aKdx2sU=:enc]" />
The physical path is a share. You need to make sure the user has permissions at both the share level and the NTFS level.

Also, did you disable anonymous auth?
No actually I enabled it.
You need to disable it if you're using basic auth.
At the root level?
Yes, at the FTP site level
This is what I'm getting.
ftp.PNG
Have you disabled anonymous auth now?
You're not going to believe this but I fixed it...  FTP authorization rules I needed to add the user there!  As soon as I did it, it worked.
ASKER CERTIFIED SOLUTION
Avatar of WellingtonIS
WellingtonIS

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial