Link to home
Start Free TrialLog in
Avatar of Steven Reid
Steven ReidFlag for Australia

asked on

Issues with External Users accessing files when the parameter &web=1 is included in the URL

We have a SharePoint site which is shared with a number of users who are external to our tenancy.
When we create a link on a page for them to open a file that has the &web=1 parameter, they only receive a page with 5 dots scrolling across the top of the screen.
If i remove that parameter, then they have no problem accessing the content.

This is mainly for PDF documents, but we have also see it with mp4 files.
If the link is an office file like Excel, Word or PowerPoint, then it does open in the browser.

I feel that it because the "&web=1" parameter is trying to tell the file to be opened in the browser application (which doesnt exist) Has anyone else heard of this. and is there a solution?  by default getting a link to the file includes this parameter,
Avatar of Jazz Marie Kaur
Jazz Marie Kaur
Flag of United States of America image

Hi Steven.

Sorry, I have not seen that before, the WebBrewers SharePoint tip blog and TechNet Community member (Chris Webb) specify modifying or leveraging ?download=1  - unsure if you had seen that parameter change. Does it happen in other browsers or all? Are you using Chrome?

References
Avatar of Steven Reid

ASKER

Hi Jazz,
It seems to happen in all browsers.  

As the WebBrewers article says if you remove the &web=1 then it works.  I have found that you don't need to include the &download=1 option.
When I look at the results of the "Check Permissions" for an external user who is affected, I can see that they have "Read, Web-Only Limited Access "
I did some digging in the developer tools, and it looks like a lot of the scripts etc are failing for permissions reasons.

Still more things to look at!
ASKER CERTIFIED SOLUTION
Avatar of Jazz Marie Kaur
Jazz Marie Kaur
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial