Avatar of Mike

asked on 

mytop on debian won't run

Not finding anything on the net about this problem that can help.
It's installed on Debian 11 and while this shows one try, I've tried many other ways including;

mytop -u root -p
mytop -u root -d mysql --prompt

I've also tried with and without a .mycnf file in the /root directory.

The so called 'exact' errors never seem to lead to the actual problem.
Since I cannot find much info, I don't know for sure if mytop is looking for this file where I have it or somewhere else. I did not find a .mytop file anywhere else on the system.

# mytop
Cannot connect to MariaDB/MySQL server. Please check the:

  * database you specified "mysql" (default is "")
  * username you specified "root" (default is "root")
  * password you specified "" (default is "")
  * hostname you specified "localhost" (default is "localhost")
  * port you specified "3306" (default is 3306)
  * socket you specified "" (default is "")

The options my be specified on the command-line or in a ~/.mytop or
~/.my.cnf config file. See the manual (perldoc mytop) for details.

Here's the exact error from DBI. It might help you debug:

Connection error: port cannot be specified when host is localhost or embedded

Open in new window

DatabasesMySQL Server* DebianLinux

Avatar of undefined
Last Comment
David Favor

8/22/2022 - Mon