Link to home
Start Free TrialLog in
Avatar of Shahid Rafiq
Shahid Rafiq

asked on

Most of th eExchage Services are down on my Exchage Server 2016 CU 12

Exchange not working, services failing to start.

Exchange is left in a completely unusable state after filed KB5000871 

Avatar of DEMAN-BARCELO (MVP) Thierry
DEMAN-BARCELO (MVP) Thierry
Flag of France image

Avatar of Shahid Rafiq
Shahid Rafiq

ASKER

This is an isolated Exchange Server not connected to Internet, less attention on this environment , well how can i make all Exchange services up
While trying to restart the "MSActiveDirectory Topology" get below error:
Process Microsoft.Exchange.Directory.TopologyService.exe (PID=4444) Forest domain.local . Topology discovery failed, error details Active directory is not available
If this service does not start, no other exchange service can start.

So, where is Active Directory? on the same machine?

Do you have DNS resolution and all necessary protocols to access Active Directory? LDAP (389, 3268),...

You can use the "telnet" client to verify connection ("telnet FullNameOfDC 389").

Verify that IPv6 is enabled on Active Directory servers and Exchange. If necessary, try to disable it on Exchange.
Use nltest command and check to which DC it is connected. Then check that DC, make sure your DC is working fine.
well after a long troubleshooting which is still going on though the issue is not fixed i realized that there is a APIPA which stops the server to communicate with outside world, i tried many things to remove this but failed, how can i remove it 
APIPA means that DHCP is enabled !

You should fix the IP addresses on all network cards.

At worst, you could also change/define the APIPA address in the tab "Alternate Address" to match your need.
@Deman: DHCP is not enabled but it takes the APIPA by itself, after so amny tries even by removing the NIC from VMware, then re added and re assigned the IP still returned back. I tried to add one more NIC and then give that one IP out of different subnet which worked very fine and didn't add any APIA to it, the moment i changed Ip subnet back to the earlier i was able to see the PIPA again

when i try to IPCONFIG /RELEASE it says "the operation failed as no adaptor is in the state permissible for this operation"
Hey guys, the issue resolved by changing the IP from .30 to .130 , keeping in mind if i used .30 APIPA will arrive if i use .130 no other IP is assigned, hence reserved .130 for now to make services up and running 
ASKER CERTIFIED SOLUTION
Avatar of Shahid Rafiq
Shahid Rafiq

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
You probably have a phantom network card that prevents you to use this IP address.