Avatar of bhunger
bhunger
Flag for United States of America asked on

Hit a Snag Installing Oracle 11g r2 on Solaris 11.2

Trying to install Oracle 11gr2 on Solaris 11.2.0.3.  Everything going well until we get this error: 

"Exception in thread "main" java.lang.UnsatisfiedLinkError: /tmp/OraInstall2021-10-23_05-39-18PM/jdk/jre/lib/amd64/motif21/libmawt.so: ld.so.1: java: fatal: libXm.so.4: open failed: No such file or directory"


Stopped dead in the water.


Old production platform that requires both of those versions, so can't get around Solaris 11.2/Oracle 11gr2.


Can't figure out how to continue.

InstallationJavaOracle Database

Avatar of undefined
Last Comment
Alex [***Alex140181***]

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Alex [***Alex140181***]

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
bhunger

ASKER
Alex, thanks for the quick response.  I should have addded my dba's specific text.  He tried two versions and got the same error.

His note:
"Getting this error running .runInstaller from database directory from install same error
 
11.2.0.1
and 11.2.0.3"

He's using the gui.  Would a command line install make any difference?

slightwv (䄆 Netminder)

Do you have X-Windows installed on Solaris?

Does xeyes or xterm run and display the window on the screen?

If you don't have X running, you'll probably need the command line install.
bhunger

ASKER
Running vncserver. Can full package be installed from command line?
Your help has saved me hundreds of hours of internet surfing.
fblack61
Alex [***Alex140181***]

@bhunger: you've marked this as solved? Is that correct or is there anything more we could do to help you?