Link to home
Start Free TrialLog in
Avatar of vmich
vmichFlag for United States of America

asked on

Cant connect via rdp to server 2019

Not rocket science but trying to setup rdp connections to a windows server 2019 but each time I try it keeps saying remote connection are not enabled but they are...

I have the rdp enabled and the domain users added to it.

What am I missing here for this

Avatar of Lee W, MVP
Lee W, MVP
Flag of United States of America image

Screen shot of exact error would be helpful.  Is it possible it means it cannot reach the server?  Is there a firewall, either Windows, Antivirus Firewall, or hardware firewall that could be blocking you?  Did someone change the RDP port (never a good idea).
ASKER CERTIFIED SOLUTION
Avatar of arnold
arnold
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
This is probably the most common RDP error there is?

Remote Desktop Services – Connection Errors


Pete
Is the server part of a domain?  If not, is it a Private network?  

If Public, here is an easy change to Private:
   

Change Network Location Type Using Security Policy

 Another way to change the network location type is to use the Local Security Policy Editor.
 We run the secpol.msc snap-in and go to the section Network List Manager Policies. On the right, find the network by its name in the Network and Sharing Center.  Then, open the network properties, and go to the Network Location tab, change the network type from Not configured to Private, and save the changes.