Link to home
Start Free TrialLog in
Avatar of Brian Davies
Brian DaviesFlag for Canada

asked on

Exchange 2016 CU22 Mailbox Delivery Queue in Retry status

I recently updated my Exchange 2016 server running on 2016 Standard Server OS and since the upgrade I have been seeing the SmtpDeliveryToMailbox queue status in Retry. I checked the event logs and did find a Certificate error which I fixed using the Error logs suggested command then rebooted the server and mail deliveries worked until sometime last night. This morning the queue is again stuck in Retry status. I have verified my server has the Oct and Nov Security updates released by MS as well. Outgoing emails are flowing without issue. This affects external emails coming in to us and internal emails between mailboxes.

Avatar of M A
M A
Flag of United States of America image

Hi Brian,
Welcome to Experts Exchange. :))
Did you try recreating certificates by running new-exchangecertificate?
Restart transport service and check.
Avatar of Brian Davies

ASKER

Did that to fix the original error and the certificate error no longer shows up. So far the only way to get the mail delivery flowing again is to reboot the server, and then it works for a few hours before it hangs again. I did note before rebooting it a short time ago that the server memory was at 76+% used. With it working after a reboot for a few hours I am wondering if I have a memory issue since updating my exchange server from CU9 to CU22? The largest memory consumer on the server was the Exchange Store Worker Process but it is always consuming a fair chunk of memory. Right now it is using @1050MB but before the reboot it was sitting around 2800-3000MB.
As a side note my server has 32GB of ram.
The largest memory consumer on the server was the Exchange Store Worker Process but it is always consuming a fair chunk of memory.

that is by design
Exchange and SQL will use as much memory as it has available to it.

can you correlate anything in the application log at about the time the queue issue occurs?
how is the disk space on C?  once the volume reaches about 20% free the transport service will stop and will cause issues with mail flow though might not be an issue if it is fixed with a reboot
Both the C drive and the D drive are less than 50% full. Going through the event logs when it first occurred was the Certificate issue but that was rectified early yesterday morning and I rebooted the server after the certificate was added as the queue was still stuck. After the reboot it worked fine till sometime last night but not sure exactly when the queue got stuck. I tried restarting the main transport service and the held messages in the queue got delivered but the queue was still stuck and started accumulating messages right away. So after searching again for a solution I again restarted the server so emails would flow again and they are still flowing now.
have you looked at the application log at the time when messages stop moving since you fixed the certificate issue?
The issue was only affecting the incoming emails, regardless of source. No emails were being delivered to the recipient's mailbox but sending was working fine.
I had to reboot the server every morning since the upgrade last monday evening, 8 Nov 2021, to get the email delivery to the mailbox queue working again. However since Thursdays reboot I haven't had to reboot and the delivery queue is still working as of now.
Hopefully it will continue working so this issue may have cleared itself up on its own. There was nothing obviously related in the event logs once I remedied the certificate issue last Tuesday morning. There were a number of KB updates that came down last week so one of them may have also fixed this issue.
ASKER CERTIFIED SOLUTION
Avatar of Brian Davies
Brian Davies
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial