Avatar of lloving
lloving
 asked on

Imported Outlook contacts appear corrupted

Trying to import Outlook contacts from a csv file generated by the export function in AOL Mail.

The actual import runs smoothly and appears to populate the target instance of Outlook as expected. However email addresses selected from those imported contact records cause the email message to be rejected and the message is not sent. This happens as soon as you hit the send button. 

I have tested this on two different computers and on two different Outlook profiles.

I have opened the CSV file in Excel and saved it as a spreadsheet and then saved it again as a csv file. Same result. 

The csv and xls versions look normal in Excel.

OutlookMicrosoft ExcelMicrosoft Office

Avatar of undefined
Last Comment
lloving

8/22/2022 - Mon
David Johnson, CD

When you do an import there is an option to map columns go through your mappings and ensure they are correct.
Tony J

lloving

ASKER


The default mappings appear to properly fill in the fields in Contacts when viewed from within Outlook.
Your help has saved me hundreds of hours of internet surfing.
fblack61
lloving

ASKER
By way of a test I abandoned the default mappings and remapped the related fields. Imported again with the same result.
lloving

ASKER
When I test the mappings from the Map Custom Fields the email addresses look like this.


Michael Pfister

Verify the source csv is in UTF-8 encoding, i.e. by opening it with Notepad++. Notepad++ can also convert it.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
lloving

ASKER
The csv file is in UTF-8 encoding
Tony J

As Michael suggested - try opening the CSV in Notepad++ (it's free) and look for the malformatting there. It may well not show in Excel but likely will in N++

lloving

ASKER
Using Notepad## (Thanks for the suggestion Michael) I see no mal-formatted fields. If I highlight the email address text and do a lookup I get the expected response from Google.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Michael Pfister

Anyway try saving it as UTF-8 to a new file and try to import it.
lloving

ASKER
I have tried saving as a copy in UTF-8 with no luck. Also saved a copy as ANSI with a csv extension, no luck.
Tony J

You could try a search and replace for non ASCII characters.

In Notepad++ do a search and replace and use the following to search for: [^\x00-\x7F]+
 
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
lloving

ASKER
The problem is the non-ASCII characters don't show up in NotePad##

All lines in the file look like this in Notepad##:
Bob,,smith,,,bobsmith@comcast.net,"home, primary",,,,,,,,,,,,,,,,,,,,,
lloving

ASKER
This does not qualify as a solution but more of an apparent workaround.
During the Outlook Contact import process "Clear Mappings" and start over. Map each field you want imported. Specifically map the email address to the email(#) field not the email(#) address field. This worked in my test environment. Now to real life.
I'll follow up later
lloving

ASKER
Contacts successfully imported using the process outlined in my previous post

​Issue resolved not solved. 
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ASKER CERTIFIED SOLUTION
lloving

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.