Link to home
Create AccountLog in
Avatar of Zack
ZackFlag for Australia

asked on

Filezilla SFTP connection issue

Hi EE,


I am connecting to SFTP via BOOMI using an RSA private key and there are no issues. However, when I try to do the same via Filezilla I get the Status:   Server refused our key.


Current setup on Filezilla


- Added private key to Filezilla (edit -> settings -> sftp -> add key file)
- Connecting to the server using Filezilla - was prompted to add servers host key to the registry (chose always trust this host, add this key to cache) 


Any ideas as to what is going, any assistance is welcome?


Thank you. 



Avatar of Kimputer
Kimputer

That's because you can directly point to the correct priv key in the SITE MANAGER. Do it IN THE CONNECTION, NOT Filezilla Settings.
The add this key to the cache is the SERVER's key, not yours.
Here's your priv key:

User generated image

User is blurred out, is still required by most servers.
Avatar of Zack

ASKER

Hi Kimputer,

Tried no fix, any other ideas.

Thank you. 
Where you required to register your IP nr as well? Are you testing from another IP nr (compared to the curretnly working solution)?
Avatar of Zack

ASKER

Hi Kimputer,

Good question I'll check with sysadmin.

Thank you. 
To debug this requires.

1) Unobfuscated, far more detailed data, than you've provided.

2) Or... if your security internal policy disallows data sharing, you'll hire someone to help.

Here's how I debug this type of problem...
ASKER CERTIFIED SOLUTION
Avatar of David Favor
David Favor
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Zack

ASKER

Hi David,

How would I run those commands on a Windows Server?

Thank you. 
Avatar of Zack

ASKER

Hi David,

Forwarded those commands to our sys admin he was able to work out the problem from them.

Cheers also to Kimputer for your assistance. 

Thank you.