Avatar of Alan Silverman
Alan Silverman
Flag for United States of America asked on

Reality check on new Lenovo LENOVO 82H9 IdeaPad 3 17ITL6

I am setting up a new LENOVO 82H9 IdeaPad 3 17ITL6  running Windows 10 at current level.  A Belarc Advisor profile for the machine is below.


It takes 2 minutes 12 seconds to boot from when I push the on/off button to when I can put in a user password that takes me to the desktop. Otherwise it's two plus minutes of that little circle going around. This seems excessive even for the older 1TB mechanical sata drive the computer came with.
 
Secondly, whenever I boot from a usb drive, whatever program I use cannot locate any other drives in the computer. For instance, if I boot from partition master or an Acronis boot flash drive or even a Windows creator's update, none of these programs see any other drive except the flash drive it booted from.
 
I sent the laptop back to the Lenovo depot with explicit instructions about what needed to be fixed.  They sent it back and nothing is different.  I need a reality check.  Even with a mechanical hard drive it should take less than 2 minutes and 12 seconds to boot up.  Secondly, I should be able to boot from a flash drive and find other drives that show up in the bios as being there. Agreed?  
 
I would appreciate your opinions because I will be calling up Lenovo support shortly to give them a piece of my mind.  I have a client waiting for this computer, I sent it into their depot and I don't think they worked on it at all.
 
Thanks,
Alan


Profile Date:Wednesday, December 8, 2021 8:04:15 AM
Advisor Version:11.1
Windows Logon:owner
Personal Home Use Only

Operating System

Windows 10 Home (x64) Version 21H1 (build 19043.1348)
Install Language: English (United States)
System Locale: English (United States)
Installed: 11/15/2021 9:08:24 PM
Servicing Branch: Current Branch (CB)
Boot Mode: UEFI with Secure Boot disabled

System Model

LENOVO 82H9 IdeaPad 3 17ITL6
System Serial Number: PF322973
Chassis Serial Number: PF322973
Enclosure Type: Notebook

Processor a

3.00 gigahertz Intel 11th Gen Core i3-1115G4
160 kilobyte primary memory cache
2560 kilobyte secondary memory cache
6144 kilobyte tertiary memory cache
64-bit ready
Multi-core (2 total)
Hyper-threaded (4 total)

Main Circuit Board b

Board: LENOVO SDK0K17763 WIN
Serial Number: PF322973
Bus Clock: 100 megahertz
UEFI: LENOVO GGCN17WW 12/03/2020

Drives

998.87 Gigabytes Usable Hard Drive Capacity
970.68 Gigabytes Hard Drive Free Space

TOSHIBA MQ04ABF100 [Hard drive] (1000.20 GB) -- drive 0, s/n 616ZTRVYT, rev JU0A2E, SMART Status: Healthy

Memory Modules c,d

7992 Megabytes Usable Installed Memory

Slot 'Controller0-ChannelA-DIMM0' has 4096 MB (serial number 202A2E35)
Slot 'Controller1-ChannelA' has 4096 MB

Local Drive Volumes

c: (NTFS on drive 0)998.87 GB970.68 GB free
BitLocker‡
‡ Suspended volume encryption.

Network Drives

None detected

Users (mouse over user name for details)

local system accounts
local user accountslast logon

owner12/8/2021 7:55:13 AM(admin)
XAdministratornever(admin)
XDefaultAccountnever
XGuestnever
XWDAGUtilityAccountnever
X Marks a disabled account; L Marks a locked account

Printers

Microsoft Print To PDFon PORTPROMPT:
Microsoft Shared Fax Driveron SHRFAX:
Microsoft XPS Document Writer v4on PORTPROMPT:

Controllers

None detected

Display

Intel(R) UHD Graphics [Display adapter]
Generic PnP Monitor (17.1"vis, September 2019)

Bus Adapters

Intel RST VMD Controller 9A0B
Intel RST VMD Managed Controller 09AB
Microsoft Storage Spaces Controller
Intel(R) USB 3.10 eXtensible Host Controller - 1.20 (Microsoft) (2x)

Multimedia

Intel® Smart Sound Technology for Digital Microphones
Realtek(R) Audio

Virus Protection

Windows Defender Version 4.18.2110.6
    Scan Engine Version 1.1.18700.4
    Virus Definitions Version 12/8/2021 Rev 1.353.2277.0
    Last Disk Scan on Tuesday, December 7, 2021 1:46:29 PM
    Realtime File Scanning On

Group Policies

None detected

Communications

↓ Bluetooth Device (Personal Area Network)

Status:Cable unplugged

Dhcp Server:none responded

Physical Address:A0:E7:0B:57:81:B2

Connection Speed:3 Mbps
↑ Intel(R) Wi-Fi 6 AX201 160MHz
primaryAuto IP Address:192.168.50.127 / 24

Gateway:192.168.50.1

Dhcp Server:192.168.50.1

Physical Address:A0:E7:0B:57:81:AE

Connection Speed:867 Mbps
↓ Microsoft Wi-Fi Direct Virtual Adapter

Status:Not connected to a network

Dhcp Server:none responded

Physical Address:A0:E7:0B:57:81:AF
↓ Microsoft Wi-Fi Direct Virtual Adapter #2

Status:Not connected to a network

Dhcp Server:none responded

Physical Address:A2:E7:0B:57:81:AE
 
Networking Dns Server:192.168.50.1

Other Devices

Microphone Array (Intel® Smart Sound Technology for Digital Microphones)
Speakers (Realtek(R) Audio)
Microsoft AC Adapter
Microsoft ACPI-Compliant Control Method Battery
Goodix fingerprint
Intel(R) Wireless Bluetooth(R)
Integrated Camera
HID-compliant touch pad
HID-compliant vendor-defined device
Microsoft Input Configuration Device
Standard PS/2 Keyboard
HID-compliant mouse
USB OPTICAL MOUSE
Trusted Platform Module 2.0
Camera DFU Device

USB Storage Use in past 30 Days

Device (mouse over for details)Last Used
ADATA USB Flash Drive, s/n 273062104023001C, rev 110012/8/2021 7:48:09 AM
ADATA USB Flash Drive, s/n 15C1701250380077, rev 1.0012/5/2021 12:23:19 PM
Innostor Innostor, s/n 124455012767287, rev 1.0011/26/2021 9:03:38 AM
ADATA USB Flash Drive, s/n 273062106008000F, rev 110011/16/2021 2:18:39 PM

Hosted Virtual Machines

None detected
Personal Home Use Only
Windows OSWindows 10* Lenovo ideapad

Avatar of undefined
Last Comment
Kimputer

8/22/2022 - Mon
McKnife

Boot time is slow, agreed. On slow mechanical drives, a cleanly installed Windows should take about 30 seconds at most from turn on to logon prompt, no more.

The invisibility is not Lenovos fault. Check whether drive encryption is in use, that would explain it.
rindi

You probably also need the drivers for the Disk controller in order to be able see the internal Disk when you boot from USB. The Windoze installer has an option to install the driver where you get asked to select the location to install to. The other tools you mention probably have a similar option.

Possibly a Windoze 11 Installer already includes those drivers. Your hardware seems relatively new, so drivers may not have been readily available yet when the iso's got built.
Kimputer

Slow HDD combined with "mere" Core i3, yes, 2.5 minutes is still in the range of possibilities.
I wouldn't exactly start investigating anything especially if it's a new Win10 install. I draw my conclusions on those 2 facts alone and mark it as "normal" for your situation.
The 30 seconds described, is also within the range of possibilities, though it requires all the fast boot options available in the system, and will return to 2.5 minutes when fast boot isn't available (full reboot, due to Windows updates for instance).

Lenovo was well within their rights to send it back exactly as is, IF they have properly checked the same model on their site, starts and boots around the same time you measured. And I'll give that a clean 99.98% chance that happened.

As for the invisible drive, it's definitely a more exotic storage controller used. You either load extra drivers during the USB boot (if the boot app supports it), or you fiddle with the BIOS and see if there's a compatibility setting (return these settings when you're done, so Windows can boot again)
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Alan Silverman

ASKER
See the two shots of the bios below. If I disable the Intel VMD Controller option, suddenly a SATA Controller parameter appears. It is set to ACHI. If I do that, apps booted from a USB flash drive show all the internal drives. But with VMD Controller turned off in the bios a boot will always get BSOD with inaccessible boot device.
rindi

You should keep ahci on & load the appropriate drivers as I mentioned earlier. Performance should be a lot better with it turned on.
nobus

that disk is a 5400 rpm drive - so it is the slowest around.
if you want faster boot - install an SSD drive
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
ASKER CERTIFIED SOLUTION
Kimputer

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Alan Silverman

ASKER
Rindi, If I turn off the Intel VMD controller in the bios I get a BSOD on a normal boot to the drive that Lenovo sent with the computer.  It says, "Inaccessible boot drive". Are you saying that the version of Windows 10 sent with this computer did not have the correct drivers to run Windows in ACHI mode?  I think this is the key if it is a bios problem. In my mind I simply can’t make that work. The computer should be able to boot in ACHI mode.

Nobus, you know me better than that.  :)
Regarding the mechanical drive, I intend on finally running this machine off an NVME drive with the mechanical drive as backup. Right now I’m running on NVME. It does go faster but there are other strange things going on.
 
There’s some indication that the hardware thinks the drive is encrypted with bitlocker.  Belarc advisior shows: BitLocker‡ ‡ Suspended volume encryption.  
I set this up as a local user. Bitlocker shouldn’t be involved.
 
Kimputer, I have been working on PCs exclusively since 1999 and was Level 2 support for IBM’s mainframes before that. I have set up hundreds of new off the shelf PCs, Dells and Lenovo mostly. I don’t remember ever not being able to boot from a flash drive.
 
When I first worked on this  problem in November I tried lots of things. I installed Win11 and got the same result. So I reinstalled Win10. The bios level the PC first came with was GGCN29WW. At the time that wasn’t even listed as a Win10 bios. I backflashed the bios to GGCN28WW, the highest bios level at the time. Same result.  
 
When I got the computer back from the Lenovo depot, they had flashed it back to GGCN17WW. When I still couldn't boot in AHCI mode, I updated this to GGCN28WW and then to GGCN29WW. Same result.
 
My original Lenovo support rep didn’t seem to know what a bios was. I asked to be sent up to someone who did. The rep said there was no one else to send me to. I asked to speak with his manager. He said his manager would give me a call back. Never received one. So I sent the laptop to the depot.  
nobus

on some older systems, i've seen NVMe drives needing drivers for it, in order to be able to boot from them - i don't know if this is the case here - but check with lenovo
rindi

When you install the OS from USB, & you can't see the Internal Disk, you have to supply the driver for the Disk controller. After that you should see the internal Disk & be able to continue the Installation. You shouldn't get a BSOD after that. When you install Windoze 10, you wouldn't use the what you got from the Manufacturer, but rather the clean & current version you can download directly from the M$ site. This ensures you don't have to do hours of upgrades after the installation, but rather just a few, & you also get a clean installation, without all the bloatware the manufacturer supplies you with.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
Alan Silverman

ASKER
I didn't install the OS from a usb drive. I just can't see any other drives when I boot from an app on a flash drive, for instance, Partition Master. That was just one symptom. The operating system came with the Lenovo itself. To me the important fact is that I cannot boot the drive that came with the computer if I disable the Intel VMD controller in the bios. That doesn't make sense to me.
Thanks,
Alan 
rindi

Then install the OS from USB. Also, most USB boot systems allow you to install Drivers so you can see the internal Disk.
Kimputer

You said you installed hundreds of PC. So what about the 2 options I gave you, you don't understand?
It's very simple, you use Intel VMD, which isn't included yet in most USB boot apps you tried.
If you turn it off, after USB boot, your HDD is visible. That's what I said all along.
Obviously your Windows installation is installed with VMD ON, and therefore freaks out when you put the BIOS back to AHCI.
So either keep switching VMD on and off, or use option 2.

⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Alan Silverman

ASKER
Kimputer,
To clarify. This has nothing to do with USB drive apps. Forgetting totally about that, if I turn off VMD I cannot boot the hard drive that came with the computer. It is only accessible with VMD on.  I should be able to turn off VMD and still use the computer, but I can't. Does that make sense? 
Thanks,
Alan

PS With computers set to raid, you can change it to AHCI but you have to go into safe mode after doing so. Then if you go into regular mode you can stay in AHCI. Is this something like that?  Also, as I said above, I tried installing Windows 11 with the same result and I'm using a NVME drive now. Speed is not the issue. No internal hard drive, mechanical, SSD or NVME will successfully boot if I disable the VMD controller in the bios. 

Kimputer

No, that doesn't make any sense at all. You should know, after installing all those hundreds PC, the storage controller during install IS IMPORTANT.
The moment you change it, BSOD! It's been a fact since the very first Windows machines.
VMD IS THE STORAGE CONTROLLER.

Change a WinXP hard drive from one computer to the next computer, what do you get? BSOD 7B!!! (Bar the coincidence the target PC is very similar to the source PC)

What you're doing with turning VMD on and off IS THE SAME THING!

So now, what's so hard to understand about option 2 of my previous solution?
rindi

The Fake RAID controllers built into many Desktop or other cheap PC's use the same drivers as the AHCI controllers, so then it wouldn't BSOD, as the drivers are already installed. BSOD's occur if the respective Drivers aren't present.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Alan Silverman

ASKER
Kimputer,
You said I would have to reinstall windows for AHCI to work. That seemed a bit drastic and I don't think it would have worked. When I rebooted I'd have the same bios settings. 

I went into the bios and changed it to AHCI then went into safe mode and that worked. If I had seen it defined as RAID I would have known to do that. But then I'd have gotten a warning about changing SATA mode. The VMD controller threw me off. Someone at Lenovo should have known enough about their bios to help me figure that out without having me send the computer to the depot.  
Kimputer

Install Windows WHILE AHCI is working. I said in option 2 already: FIX IT TO AHCI in BIOS. Even though I've written all the words, you never read them properly.
How would it not work?
AFTER that you don't have to enter the BIOS ever again.

Also, I explained before, when sending a WORKING laptop to support, you will get it WORKING back. It's not their responsibility to do your BIOS settings according to your needs (even though it sounds nice).
The seller usually helps you along the way (if it's not a webshop only). That's why physical shops with expert sales and support are sometimes still the way to go, even though they may be a few quid more expensive than others. You pay for expertise, always.
Alan Silverman

ASKER
Thanks to everyone for your help.
Best,
Alan 
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Kimputer

Just so you know, you can save your re-install if you have to correct software to fix the BSOD.
But you need the newest paid version mostly (Paragon), and jumping to Win11 saves you a lot of upgrade time later on (and that's a free option that WILL shave of some boot time).