Avatar of Paul Freitas
Paul Freitas
Flag for Canada asked on

Emails stuck in exchange 2016 queues

Emails are stuck in queues on an Exchange 2016. I checked DNS, Connectors, Certificates, Virtual Directories....

Someone has an idea?


ExchangeDNS

Avatar of undefined
Last Comment
Paul Freitas

8/22/2022 - Mon
Lee W, MVP

M A

Please try these commands first
Set-malwarefilteringserver -Identity servername -bypassfiltering $true
Restart-service msexchangetransport

Open in new window


Lee W, MVP

I would no longer recommend the solution MA has - that was the work around found the day of the issue.  Microsoft has issued an official response - follow their guidance for the safest results.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Paul Freitas

ASKER
I did those 2. When it came out on Jan.1st and then the Microsoft guidance when it came out. It was working until today .....
Seth Simmons

I checked DNS, Connectors, Certificates, Virtual Directories....

have you checked free disk space?
if space is too low (below ~20%) then you have backpressure and the transport service will stop mail flow

failing that, look at event logs for anything unusual
Paul Freitas

ASKER
I didn't think of that. Thank you! But in that I'm good. Log disk at 42% and Database at 33%
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Lee W, MVP

OS disk?
Paul Freitas

ASKER
13% Used 
Seth Simmons

have you looked at event logs?
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Paul Freitas

ASKER
Yes, here's one from the TransportRoles\Hub: (similar in Mailbox)
2022-01-07T02:56:31.982Z,15.1.2375.17,Intra-Organization SMTP Send Connector,SmtpDeliveryToMailbox,igxdb02,InfoDomainNonexistent,192.168.1.1,[Domain:Result] = domain.intelgenx.com:InfoDomainNonexistent;
That IP 192.168.1.1 is not mine and don't know where it comes from....


Seth Simmons

are all of the messages in the queue showing the same destination domain or different?
is mail flowing in general and just a few sitting in the queue or is mail not going in and out?
Paul Freitas

ASKER
Nothing is going in or out. Even between users
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Seth Simmons

have you tried restarting the transport service or rebooting?

Paul Freitas

ASKER
Yes...
Seth Simmons

all other automatic exchange services are running?
and you said dns is ok?  as in the dns servers configured on the exchange server?
something must have changed if it was working yesterday
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Paul Freitas

ASKER
Automatic Services: All running
DNS: non of the resolve-dnsname i ran came with an error
The only thing that changed was the fix Lee talked about earlier that I applied yesterday
Seth Simmons

The only thing that changed was the fix Lee talked about earlier that I applied yesterday

and some in that thread are complaining it didn't fix it
ASKER CERTIFIED SOLUTION
Paul Freitas

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question