Link to home
Start Free TrialLog in
Avatar of D B
D BFlag for United States of America

asked on

VS 2022, SSIS Package Errors

My laptop crashed and I am configuring a new one. Installed VS 2022 and SSIS. I've opend a solution containing a DTSX package. I am unable to open any of the Execute SQL Tasks as I get the following error:


The task with the name "task name" and the creation name "Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask.ExecuteSQLTask, Microsoft.SqlServer.SQLTask, Version=16.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" is not registered for use on this computer.

Contact Information:

Execute SQL Task


I've Googled the error but unable to find a definitive resolution. When I open the Properties, almost every one shows, "Could not get value for property '{EEA11184-C94B-464D-91A8-4EC699474D99}'. Specified cast is not valid."


Getting similar error on my Connection Managers stating  "The requested OLE DB provider SQLNCLI11 is not registered. If the 64-bit driver is not installed, run the package in 32-bit mode. Error code: 0x00000000."


Avatar of Jim Horn
Jim Horn
Flag of United States of America image

>Could not get value for property '{EEA11184-C94B-464D-91A8-4EC699474D99}'
{Very wild guess} Your old box had connections that are not installed on your new box, and all connections (/everything?) is stored as a GUID.
To get some insight as to what this is make a copy of your .dtsx file, then open the file in Notepad or your favorite text/XML file editor, search for that GUID, and see what's around it.

Good luck.
Avatar of D B

ASKER

Jim, we have aliases set up in each environment configured through SQL Server Configuration Manager and based on the environment we are in. Those have all been reconfigured. Besides, that should not affect my ability to open an Execute SQL task, even a new one I've dragged onto the Control Flow pane and tried to open, that doesn't even have a connection defined yet.
Hi,

SQLNCLI is not installed on a fresh new Windows installation. You need to download and install it in the right bit version.
https://www.microsoft.com/en-US/download/details.aspx?id=50402

I had the same issue these days with an older version of SSIS Script Task. I could under no circumstances get my old script task working until I looked into the XML code (you don't need to use Notepad, just right click on the package and use "open code" - any changes in design mode are automatically synchronized with the XML and vice-versa).

Visual Studio has removed my script task, unfortunately also the whole code (not dramatic in my case, but really annoying) and later on it replaced the task with a "Replacement Task"....

Moving a new script task into the package offered in XML that it inserted a new version of the script task and this one was editable. So my recommendation: If you have a backup of your package, don't open it in Visual Studio, open it in an external editor like Notepad++  (which can display XML far better) and copy the task code from here. Then open your current package as usual in VS and remove the script task, then insert a new one, restore the connections and properties and insert the copied code. After that the package work again.

Information about the script task problem i.e. here:
https://social.msdn.microsoft.com/Forums/en-US/0a53330f-86f1-485b-8c11-ec1c78667574/unable-to-open-script-task-in-ssis-packages-in-microsoft-visual-studio?forum=sqlintegrationservices

In my case the script task DLL was not in one of these folders, although Visual Studio allowed me to insert a new script task...

I don't really understand why something like that is possible, it's a no-go that a development environment changes the content of a package or even replace it with a meaningless "Replacement Task" and deleting the developer work without warning. So best is to make a backup of the whole Visual Studio project folder on a regular basis to be able to at least restore your work.

By the way: I have tried VS repair installation and many more, but the package was broken, code lost, no chance to get it back.

Cheers,

Christian
ASKER CERTIFIED SOLUTION
Avatar of D B
D B
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial