Link to home
Start Free TrialLog in
Avatar of coder
coderFlag for Australia

asked on

not able to run asp.net core web api application

Hi Experts,


I have created a asp.dot net core application and copied it to the deployment folder.  it works fine.


secondly, I want to deploy a asp.net core web api application,  I am not able to run that application.  But when I run from vs code, I am able to the swagger ui to test this web application.  But when I deploy it to that folder it is not working.


Then I removed the web application files from that folder and tried to run just the web api application  it fails,  I tried coping the debug files and enabled log on web config I am not able to the swagger ui for that web application.  I dont have access IIS, I can just copy the files to that folder. and see whether it runs.  I am unable to find why the web api application is not running.


Please advise on how to make the asp.net core web application to run on that deployment folder.


I am using .net 6.0 framework. 


secondly please advise how to deploy both the web application and web api application both to be deployed to the same folder.  

ASKER CERTIFIED SOLUTION
Avatar of dfke
dfke

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of coder

ASKER

@dfke

Thank you so much
Its working fine now.  The mistake I had done is when I debug, it was working the swagger.  I copied the files to the deployment folder and I was trying with the url including swagger which I used on debug mode.  something like https://localhost:7022/swagger/API/getusers instead of https://example.com/API/getusers on the deployment folder.  it is working fine without including swagger in the url.