Link to home
Start Free TrialLog in
Avatar of Ralph Gould
Ralph GouldFlag for United States of America

asked on

Hosted SFTP solution with ssh

I'm looking for some sort of hosted SFTP solution with the.following requirements. Anyone have any leads. Can't use a Synology server because it now requires the admin account only. Tried hostedftp while they were helpful the ssh with no keys is an issue. Any help would be appreciated.


Reqs:

The server allows SSH from the user provided with password


At this time, the system does not support SSH Keys, it must be password


The user provided is able to run SFTP


The user provided is able to create directories


The user provided is able to write files

Avatar of David Johnson, CD
David Johnson, CD
Flag of Canada image

use filezilla server 

Avatar of Ralph Gould

ASKER

Filezilla server will work without keys for ssh? Would I need to allow some sort of ssh server or that's all built in? Thank you

filezilla server is the sftp server and you can add user/passwords

I understand that portion. The part I was confused on is ssh with
just  username and password. I thought ssh always required keys to be exchanged. This is a request from a phone company to send audio recordings l. The requirements listed above are non negotiable so each solution I've tried so far SFTP is fine but ssh session without keys seems to be an issue. I'll need to check out filezilla server and test.
ASKER CERTIFIED SOLUTION
Avatar of David Johnson, CD
David Johnson, CD
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial

You just need to edit your sshd_config file.  On some systems it's in /etc/sshd_config and on others it's in /etc/ssh/ssd_config.  The default settings are usually listed as comments.


You just need to find the default line for Public Key Authenticaltion and turn it off

#PubkeyAuthentication yes

Open in new window

It's probably better to leave the above line and add the following below

PubkeyAuthentication no

Open in new window


By default, you should have Password authentication already enabled.

#PasswordAuthentication yes

Open in new window