Link to home
Start Free TrialLog in
Avatar of Blair Benjamin
Blair BenjaminFlag for United States of America

asked on

How to remove calendar delegate notifications when user is not visibly configured as a delegate

I have an Outlook / O365 user (User A) who is receiving calendar notifications for another user (User B) but I'm having trouble locating the setting that is causing this.  I'm well aware that this is typically due to a user configuring another user as a delegate to their Outlook/Calendar.  However, in this case, the User A getting the notification is not showing as a delegate in User B's Outlook account.  It's almost as if a setting is orphaned somewhere and can't be located.   User A actually WAS a delegate for User B in the past, but is no longer.  But they're still getting the notifications.  What can I check and where can I maybe find where it's configured to send calendar notifications to User A?  I'm stumped.

Avatar of Vasil Michev (MVP)
Vasil Michev (MVP)
Flag of Bulgaria image

First thing you should do is run a message trace against one of the messages, details therein can give you a clue as to how the message ended up being delivered to User A. Here's the documentation on it: https://learn.microsoft.com/en-us/exchange/monitoring/trace-an-email-message/message-trace-modern-eac

To cover the basics, check the delegate permissions via PowerShell and/or reset the delegate collection altogether:


Get-MailboxFolderPermission userA:\calendar
Remove-MailboxFolderPermission userA:\calendar -ResetDelegateUserCollection

Open in new window


Also check the calendar processing settings:


Get-CalendarProcessing userA | select ResourceDelegates

Open in new window


And cover Inbox/Mail flow rules too.

Avatar of Blair Benjamin

ASKER

I think the powershell commands only work when the user mailbox lives on a local exchange server.  Our users' mailboxes are in O365 cloud.  When I run these commands, it says the specified mailbox does not exist.

They work fine in Exchange Online. Make sure you're connected with account with sufficient permissions. Note that the Calendar folder might have a different name, depending on the regional settings configured on the mailbox. You can use the full address of the mailbox too, user@domain.com:\Calendar.

I was finally able to run the commands on the O365 mailbox.  It doesn't seem to be yielding and reporting the correct setting though.  At least it's not showing UserB as having any delegates. It's behaving for as though UserB has UserA configured as a delegate here (in Outlook, as pictured below) but there are no values present.

 User generated image
UserA is Tom.  UserB is getting notifications as pictured below.

User generated image

So both cmdlets return nothing? What about message trace, did you run that?


I'd still suggest you run the below cmdlet to "reset" the delegate collection:


Remove-MailboxFolderPermission userA:\calendar -ResetDelegateUserCollection

Open in new window

Run the below in powershell exchange online to view any settings that might be pointing to userB
Get-CalendarProcessing emailaddressofuserA | fl

secondly check the rules of userA
Get-InboxRule -Mailbox emailaddressofuserA  | Select -ExpandProperty:Description
No luck yet it finding the place where this setting is hiding.  Like I said, I suspect it's probably orphaned somewhere.  I think what I'm going to try next is to actually ADD UserA as a delegate for UserB so that it correct setting is in fact where it should be for this behavior to be happening.  I'll then remove them and see if that ties up the loose ends.  I'll follow up on this thread if that's successful.
ASKER CERTIFIED SOLUTION
Avatar of Blair Benjamin
Blair Benjamin
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
It seems as though the notifications have stopped, so I think we can close out this thread.  Thank you to those who contributed.