Link to home
Create AccountLog in
Avatar of Brian Sheppard
Brian SheppardFlag for Canada

asked on

PHP Issues setting timezone etc

Roundcube 1.6.1 gives error on install:

Roundcube Webmail Installer Errors.pdf

I don't know how to correct the php error with concern to date tome Timezone etc. 

Can anyone assist as I have tried to set them:

[Date]

; Defines the default timezone used by the date functions

; http://php.net/date.timezone

date.timezone = America/Glace_Bay


; http://php.net/date.default-latitude

date.default_latitude = 40.8532


; http://php.net/date.default-longitude

date.default_longitude = -8006211


; http://php.net/date.sunrise-zenith

;date.sunrise_zenith = 90.833333


; http://php.net/date.sunset-zenith

;date.sunset_zenith = 90.833333


But can not!

Brian

Avatar of gr8gonzo
gr8gonzo
Flag of United States of America image

Where have you set these? Have you restarted PHP-FPM or the web server after making the changes? Changes to php.ini don't take effect until the server re-reads the file, which happens when the web server starts (or if you're using PHP-FPM, when it starts).

Avatar of Brian Sheppard

ASKER

I have done my changes right in the /etc/php.ini file.
Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = America/Glace_Bay

; http://php.net/date.default-latitude
date.default_latitude = 40.8532

; http://php.net/date.default-longitude
date.default_longitude = -80.0621

; http://php.net/date.sunrise-zenith
;date.sunrise_zenith = 90.833333

; http://php.net/date.sunset-zenith
;date.sunset_zenith = 90.833333

Roundcube-Webmail-Installer-Errors.pdfRoundcube-Webmail-Installer-Errors-2.pdf
Just so you know that now the INTL is the only error after a restart:
Checking PHP extensions

The following modules/extensions are required to run Roundcube:

PCRE:  OK
DOM:  OK
Session:  OK
XML:  OK
Intl:  NOT OK(See https://www.php.net/manual/en/book.intl.php)
JSON:  OK
PDO:  OK
Multibyte:  OK
OpenSSL:  OK
Filter:  OK
Ctype:  OK

Okay. So you just need to install that extension, then. Do you know how to do that? If not, then what operating system is PHP running on?

I am using RHEL 9.0 Plow. And I don't know how to install it.
What dnf or yum do I use?
Brian

You need to keep consistent with how you installed PHP in the past. Did you install PHP using yum?

yes :
https://computingforgeeks.com/how-to-setup-mail-server-on-centos/ 

sudo dnf install -y php-common php-json php-xml php-mbstring php-mysqlnd
SOLUTION
Avatar of gr8gonzo
gr8gonzo
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account

Why did you accept your own comment as the solution?

SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account

Hi Brian,


Right, so you should have selected my first comment as the solution (the one where I talked about restarting the service). And probably the comment about installing the intl extension, too.

Sorry kinda new I'll follow that protocol in the future!
Brian

No problem. It isn't locked down - you can just click the "a solution" link below each comment that is part of the solution.