Link to home
Create AccountLog in
Avatar of Scott Jackson
Scott JacksonFlag for United States of America

asked on

Computers can't see each other on same network

I have two laptops (one running Windows 10 and the other Windows 11) on same wifi network and both set to network discoverable.  However they do not see each other or appear as a network device in Explorer.

Avatar of Mohammad Rummaneh
Mohammad Rummaneh
Flag of Jordan image

maybe windows firewall enabled and this maybe make your laptops undiscoverable

for the testing , just disable windows firewall and check

How are you connecting? If the devices are on a domain, you have to use the FQDN to connect from a computer that *isn't* on the same domain or using a DC as a DNS server. 

Make sure the network is set to PRIVATE in the firewall.

Make sure Network Discovery is enabled. Explorer --> Network --> Enable? YES

Check the settings on your wireless router. Many have an option where you can make the connection private.
Make sure that the Function Discovery Resource Publication service is running.

Can the devices ping each other by IP address?
Avatar of Scott Jackson

ASKER

It is a private setting, firewall is off and Function Discovery Resource Publication service is runnning.
Can the devices ping each other by IP address?
Yes the devices can ping each other fine.
Next is to try:
Start
Run
\\<IP address of other computer>\
OK

Try the same command with replacing the IP address with the name of the other computer.  Keep in mind that if you are successful and sign in to the other using one method (IP vs. name), you'll need to reboot to log in through the other method.

Also, do you have any shared resources (folders, printers) on either device?

Some things to try...

Make sure these services are running  Services.msc:  DHCP Client,  DNS Client, Function Discovery Resource Publication, Function Discovery Provider Host,  SSDP Discovery,  UPnP Device Host

... Network and Sharing Center\Advanced sharing settings
    Private >> Network Discovery  
    Check Box:   Automatic setup of network connected devices  
                           Try leaving it off (if that does not help put it back on)

regedit. Locate: HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
make sure "AllowInsecureGuestAuth" value is set to 1

I also keep this little .bat file for this issue

:: Turns on network discovery
:: requires Administrator
:: https://thegeekpage.com/fix-network-computers-are-not-showing-up-in-windows-10/

netsh advfirewall firewall set rule group="Network Discovery" new enable=Yes

Pause
Could not find registry entry you shared.  Closest I could find was
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PolicyManager\default\LanmanWorkstation\EnableInsecureGuestLogons
And when I attempted to change the "value" it wouldn't let me.
I believe that one is more about file sharing.  I had all these notes saved for discovery and file sharing issues combined.
The Windows 11 laptop now sees the Windows 10 laptop but not vice versa.
Did you try
Start
Run
\\<IP address of other computer>\
OK
?
Yes i had done that
And what was the result?
If it didn't connect, what did happen?

Do the user accounts on both computers have passwords?
When I ping them using the CMD they see each other.
When I view File Explorer on the Windows 11 machine it can see the Windows 10 machine as part of the Network.  But from the Windows 10 it doesn't see the other one.  I even went to my router admin and the network maps say same thing.
Its same user for both and they have same passwords
The suggestions provided need to be applied to both PCs.
They were.
What were the results of the two different \\<....> commands?
They saw each other
Forgive me if you already reported on this, but did you try to use File explorer to manually connect by entering \\pcname or \\IPaddress in the file name?


You know what, I just loaded up a Windows 11 pro on test PC on my network.  I can see it under network in file explorer from my Windows 10 PC -- But I can't see my Windows 10 PC from the Win 11 PC.  Sounds similar to what you have, but the opposite?
I did not use File Explorer.
"I did not use File Explorer."
"or appear as a network device in Explorer"

I'm misunderstanding.  Those seem to contradict each other.
If you enter the \\<PCName>  or enter the \\<IP Address>  in fileexplorer it should show the shared elements on the pc
So I just got my issues resolved.  And I updated my list with a few more items to check

      Services.msc >> Set to automatic(delayed start optional):        
                  DHCP Client
                  DNS Client
                  Function Discovery Provider Host
                  Function Discovery Resource Publication
                  Network Connections
                  Peer Name Resolution Protocol
                  Peer Networking Grouping
                  Peer Networking Identity Manager
                  SSDP Discovery
                  UPnP Device Host


      regedit.       Locate:
HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
                                   make sure "AllowInsecureGuestAuth" value is set to 1

      regedit.       locate  
HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows > CurrentVersion > Policies > System
            Make sure DWORD   EnableLinkedConnections  is set to 1
            If not there, right click and create new DWORD
                                  EnableLinkedConnections and set it to 1

      Programs and features >> Turn Windows features on or off
                All the SMB folders are checked
   

"All the SMB folders are checked": if you are including SMB 1.0 items, there are serious security concerns with that.
When I turn off all SMB 1.0 boxes, all the other PCs on my network stop appearing in FileExplorer >> Network (on windows 11, I didn't check 10).  

Interestingly one of the new Items under SMB 1.0/CIFS (since Windows 7) is
     SMB 1.0/CIFS Automatic Removal.  
The description says it "automatically removes support for legacy SMB V1.0 protocol support, when its not actively needed during normal system usage."  Which indicates to me, unless you are file sharing with an XP box on the network, SMB v1.0 will be off automatically.  

The problem with SMB v1.0, as I understand it, is SMB v1.0 does not support encryption. That means that any attacker who steals a password and logs into an endpoint can capture SMB 1 traffic, view it in plaintext, and even modify the stream to send false commands.  

There must be some function that is included with that feature that affects the ability of FileExplorer to see Windows devices and some (not all) other devices on the network.  

This is not a new issue.  Its been around for years and I assume the rationale for the automatic shut off mechanism.  

This was not found at that registry "AllowInsecureGuestAuth" value is set to 1 

This was not fuond either EnableLinkedConnections is set to 1

I added those DWORDS.  Right click on the parent, select add DWORD, copy and paste the name, then set them to to a value of 1.

I have done so Fred. 

My Windows 10 machine still does not see the Windows 11 machine on File Explorer.

My router sees both machines fine on the Network Map.

Gee Scott, we are nearly out of options.  maybe should review all the suggestions provided once again?  

Forgive me, but I assume you already made sure both PCs are in the same Workgroup and things are set correctly in:
Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings
Like I said forgive me for asking.  

If after reviewing all this stuff, you still can't see the Win 11 PC from the Win 10 PC, maybe try a couple longshots.  

Try running Sfc /scannow and DISM
Try deleting (and driver) your network card, then reboot.
Create a new user on the Win10 PC see if things work.    



ASKER CERTIFIED SOLUTION
Avatar of Scott Jackson
Scott Jackson
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
If you have exhausted all efforts to get the computer to show up in File Explorer, consider mapping drive letters to the folders you want to access.  Those drive letters should show up in File Explorer.

If you are trying to access printers on the other computer, once you install them on the remote computer, they should be available.