Link to home
Start Free TrialLog in
Avatar of Marthaj
MarthajFlag for United States of America

asked on

Installing php with a PHP5.6 tar file on Ubuntu 14.04

I have a php-5.6.35.tar.bz2 file which successfully unpacked.

The OS is Ubuntu 14.04 and I need to use PHP5.6

It created the folder /usr/local/src/php-5.6.35

The instructions I was using -

 https://www.thoughtco.com/installing-php-on-linux-2693997 

Open in new window

Do not work. 

Yes, I know both the Ubuntu 14.04/Php 5.6 are legacy apps - upgrading is not an option at this time. I should be able to install the PHP5.6 on the Ubuntu 14.04 server.

Can anyone help get this installed correctly ?

Any help appreciated.

Thank you.


Avatar of ste5an
ste5an
Flag of Germany image

Well, for which system is this tarball? What errors do you get?
Hi,

You can try using this old tutorial
https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu-14-04

I recommend you to use PHPCommpatibility to test your old application so you can update it asap for security reason.
https://github.com/PHPCompatibility/PHPCompatibility

If this still fails and you need to setup a test environment:

You can try to install Xampp
https://www.apachefriends.org/fr/download.html

Or if you have Windows PC  you can use Wampserver
https://www.wampserver.com/en/
All versions
https://wampserver.aviatechno.net/

Both allow to install multiple PHP, Apache & MYSQL version and switch between the versions
Avatar of Marthaj

ASKER

Thank you both for responding -
The tar ball is specifically for PHP5.6 to be installed on  a Ubuntu 14.04 server. The tar file name is: php-5.6.35.tar.bz.
 Since PHP 5.6 is no longer available in ppa repositiories  is the reason I am using a tar ball.
 The OS needs to Ubuntu 14.04 with Apache 2.4 and Php5.6
I think I have found the issue. Testing it out now,.
Avatar of noci
noci

php up to 8.0 (and soon 8.0) is non-supported.  No updates etc.
Ubuntu 14 is non-supported, non updated etc.

Consider upgrading to supported (and bug-fixed systems).
systems from April 2014 (release date for Ubuntu 14) is supported for about 5-6 years.
With recent openssl (fith several MAJOR security fixes).
If you really need to run Ubuntu 14..., ensure it is NOT reachable in any way shape or form from the internet.
(Although it's security is better than windows from the same age..., it lacks really important updates).
https://endoflife.software/operating-systems/linux/ubuntu
Avatar of Marthaj

ASKER

Thank you for responding.
noci - Yes, the Ubuntu 14.04 and Php5.6 are both very much legacy software. And yes, it needs to be updated. No doubt!!  :)
There are plans to upgrade it. The legacy application is not going to be on a 'live Internet server' but needs to be loaded on a 'closed' environment that has no connection to the Internet etc. for reviews etc.
ASKER CERTIFIED SOLUTION
Avatar of Marthaj
Marthaj
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial