Link to home
Create AccountLog in
Avatar of Julie
JulieFlag for United States of America

asked on

Cannot RDP to computer even thought it's enabled

I had to re-image a Windows 10 PC on a domain and since then, the computer will not accept any RDP connections. I have followed this article: https://learn.microsoft.com/en-us/windows-server/remote/remote-desktop-services/troubleshoot/rdp-error-general-troubleshooting and the weird thing is that after I deleted the self signed certificate, it did not regenerate it, but the MachineKeyFolder permissions are correct. I don't know what else to try. I have turned off AntiVirus (Trend Micro) and tried both DHCP and static IPs. All the settings I know of for RDP are enabled. This user works remotely and relies on RDP to connect to her computer through VPN. Other computers on the network accept VPN connections.

Avatar of NVIT
NVIT
Flag of United States of America image

Can the re imaged station be seen in the domain?

Try re joining to domain
The link you gave shows an error

"404 - Page not found"

Alternatively, try the troubleshooting steps on this page are the same: https://learn.microsoft.com/en-us/windows-server/remote/remote-desktop-services/troubleshoot/rdp-error-general-troubleshooting
Avatar of Julie

ASKER

Yes, it is on the domain, can access all domain resources, printers, mapped drives, can see other domain members, can even RDP to other computers. It shouldn't need to be on a domain for RDP. I have many offices I support that are on workgroups and can use the VPN and them RDP to a computer to work remotely. All these factors make me think it is unrelated to the domain.

I don't know why my link didn't copy correctly but your link is exactly what I tried. Nothing worked.
You mention that users are trying to access it through a VPN.  Are they able to ping it?  Have you tried to RDP to it from a computer on the same network?
Always test locally as compprobsolv suggested.

Can you connect using psexec?
To check netmask?


Avatar of Julie

ASKER

I think I got it solved. I enabled file & printer sharing to be able to ping. I changed the firewall to allow RDP and now it works.

Thanks you all of your for your suggestions. I think I am okay on this one. So strange that I have never had this issue before in the 20 years I have been setting up computers for this client. The only thing I did differently was to join it to the domain remotely. Maybe that was it.
Glad to hear you got it working.

A good starting point when RDP won't work is to disable AV, disable the firewall (on the computer), and test locally.  If that works, you can move back one step at a time and see where the problem is.
ASKER CERTIFIED SOLUTION
Avatar of Julie
Julie
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account