Link to home
Start Free TrialLog in
Avatar of Robert Ehinger
Robert EhingerFlag for United States of America

asked on

Problem trying to install Windows

I have 2 HP laptops.One is a 17-cn0108ds and the other is a 15-dy4008cy. I am trying to install larger SSD drives in both but when trying to install Windows I get this error on both - We Couldn’t Find Any Drives. To Get a Storage Driver, Click Load Driver. 

I have tried loading the storage driver from the HP site but none of them are the correct driver, I have updated the BIOS, tried installing from a CD and tried loading from a bootable USB device with no success. 

Please advise.


Thank you!

Robert




Avatar of ☠ MASQ ☠
☠ MASQ ☠

Would be useful to know which SSDs you're trying to install to but in the meantime have a look at this thread for a suggested approach.

https://www.experts-exchange.com/questions/29257914/Hard-drive-not-shown-when-installing-windows-10Pro-on-HP-3010-laptop.html?anchorAnswerId=43525063#a43525063

For the 15-dy4008cy you need sp139242
https://ftp.hp.com/pub/softpaq/sp139001-139500/sp139242.exe

For the 17-cn0108ds you need sp134215
https://ftp.hp.com/pub/softpaq/sp134001-134500/sp134215.exe

have you verified the drives are seen in the bios?

post a picture of the bios screen showing the drives - or where they should be displayed
if the bios is UEFI - you can try setting it to legacy mode ( turning safe boot off)
Avatar of Robert Ehinger

ASKER

In the 17" laptop I ma using a Silicon Power PCIe Gen 3x4 M.2 2280 SSD P34A60. If I try using sp134215 and check the option to hide all non-compatible drivers, no drivers appear. If I uncheck that option there are several drivers but none successfully install. The drive I am replacing is HP PN M17197-001. PM991a NVMe 256GB.
Secure boot is disabled.
BIOS screen shot attached.


BIOS-Screen.jpg
https://ftp.hp.com/pub/softpaq/sp135501-136000/sp135890.exe
Is the alternative F6 driver block for this model

Ask Seth asked earlier does the M.2 appear in the BIOS?  It's not explicitly listed in your screenshot.
That screen shot is exactly the same as when I reinstall the original SSD that already has an OS and will allow the laptop to boot. In fact, if I try to do a clean install of Windows on to original SSD drive I get the same error.
Also, I do not see an option to enable legacy devices.
and in the main section?
if all fails, contact HP    https://www.hp.com/be-nl/contact-hp/contact.html      for NL, you can choose another country
Find Create Windows 10 installation media on the page below.
click the "Download Now" button
Follow the instructions to create installation media on a different PC
The media then supports both EUFI and MBR boot.  

https://www.microsoft.com/en-us/software-download 
Fred Hakim - that is exactly the method I have been trying to use but I get the same error using a DVD to install.
I am attaching all the BIOS screens so if someone can tell me how to enable legacy devices from them it would be greatly appreciated.
BIOS-Main-Screen.jpg
BIOS-Security-Screen.jpg
BIOS-Configuration-Screen.jpg
BIOS-Boot-Order-Screen.jpg
And the sp135890.exe download produces a different, but equally useless, choice of drivers?
If so unpack the whole of the unpacked file and try once more.
The laptop uses Intel's SoC (System on a Chip) hardware.
AFAIK with these models your only option is Secure Boot is On or Off not, really the same as Legacy Boot .  Just turns off cyptographic checking of the operating system to prevent unauthorised changes.  The frustration here is not being completely sure that the M.2 is correctly installed or if it's simply the installer not functioning as expected. Either way it's more difficult than it should be.

Going off on a slight tangent how familiar are you with Rufus as an installer?  That builds a specific UEFI installer from the Windows .iso, might be another approach , just a thought ...
I did that and get the same result.
The frustration here is not being completely sure that the M.2 is correctly installed - I get the same error with the original SSD - tha one with an OS that will allow to lapto to boot.
ASKER CERTIFIED SOLUTION
Avatar of ☠ MASQ ☠
☠ MASQ ☠

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
It makes no sense but now I can load Windows.
You've simply beaten it into submission :)
it often happens after manipulating several commands orr settings, that what i call "the stuck bit" that holds your system from booting - is reset. in bios  i usually try default settings for that ( after making a note of the original settings)