Link to home
Create AccountLog in
Avatar of Paul Ralph
Paul Ralph

asked on

LACP in suspended state Cisco Nexus 91380 to Cisco Nexus 91380

Hi,


I am trying to set up 2 cisco Nexus 93180 ver 9.3(11) with lacp between them one port channel will always be in the Suspend state whether I have them set as trunk ports or access ports. any help would be greatly appreciated. 


 I have ran the following commands on both switches:

switch A  

Top_of_Rack(config)# interface port-channel 2

Top_of_Rack(config-if)# inter e1/53-54

Top_of_Rack(config-if-range)# switchport

Top_of_Rack(config-if-range)# channel-group 2 mode active

command failed: port not compatible [port mode]

** You can use force option to override the port's parameters

** (e.g. "channel-group X force")

** Use "show port-channel compatibility-parameters" to get more information on failure


Top_of_Rack(config-if-range)# switchport mode access

Warning: If the interface is configured with mappings, all the associated mappings would be removed when port mode is changed

Warning: If the interface is configured with mappings, all the associated mappings would be removed when port mode is changed

Top_of_Rack(config-if-range)# switchport mode access

Top_of_Rack(config-if-range)# channel-group 2 mode active

Top_of_Rack(config-if-range)# show port-channel summary

Flags:  D - Down        P - Up in port-channel (members)

        I - Individual  H - Hot-standby (LACP only)

        s - Suspended   r - Module-removed

        b - BFD Session Wait

        S - Switched    R - Routed

        U - Up (port-channel)

        p - Up in delay-lacp mode (member)

        M - Not in use. Min-links not met

--------------------------------------------------------------------------------

Group Port-       Type     Protocol  Member Ports

      Channel

--------------------------------------------------------------------------------

1     Po1(SD)     Eth      LACP      Eth1/49(D)   Eth1/50(D)

2     Po2(SD)     Eth      LACP      Eth1/53(s)   Eth1/54(s)

Top_of_Rack(config-if-range)#



When I run cmd show interface e1/53-54  brief:


Top_of_Rack(config-if-range)# show interface e1/53-54 brief


--------------------------------------------------------------------------------

Ethernet        VLAN    Type Mode   Status  Reason                 Speed     Port

Interface                                                                    Ch #

--------------------------------------------------------------------------------

Eth1/53         1       eth  access down    suspended(no LACP PDUs)  auto(D) 2

Eth1/54         1       eth  access down    suspended(no LACP PDUs)  auto(D) 2

Top_of_Rack(config-if-range)#



this is the running-config of switch A

!Command: show running-config

!Running configuration last done at: Mon Apr 17 15:47:49 2023

!Time: Mon Apr 17 15:53:12 2023


version 9.3(11) Bios:version 05.47

switchname Top_of_Rack

vdc Top_of_Rack id 1

  limit-resource vlan minimum 16 maximum 4094

  limit-resource vrf minimum 2 maximum 4096

  limit-resource port-channel minimum 0 maximum 511

  limit-resource u4route-mem minimum 248 maximum 248

  limit-resource u6route-mem minimum 96 maximum 96

  limit-resource m4route-mem minimum 58 maximum 58

  limit-resource m6route-mem minimum 8 maximum 8



feature telnet

feature lacp


system default switchport



vlan 1


vrf context management

  ip route 0.0.0.0/0 192.168.0.1


interface port-channel1

  description Top of Rack to Stack Switch

  switchport mode trunk

  switchport trunk allowed vlan 12

  lacp min-links 2


interface port-channel2




interface Ethernet1/49

  switchport mode trunk

  switchport trunk allowed vlan 12

  channel-group 1 mode active


interface Ethernet1/50

  switchport mode trunk

  switchport trunk allowed vlan 12

  channel-group 1 mode active


interface Ethernet1/51


interface Ethernet1/52


interface Ethernet1/53

  channel-group 2 mode active


interface Ethernet1/54

  channel-group 2 mode active


interface mgmt0

  vrf member management

  ip address 192.168.0.15/24

line console

line vty

boot nxos bootflash:/nxos.9.3.11.bin

no system default switchport shutdown



  SWITCH B:

LC_CORE(config-vlan)# config

LC_CORE(config)# show port-channel summary

Flags:  D - Down        P - Up in port-channel (members)

        I - Individual  H - Hot-standby (LACP only)

        s - Suspended   r - Module-removed

        b - BFD Session Wait

        S - Switched    R - Routed

        U - Up (port-channel)

        p - Up in delay-lacp mode (member)

        M - Not in use. Min-links not met

--------------------------------------------------------------------------------

Group Port-       Type     Protocol  Member Ports

      Channel

--------------------------------------------------------------------------------

2     Po2(SD)     Eth      LACP      Eth1/53(D)   Eth1/54(D)

3     Po3(SD)     Eth      LACP      Eth1/1(D)    Eth1/2(D)    Eth1/3(D)

                                     Eth1/4(D)

4     Po4(SD)     Eth      LACP      Eth1/17(D)   Eth1/18(D)

5     Po5(SD)     Eth      LACP      Eth1/19(D)   Eth1/20(D)

LC_CORE(config)# LC_CORE(config-vlan)# config


LC_CORE(config)# show inter e1/49-50 brief


--------------------------------------------------------------------------------

Ethernet        VLAN    Type Mode   Status  Reason                 Speed     Port

Interface                                                                    Ch #

--------------------------------------------------------------------------------

Eth1/49         1       eth  trunk  up      none                     100G(D) --

Eth1/50         1       eth  trunk  up      none                     100G(D) --

LC_CORE(config)#

 

LC_CORE(config)# show running-config


!Command: show running-config

!Running configuration last done at: Mon Apr 17 16:34:15 2023

!Time: Mon Apr 17 16:43:27 2023


version 9.3(11) Bios:version 05.47

switchname LC_CORE

vdc LC_CORE id 1

  limit-resource vlan minimum 16 maximum 4094

  limit-resource vrf minimum 2 maximum 4096

  limit-resource port-channel minimum 0 maximum 511

  limit-resource u4route-mem minimum 248 maximum 248

  limit-resource u6route-mem minimum 96 maximum 96

  limit-resource m4route-mem minimum 58 maximum 58

  limit-resource m6route-mem minimum 8 maximum 8



feature telnet

feature lacp



ntp server 192.168.0.55 use-vrf default


vlan 1,12,17,900-903

vlan 12

  name Internal_Wifi

vlan 17

  name Voice

vlan 900

  name Pure_ISCSi

vlan 901

  name Pure_Replication

vlan 902

  name VMWARE_VMotion

vlan 903

  name Provisioning


vrf context management

  ip route 0.0.0.0/0 192.168.0.1


interface port-channel2

  description Uplink from Top of Rack Switch

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  lacp min-links 2


interface port-channel3

  description Uplink to HP Stack

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  lacp min-links 2

  lacp max-bundle 8


interface port-channel4

  description CATO 1

  switchport mode trunk

  switchport trunk allowed vlan 1,10,12,17

  lacp min-links 2

  lacp max-bundle 8


interface port-channel5

  description CATO 2

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  lacp min-links 2

  lacp max-bundle 8


interface Ethernet1/1

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  channel-group 3 mode active


interface Ethernet1/2

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  channel-group 3 mode active


interface Ethernet1/3

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  channel-group 3 mode active


interface Ethernet1/4

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  channel-group 3 mode active



interface Ethernet1/17

  switchport mode trunk

  switchport trunk allowed vlan 1,10,12,17

  channel-group 4 mode active


interface Ethernet1/18

  switchport mode trunk

  switchport trunk allowed vlan 1,10,12,17

  channel-group 4 mode active


interface Ethernet1/19

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  channel-group 5 mode active


interface Ethernet1/20

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  channel-group 5 mode active




interface Ethernet1/49

  switchport mode trunk


interface Ethernet1/50

  switchport mode trunk


interface Ethernet1/51


interface Ethernet1/52


interface Ethernet1/53

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  channel-group 2 mode active


interface Ethernet1/54

  switchport mode trunk

  switchport trunk allowed vlan 1,12,17

  channel-group 2 mode active


interface mgmt0

  vrf member management

  ip address 192.168.0.16/24

line console

line vty

boot nxos bootflash:/nxos.9.3.11.bin

no system default switchport shutdown


ASKER CERTIFIED SOLUTION
Avatar of Craig Beck
Craig Beck
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Paul Ralph
Paul Ralph

ASKER

Thank you Craig I will try your suggestion.  also I am very new to configuring Cisco hardware I a learning on the fly here.