[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More



An assembly language (or assembler language) is a low-level programming language for a computer or other programmable device in which there is a very strong (generally one-to-one) correspondence between the language and the architecture's machine code instructions. Each assembly language is specific to a particular computer architecture, in contrast to most high-level programming languages, which are generally portable across multiple architectures, but require interpreting or compiling. Assembly language is converted into executable machine code by a utility program referred to as an assembler; the conversion process is referred to as assembly, or assembling the code.

Share tech news, updates, or what's on your mind.

Sign up to Post

CRM 2013, Dynamics 365 online

I am looking for a method to test plugins converted for D365 from CRM 2013.  With a Dev environment, how can this be done using Visual Studio and the PRT?

Ideas are: on Dev, if we register the plug-in assembly, ,register a plug-in step for an event and test its execution by doing whatever is shown in the code.  For example, step through the code as a plugin and test that it performs the actions in the CRM 2013.

Questions: can Visual Studio be used in Debug mode to step through the code and provide an adequate test?  Can the PRT be used to view the registered plugin and verify that the plugin ran as expected?

Learn SQL Server Core 2016
LVL 12
Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

Binary bomb phase 3
I am having trouble understanding this part of my bomb lab. I am not sure where to go from here. I know that I need to figure out what two decimals values will make the program not explode. I have attached the assembly code for reference.
   0x0000000000400ffd <+0>:     sub    $0x18,%rsp
   0x0000000000401001 <+4>:     mov    %fs:0x28,%rax
   0x000000000040100a <+13>:    mov    %rax,0x8(%rsp)
   0x000000000040100f <+18>:    xor    %eax,%eax
   0x0000000000401011 <+20>:    lea    0x4(%rsp),%rcx
   0x0000000000401016 <+25>:    mov    %rsp,%rdx
   0x0000000000401019 <+28>:    mov    $0x402b5b,%esi
   0x000000000040101e <+33>:    callq 0x400c90 <__isoc99_sscanf@plt>
   0x0000000000401023 <+38>:    cmp    $0x1,%eax
   0x0000000000401026 <+41>:    jg     0x40102d <phase_3+48>
   0x0000000000401028 <+43>:    callq 0x4017e4 <explode_bomb>
   0x000000000040102d <+48>:    cmpl   $0x7,(%rsp)
   0x0000000000401031 <+52>:    ja     0x4010ca <phase_3+205>
   0x0000000000401037 <+58>:    mov    (%rsp),%eax
   0x000000000040103a <+61>:    jmpq   *0x402840(,%rax,8)
   0x0000000000401041 <+68>:    cmpl   $0x68,0x4(%rsp)
   0x0000000000401046 <+73>:    je     0x4010cf <phase_3+210>
   0x000000000040104c <+79>:    callq 0x4017e4 <explode_bomb>
   0x0000000000401051 <+84>:    jmp    0x4010cf <phase_3+210>
   0x0000000000401053 <+86>:    cmpl   $0x126,0x4(%rsp)
   0x000000000040105b <+94>:    je     0x4010cf <phase_3+210>
   0x000000000040105d <+96>:    callq 0x4017e4 

Open in new window


We have a simple application that was done by a predecessor. All it does is allows users to enter 'item numbers' and send to print. The item data is saved on a separate excel sheet in the same folder. All dll files, EXE. file and excel file are in the same folder. I've just copied this folder to a new machine trying to replicate the process. I can run the application but when I click send to print button on the application I get below error;

"Unhandled exception has occurred in your application if you click continue the application will..."

"could not load file or assembly microsoft.reportviewer.common version="

I've tried installing the relevant files for above exceptions. However, think this is to do more with the 'Print' button on the application and coding behind it.
Please see attached.

Can someone advise what I need to do to get this to work please?

Thanks in advance.
I have a .Net Framework (4.6.1) class library project (call it A).
Then I have a UWP app (call it B), and I want to use the code in A by referencing to A from B. But that is not possible. UWP apps are .Net Core and not compatible with .Net Framework.

So I created a .Netstandard 2.0.3 class library project (call it C), to be a proxy between A and B. I now reference from A (the UWP app) to C (the .Netstandard class library), and then from C to B (the .Net framework class library).

Everything compiles now, but when I run/debug the UWP app in Visual Studio I get the following error originating from the code in A:

System.IO.FileNotFoundException: 'Could not load file or assembly 'System.Web.ApplicationServices, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35'. The system cannot find the file specified.'

System.Web.ApplicationServices is a .Net Framework reference in A, and is not compatible with B. I was hoping to get around this by using .Net standard and C as a proxy between A and B.

Any suggestions on how to fix this?

Code examples won't help here, the code works fine, but not the integration between the various technologies.
Accountant sends us tax returns as password protected PDFs (password needed to open it.  Properties says it was created with Thomson Reuters FileCabinet CS.  The security tab says I can print, copy contents, comment, etc (I can do everything execpt doc assembly and page extraction, whatever those are : )

I click on them in outlook, it opens in Acrobat Reader DC ( free version) - this is on a windows 10 pro machine by the way.

I want to keep a PDF without the password.  So print to PDF?  But they get sooo much larger

Working on it now, he sent a 24 page PDF that is 93kb

trying different apps:

microsoft print to PDF - 673kb
Tried printing with PDF Creator, but it balks because PDF is password protected (to open, and printing is allowed).  WTF!


Tried opening in chrome.  printing w/ microsoft print to pdf made it a 5MB file!  And still can't use pdf creator.

What's a good combination for opening & printing a PDF or some other easy way to strip off password protection to open a PDF
Take a string input and make only the first letter of every word in the string uppercase and display the result on assembly language

i use assembler emu8086
When I compile someone c# code, I got the following warning.  What do I need to resolve this? Any idea?

The primary reference "xxxConfiguration" could not be resolved because it has an indirect dependency on the assembly "xxxAsync, Version=, Culture=neutral, PublicKeyToken=58aa7495915e0000" which was built against the ".NETFramework,Version=v4.6" framework. This is a higher version than the currently targeted framework ".NETFramework,Version=v4.5".
I have an access database that I am converting to a vb.net project.  There are a few lines of script that are causing issues.  Mostly the DLookup conversion.  Any help at converting this script would be most appreciated.  Thank you in advance!

Here is the original VBA code:

Private Sub Form_Timer()
'On Error GoTo ErrTrap:
    Dim DB As Database
    Dim rs As Recordset
    Dim count As Integer
    Dim displayCount As Integer
    Dim formToOpen As String
    Dim stopTime As Date
    Dim nowTime As Date
    Dim WinWnd As Long
    'Determine if a member of management has set an alert message. If not, continue normal operations
    If DLookup("Alert", "AlertMessage", "Alert > 0") <> "" Then
        'Open the alert message
        DoCmd.OpenForm ("frmMessage")
        Call Form_Query
        'Run the NRFT screen for 1 minute, then open the safety message
        If runCount = 2 Then
            DoCmd.OpenForm ("Form1")
        End If
        'Close the safety message after 1 minute
        If runCount = 5 Then
            DoCmd.Close acForm, "Form1"
        End If

        If runCount >= 8 Then
            'Loop through all rows in the Content table where Active is set to yes
            'For Count = 0 To DCount("Active", "Content", …
I have an ASP.NET web forms project, currently running in .net 4.5 version. I am trying to migrate the source code to bitbucket. I pushed the code and compiled the project successfully. when I try to run the project, I get an runtime error shown below -

Could not load file or assembly <add assembly="System.Web.Helpers, Version=, Culture=neutral  ....

In the project, under references I see system.web.helpers.dll, but the inside the folder  (C:\documents\repos\myproject\bin\System.Web.Helpers.dll )  the dll is not there.

when i go to nuget package manager , and search for system.web.helpers.dll , I can't find it.

Questions -

1. Is this dll no longer available and is replaced by something else?
2. I suppose, when the project was created initially, a reference to dll was added to the project. and looking at the folder path for the dll in the project ( C:\documents\repos\myproject\bin\System.Web.Helpers.dll), when i did a clean build the dll must have been deleted . when the dll was added initially, was it supposed to be in the bin folder?
3. or was this dll availabe in older version of .net ? if i update the .net framework version, I would probably need to update other dlls too, which I am trying to avoid.
4. what are best practices in such situations?

My SCCM 2012 server having problem getting update. Ps advice the error below. Tks

SMS_WSUS_Control_Manager (Tread: 8068 0x1F84)
System.Net.WebException: The request failed with HTTP status 503: Service Unavailable.~~   at Microsoft.UpdateServices.Administration.AdminProxy.CreateUpdateServer(Object[] args)~~   at Microsoft.UpdateServices.Administration.AdminProxy.GetUpdateServer()~~   at Microsoft.SystemsManagementServer.WSUS.WSUSServer.ConnectToWSUSServer(String ServerName, Boolean UseSSL, Int32 PortNumber)

Failed to create assembly name object for Microsoft.UpdateServices.Administration. Error = 0x80131701.
C++ 11 Fundamentals
LVL 12
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Problem statement: I am trying to do a writeback through .NET assembly stored procedure in SSAS - Multidimensional Cube

Are there any server level settings ? or any additional roles setting?

**Note: User is already an admin.

The .NET code works perfectly fine when debugged from the visual studio, the connection to the server works and the cube update also works.

1) When created an assembly using the dll file from .NET class library in the SSAS server, the calling of assembly stored procedure fails and throws error as follows;
a) Assembly Permission set : Safe/External Access
"Executing the query ...
Query (1, 6) Execution of the managed stored procedure UpdateCube failed with the following error: Exception has been thrown by the target of an invocation.Request for the permission of type 'System.Data.OleDb.OleDbPermission, System.Data, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed..
Run complete"
b) Assembly Permission set : Unrestricted
"Executing the query ...
Query (1, 6) Execution of the managed stored procedure UpdateCube failed with the following error: Exception has been thrown by the target of an invocation.An error was encountered in the transport layer.
The peer prematurely closed the connection..
Run complete"

Attached my .cs code which I build to obtain the dll file and then create an assembly on SSAS.
using System.Data;
using System.Data.SqlClient;
using System.Data.SqlTypes;
using Microsoft.SqlServer.Server;

using System.Collections.Generic;
using System.ComponentModel;

using System.Drawing;
using System.Text;
using System.IO;
using System.IO.Ports;
using System.Threading;
using System.Text.RegularExpressions;
using System;

public partial class StoredProcedures
    public static void SqlStoredProcedure1(string strPortName, string strBaudRate, String strPhone, String StrMsg)
            bool sms_status;
        SerialPort port = new SerialPort();
        port.PortName = strPortName;
        port.BaudRate = Convert.ToInt32(strBaudRate);               //updated by Anila (9600)
        port.DataBits = 8;
        port.StopBits = StopBits.One;
        port.Parity = Parity.None;
        port.ReadTimeout = 300;
        port.WriteTimeout = 300;
        port.Encoding = Encoding.GetEncoding("iso-8859-1");
        //  port.DataReceived += new SerialDataReceivedEventHandler(port_DataReceived);
        port.DtrEnable = true;
        port.RtsEnable = true;
        StoredProcedures p = new StoredProcedures();
        sms_status = p.sendMsg(port, strPortName, strBaudRate, strPhone, StrMsg);
        catch (Exception ex)
            throw ex;

    public AutoResetEvent receiveNow;

    //Close Port
    public void ClosePort(SerialPort port)

Open in new window

Hi Experts,

I have an application with a reference to Microsoft.SQLServer.BatchParser.dll
I have a problem when I install my application with batchparser (version 9 - SQL2005) and try to update it to batchparser (version 14 - SQL2017)

The assembly is in the directory of the application, but when I try to run the application I get the error message "Could not find file or assembly 'Microsoft.'SqlServer.BatchParser.dll' or one of its dependencies. The specified module could not be found".

Is it possible to update this assembly by copying it to the application directory? Because this is an update, I do not want to manually register or install anything.
I have tried building my application in x86 instead of AnyCPU, but still have the problem.
Create assembly [SMS_Attend]
from 'C:\Users\Muhammad\Documents\Visual Studio 2015\Projects\Database3\Database3\bin\Debug\Database3.dll'
with permission_set = unsafe

Open in new window

CREATE ASSEMBLY failed because it could not open the physical file 'C:\Users\Muhammad\Documents\Visual Studio 2015\Projects\Database3\Database3\bin\Debug\Database3.dll': 5(Access is denied.).

Hello. I am working with floating point numbers in x86 assembly. I am doing an effort to understand the IEEE 754 document. I have no official document from IEEE. I am running this as an beginner with no budget enough to buy it. That is other problem.

I am facing it learning from open resources. How can I write a custom floating point number and load it into x86 registers? I want to see the program working with exact bits. Example. The program treats the sign bit, the exponent 8 bits and the 23 bits mantissa.

The idea is to supervise the work done. I am using OllyDbg as my tool to see behaviour of the program running in my machine. My machine is x86-based. I am working with Assembly. Some nice C code explaining it could be nice too.

I have no source code yet about this.

Please, thanks.
Hello. I am building an assembly program. I have no skills yet in this field. I am mainly a C++ programmer.

I am studying stack frames. I am set up a frame for a particular function, and it works. But when i call another function, it crashes.

I don't know how to set up it properly. I am tried setting up a stack frame from start but i dont' appears to do nothing. It crashes too.

Here is my original code. I don't know how to set up properly the stack frame.
;Copyright(c) Jorge Enrique Mesa Mosquera
;All rights reserved.

;-Write a function and call it properly from the main body.
include 'win32ax.inc' ; you can simply switch between win32ax, win32wx, win64ax and win64wx here

;Print a string
;Ask for username
;Print a string
;Ask for password
;Look up in table for right matching credentials
;If the credentials exists, then create a file with the credentials.

;Print a message asking for username
;Ask for a username string
;Save username string in a string variable

;Print a message asking for password
;Ask for a password string
;Save password string in a string variable.

;Check if the



        call function_enrique

        call function_enrique2
        invoke  ExitProcess,0

;Enrique is a function that receives four parameters, and show a message box using Win API
        push ebp
        mov ebp, esp
        sub esp, 16
        ;push edi     ; Save the values of registers that the function
  ;push esi     ; will 

Open in new window

I have an assembly on a customer SQL Server that has been working for a year flawlessly
It passes data to a web service
Their server is a SQL 2008R2

I have the SAME Assembly loaded on a SQL 2008R2 of our own

Neither have been changed
All of a sudden the customer is timing out with the attached error

I can run the same process on my server virtually instantaneously

Any ideas?

Msg 6522, Level 16, State 2, Line 2
A .NET Framework error occurred during execution of user-defined routine or aggregate "EverywareGTG": 
System.NullReferenceException: Object reference not set to an instance of an object.
   at HelloEveryware.PassIn.GTG(String user, String token, String PID, String OID, String TSW_ID, String FirstName, String LastName, String IsOwner, String EmailAddress, String AccomName, String AccomAddress, String AccomState, String CheckinDate, String CheckinTime, String CheckoutTime, String AccomNights, String TourDate_Disp, String TourWave, String TourLocation, String ContactUsPhone, String DateAdded, String SendNow, String AccomCreationDate, String AccomPhone, String ActivitySeason, String CampaignName, String CancellationPeriod, String CheckinDate_Disp, String CheckInDayOfWeek, String CheckoutDate, String CheckoutDate_Disp, String ContactUsEmail, String ContactUsSignature, String OpenDate, String OpenExpirationDate, String OpenExpirationDate_Unix, String OpenMonths, String OwnerAgentName, String OwnerLottoPreferenceLevel, 

Open in new window

Hi,  I have another error in my .NET application.

"Could not load file or assembly 'Microsoft.Practices.EnterpriseLibrary.Common, Version=5.0.414.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. "

C# web service calling another .NET assembly using reflection
I use a web service to a run-time assembly call using C# Reflection.
The assembly is in Binary format in database. All records contains a binary data which is almost same in structure. It has a Start method in a class called 'MyAssembly'
First I loads assembly object using  the Binary data, then finds the type - MyAssembly from it and then calls a method 'Start'. The start will write the logs into a directory. This works entirely fine when we call from an executable. All executables goes into separate process ID and the results are getting.

Then calling the same step using a Web service hosted in IIS, the results are getting messed up. Simultaneous calls to the same method gets the results into different different calls.
Example: Method1 called using web service and the logs are writing into File1.
Method1 again called using different arguments and the logs are writing into File2.
When calling method1 two times at the same point of time using web service, gets the logs messed up, File1 details are showing in File2 and File2 are in File1. It is not only the logs issue bug also the execution are getting wrong that inner methods are not getting proper outputs and return values. Everything messed up.

When the web service is calling EXE program (Which is not allowed in so many conditions) - That is without finding out the method using reflection and then calling it, it just calls an exe program using …
Python 3 Fundamentals
LVL 12
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

I'm following the example on https://docs.microsoft.com/en-gb/visualstudio/test/walkthrough-creating-and-running-unit-tests-for-managed-code
to learn about unit testing.
When I add the reference to Bank.sln I'm getting a message:

A reference to D:\Documents\UnitTesting\Bank\Bank.sln could not be added.  Please make sure that the file is accessible, and that it is a valid assembly or COM component.
Could it be because Visual Studio 2017 is installed on my C drive and this project is on my D drive?  I'm using C#.net
I am learning assembly, and using TASM. When running code, I can't watch the registers. But now I am working with 32bit registers, and I don't know where to view and follow them in the debugger. Can someone help me please?
I want a program for 100ms dealy in 8086  microprocessor
About half our class turned in this assignment on its due date; many of us are lost. Even though it's past-due, it's been nagging me, and I'm curious to find out how it works. I come here, hoping someone will be able to guide me, as to what I need to know about this diagram in order to answer its accompanying questions.

Here is what I know:

  • "Sequential instruction execution" is where each instruction is fetched and executed to completion before the next one begins.
  • The `popl` instruction moves the data element from the top of the stack/register into the specified operand.
  • `%esp` is the stack pointer

I want to need a code of simple game with description in assembly language Masm
For e.g.
Tic tac toe game
hi, i want to ask opinion from experts regarding die attach process in semiconductor industry.

paste use for die attach is epoxy sumitomo crm 1084. i want to seek advice what is the best method for thawing process of this epoxy? currently the  storage is kept at temperature -40C and for thawing process is put the syringe vertically for 1 hour at room temperature.

I'm thinking of thawing it for 1 hour at toom temperature in slow moving situation. is it give better impact in overcome void inside epoxy problem or it will create more void by thawing in motion .

thank you expert


An assembly language (or assembler language) is a low-level programming language for a computer or other programmable device in which there is a very strong (generally one-to-one) correspondence between the language and the architecture's machine code instructions. Each assembly language is specific to a particular computer architecture, in contrast to most high-level programming languages, which are generally portable across multiple architectures, but require interpreting or compiling. Assembly language is converted into executable machine code by a utility program referred to as an assembler; the conversion process is referred to as assembly, or assembling the code.

Top Experts In