We help IT Professionals succeed at work.

AWS

Amazon Web Services (AWS), is a collection of remote computing services, also called web services, that make up a cloud-computing platform  operated from 11 geographical regions across the world. The most central and well-known of these services include Amazon Elastic Compute Cloud, also known as "EC2", and Amazon Simple Storage Service, also known as "S3". Other services include Elastic MapReduce (EMR), Route 53 (a DNS web service),  provides a highly available and scalable Domain Name System (DNS) web service, Virtual Private Cloud (VPC), storage, database, deployment and application services.

HI,

Hi I have done some calculations and have all my results in one row across a number of columns.

 Percent 1 percent 2, percent3

I would like to pivot these so i have 2 columns,

Percents.      Total

Percent1 0.64
Percent2 0.22
Etc
0
Finding MySQL on my MacBook and remote DB access

I think I used to access MySQL from the browser (Chrome) on localhost, but I do not recall the exact URL.

Can someone explain how to find MySQL?

Also, I have a developer who will be hosting my website, not yet at AWS, but on an internal server. Can I view that database from my version of MySQL? I would of course need to be given access. I will access the website from an IP address I will be given.

Thanks.
0
Have an application in VC++ VS2017 that runs fine on hundreds of PCs.   I'm now trying to run this code on an AWS windows server and my code crashes when it attempts to call entry points in gdiplus.dll

I can see that gdiplus.dll exists on the server in windows/system32.   If I try a regsvr32 on it, it fails.

Also the version of gdiplus.dll on this server is slightly older than the one I use elsewhere.

What is recommended course of action?
0
My CIO came to me and suggested we investigate moving our domain controller to the cloud.  His rational is that we use it for authentication from all of our devices.  We have several sites that have their own internet connection, but we have a VPN connection from each of the sites for authentication.  He thinks that when people log in it slows down our internet, so with that said he wants us to look into it.

I have done some research and everyone says AWS or Microsoft Azure AD Services, but I have no clue where to start.  I also understand that this migration does not take into affect the GPO's which we rely on.  Our domain server houses not only our AD, but our DHCP and DNS.  Can someone point me in the right direction so I can at least start to make some sense out of this project.
0
Sorry for the newb sounding question.

I am starting a project in with AWS and I am trying to find a CDN location for the AWS Cognito js files.

I have looked all over the AWS documents for Cognito and was not able to find the information that I need.

Not for sure if I am asking the right questions.  I just want to be able to pull the js files without having to put them on my server.

Thank you
0
Hi Experts,
We are using AWS SFTP. For most of the users SSH key is used for authetication. But one user needs a password. Is there anyway we can create a password?

Thanks in advance!
0
Hi, I am hoping someone can help.

 I have a DC in AWS running Server 2019. I have installed routing and remote access onto to enable people to VPN in. I have installed routing and remote access before with no issue, but never with AWS.

Summary:

MS VPN Only - not NAT
MS Firewall on / off - no change
AWS Ports open in security group (1723, 500, 4500) - also tried all ports opening
MS EAP & MS Chap2 enabled
MS Network policy checked, nothing obvious
MS Firewall log shows accepting connections from 500 & 4500 but nothing else
AWS Source / Destination check turned off

When trying to connect, just times out.
Replicated settings (the best I could on a 2016 server on test bed - not AWS) works fine.

Two errors found in MS logs:

The Secure Socket Tunneling Protocol service could not be configured to accept incoming connections. The detailed error message is provided below. Correct the problem and restart the SSTP service. Access is denied.

&

CoId={FF5DF464-E1D4-6134-CD72-E0129DDF54A2}: The following error occurred in the Point to Point Protocol module on port: VPN2-127, UserName: <Unauthenticated User>. Negotiation timed out


Going out of my mind with this, any ideas?
0
Adding a Windows 10 Hosted VDI on AWS

I thought this would be simple on AWS. But, when I try and "Launch an Instance" and look through the various Windows options, I see only Windows Server?

Isn't a Windows 10 Desktop VDI considered an Instance?

What am I missing?

Thanks
0
We are currently have a large amount of data we want to back up to a safe location. All of our IT infrastructure including servers and storage (Dell EMC) are located on premise. We have a gateway server that allows our servers to connect to the Internet. The data doesn't need to be accessible constantly. We only need to retrieve the data when there is a catastrophic event on premise. We are looking into AWS Glacier as our solution; however, we have couple concerns:

. Can we just use the AWS Glacier service without using any other AWS services to upload and to retrieve our data?
. Our data is currently located on an Isilon that doesn't have direct access to the outside Internet? Can we set up so that we can upload/retrieve data from the Isilon to AWS Glacier?
. The files and folders we want to back up to AWS contain very large graphic files. The files can go up to couple hundred Gibs. Will speed be an issue?
0
I have a WordPress site running a LAMP stack in AWS (Amazon Linux).

The version of PHP I have is:

PHP 7.0.33 (cli) (built: Jan  9 2019 22:04:26) ( NTS )

Open in new window


I noticed that the latest version of PHP is 7.3, available via the AWS Package Manager as:

sudo yum install -y php73

Open in new window


If I was to install this version of PHP are there any WordPress Configuration changed I'd need to make?

Thanks!
0
We have a Synology NAS and would like to do a daily cloud backup.

I am looking for a suggestion as to the overall best cloud server.

We do our local backups using Hyper Backup and it seems to work OK.

I have tried using Hyper Backup to AWS cloud. For me, not a good solution.

We have about 2000 gigs of data with about 400 megs getting modified daily.

This whole external cloud backup is new to me.
0
I need to install a Let's Encrypt SAN Certificate, so that multiple domains can use Let's Encrypt. I am currently running AWS Linux (basically RedHat). Does anyone have a good "go to" set of directions on how to create a Let's Encrypt SAN Certificate on AWS Linux?

Thanks
0
I have a Wordpress site on a LAMP Stack running in AWS. I have Let's Encrypt running to automatically update the TLS Certificate and I re-direct all traffic to the "www." instance for the purposes of SEO.

The site works as expected for EVERY browser EXCEPT Safari. What I mean is that I've tried Chrome, Firefox, Opera, Vivaldi and Internet Explorer. I made not changes to the Server itself and I'm a little perplexed as to what happened. Below is a screenshot from some testing I was doing using BrowserStack. This seems to be happening on all Safari browsers back to iOS7.

Any idea what's going on here? Is this fixable from my end?

wordpress-site-safari-anomaly.jpg
0
I'm having issues with my haproxy servers (running Ubuntu 16.04) rejecting new connections (or timing them out) after a certain threshold. The proxy servers are AWS c5.large EC2's with 2 cpus and 4GB of ram. The same configuration is used for both connection types on our site, we have one for websocket connections which typically have between 2K-4K concurrent connections and a request rate of about 10/s. The other is for normal web traffic with nginx as the backend with about 400-500 concurrent connections and a request rate of about 100-150/s. Typical cpu usage for both is about 3-5% on the haproxy process, with 2-3% of the memory used for the websocket proxy (40-60MB) and 1-3% of the memory used for the web proxy (30-40MB).

Per the attached config, the cpus are mapped across both cpus, with one process and two threads running. Both types of traffic are typically 95% (or higher) SSL traffic. I've watched the proxy info using watch -n 1 'echo "show info" | socat unix:/run/haproxy/admin.sock -' to see if I'm hitting any of my limits, which does not seem to be the case.

During high traffic time, and when we start to see issues, is when our websocket concurrent connections gets up to about 5K and web requests rate gets up to 400 requests/s. I mention both servers here because I know the config can handle the high concurrent connections and request rate, but I'm missing some other resource limit being reached. Under …
0
Hi
I think I am ready to roll on my final proper game coding.

I can get html/javascript code running from my local OS X XAMPP  7.2 local server, of course, w MacBook IP address..but is isn't always-up, and I need it always on.

But, for an intended final product, I've been looking at the options for a real-world type dev system.

It looks like Amazon Web Services has very reasonable options for eventual monthly billing. here

I'll use the free tier.
For now, I need only the ability to put a simple page up that can load a device .io game in html and serve the game code to the player browser / device correctly.
Is that what gameLift is suited for? If I put my working .io game directory in my Godaddy space, it doesn't work. I apologize for bringing up Godaddy again. It'll be the last time, I hope. So, gamelift can serve an .htm that pulls up its .io code?
Is gamelift mainly for MMO games / games w player accounts?
I'd say that - My first game - .io game - is most similar to games like word-scapes and Drag-'n-Merge, not yet fortnite or Slither.io

Thanks
0
I've got questions about GDPR and CCPA data deletion requests and backup sets. Its pretty straight forward to remove a person that has asked for data deletion from our production environment. My problem is our backup set and machine snapshots stored in AWS or Azure. I cannot find much information about whether or not we would be in compliance if we didnt delete data contained in encrypted/password protected incremental backup sets. Does anyone have any experience with this?
0
I am new to AWS RDS. We have SQL server in Azure, not SQL Azure. I think AWS RDS, like SQL Azure is Platform as a Service (PaaS), not  infrastructure as a service;. I want to know if this is correct statement.

I have MS 2016  Always-on cluster. What is the benefits if we want to do AWS RDS.

What is pros and cons for AWS RDS vs not just AWS?
0
private void submitCallablesWithExecutor()
				throws InterruptedException, ExecutionException, TimeoutException {

			ExecutorService executorService = null;

			try {
				executorService = Executors.newCachedThreadPool();

				Future<String> task1Future = executorService.submit(new Callable<String>() {

					public String call() {
						try {
							processExportRequest(xmlPutRequest_, customizedRequest_, response_);
							return "Success";
						} catch (Exception ex) {
							return ex.getMessage();
						}
					}
				});

			} finally {
				executorService.shutdown();

				try {
					if (!executorService.awaitTermination(800, TimeUnit.MILLISECONDS)) {
						executorService.shutdownNow();
					}
				} catch (InterruptedException e) {
					executorService.shutdownNow();
				}
			}
		}

Open in new window


within processExportRequest I am calling upload to S3.  I have tried both S3Client and S3AsyncClient.  In both cases, I am getting following error:

Failed to upload to S3: java.lang.IllegalStateException: Interrupted waiting to refresh the value.

I don't see anywhere in my code that's calling Thread.interrupt(), and everything else seems to work fine, just not S3 upload.  Maybe the multithreaded nature of Java Future is not compatible with AWS SDK?  Thanks.
0
I have a Wordpress site running on a LAMP stack running in AWS EC2 that got compromised today. The hacker encrypted the small MySQL database with a Bitcoin address instead of the expected tables.

I would like to install some AntiVirus and Malware software as a future deterrent. It wouldn’t have done me a lot of good in this case, but I realized that the folks before me didn’t set this up.

1/ Do you have any recommendations for software that plays nicely with Amazon Linux (basically RedHat)?

2/ Do you have a favorite set of “go-to” installation and configuration instructions that you could share? I need something fairly simple to setup & automate updating heuristics and protecting the system.

Thanks for your help!
0
I am looking to set up and EC2 server to process files, potentially user uploaded , but they could be saved in S3 and processed later as a nightly job or something similar. I don't know if having a EC2 server is better or this can be simply done by a lambda.

my org has lot of ec2 servers and s3 buckets, if I wanted to add some code , what else do I need to set up apart from giving read/write permission to the s3 objects/buckets. do I need to set up a different user, or any other rules . I don't think vpc is needed.

and what about the security, if I allow users to upload files and eventually save it to the s3 bucket?
0
I want to upload a file to S3 bucket, but my company want to use IAM role as opposed to access keys.  This is AWS documentation on how to upload to S3 asynchronously:

S3AsyncClient client = S3AsyncClient.create();
		CompletableFuture<PutObjectResponse> future = client.putObject(
				PutObjectRequest.builder().bucket(BUCKET)
						.key(fileName)
						.build(),
				AsyncRequestBody
						.fromFile(fromFile.toPath()));
		future.whenComplete((resp, err) -> {
			try {
				if (resp != null) {
					System.out.println("my response: " + resp);
				} else {
					// Handle error
					err.printStackTrace();
				}
			} finally {
				// Lets the application shut down. Only close the client when
				// you are completely done with it.
				client.close();
				
			}
		});

		future.join();
	}

Open in new window


I don't see anywhere to put in IAM role info.  I tried to put it in ~/.aws/credentials in this form:

[useraccount]
aws_access_key_id=<key>
aws_secret_access_key=<secret>

[somerole]
role_arn=<the ARN of the role you want to assume>
source_profile=useraccount

but so far haven't gotten it to work.  I read somewhere you need to use STSAssumeRoleSessionCredentialsProvider but didn't see any good examples.  My main question is do I even need to do anything if I already assigned the IAM role to an ECS instance.  Can someone help me?   Thanks.
0
I plan to use Amazon Aurora Serverless  (MySQL-compatible ) , but to build locally can I install mysql locally or we have to connect to the aws right from the start?
0
I am running below from my mac laptop

ssh -f -N -T -R2222:localhost:22 ec2-user@app.my_aws_host.com

Open in new window


and per my understanding when I do below below from any other ssh client then I should be connected ( ssh ) to my mac laptop

ssh ec2-user@app.my_aws_host.com -p 2222

Open in new window


But I am getting connection refused error. Appreciate any help here

P.S: port 2222 is open in my security group in AWS
0
Hi Experts,
Trying to read and come up with a technical details on how to design multi cloud architecture for a Proof of concept

Basically what I'm thinking
1. Simple application (hello world) running on a container
2. Deployed above app in Azure as primary site
3. as a secondary site deploy and shut down as a standby
4. Global dns setup and pointing to Azure LB
5. Deliberately fail Azure, so it fail over to AWS and scale out.

Just trying to get high level technical details considering above scenario. Later plan is to automate through terraform.

This is just for POC :)

thanks in advance
0
We are subscribing to Teammate SaaS (that's hosted in AWS)
& our data to be hosted is deemed sensitive.

Q1:
by default is data at rest encrypted by default (whether it's
default offering by AWS or by Teammate)?

Q2:
Is backup offered by default (by Teammate or by AWS?) or
this is an optional item that we must subscribe/purchase
separately?

Q3:
For data sovereignty purpose, can we specify to Teammate
(or is it AWS) that the data must be hosted in AWS DC in
the local country only & not 'synced' to overseas?
0

AWS

Amazon Web Services (AWS), is a collection of remote computing services, also called web services, that make up a cloud-computing platform  operated from 11 geographical regions across the world. The most central and well-known of these services include Amazon Elastic Compute Cloud, also known as "EC2", and Amazon Simple Storage Service, also known as "S3". Other services include Elastic MapReduce (EMR), Route 53 (a DNS web service),  provides a highly available and scalable Domain Name System (DNS) web service, Virtual Private Cloud (VPC), storage, database, deployment and application services.