Components are those devices that are internal to a computer -- the PC boards, the central processor (CPU), the memory (RAM), disk and video controllers and so on.

Share tech news, updates, or what's on your mind.

Sign up to Post

I am looking for a dock that reads old IDE, Ultra IDE, and also old smaller laptop HDs as well as any type of SATA HDs.  I would prefer one with a USB 3.0 connection.  I've looked all over and haven't been able to find someone that offers one.  One other option that I just thought of would be to use some type of converter with it with one end of the converter going to the HD and the other end going to the dock.  Example old IDE drive connected to the converter and then the converter connected to the dock.  Please advise if you can find a dock that will connect them directly with the dock and if there are converters available, and if so, will they work with a dock.
My company has an Epson Expression 1680 scanner that has stopped working. The manual for this scanner has been attached to this question. Epson-1680-scanner-exp168uu4.pdf

We need to order a replacement scanner and have found this scanner for sale on Amazon:

(which is identified as an "EPSON 1680 - EPSON PERFECTION 1680 W/ADF" scanner.

My question about this scanner listed for sale on Amazon is whether or not it is the exact same model as our existing Epson Expression 1680 scanner.

We need to make sure that we order the exact same model scanner.

I have already asked this question on Amazon but haven't yet received a reply.
I have an EPSON Expression 1680 scanner that won't power on.

I have replaced the power cord with several known good power cords and have plugged this scanner into different power plugs but it still won't power on.

What can I do to troubleshoot or fix this issue?

Does this scanner have a fuse or similar item that can be replaced that might fix this issue?

Attached is the manual for this scanner.

Please provide me with the URL addresses orFRU numbers I can use to purchase a second battery pack for Lenovo Ideapad Yoga 910-13IKB Laptop so that I can have a total of two batteries connected to my Lenovo laptop at the same time.

The serial number for this laptop is PF0QV5V6.
Machine is HP Pavilion HPE h8-1100z
BIOS is corrupted by malware.
No access to OS, installing new OS not possible.

How can one recover (re-flash) the BIOS?
From an USB drive yes, but HP's Hardware Diagnostics utility does not support any of the Pavilion HPE for BIOS recovery..
Has anyone recovered the BIOS on a Pavilion HPE lately? The BIOS update exe (from HP support site) does not offer anymore the option of creating an USB drive.

Any other option other than recycling this expensive machine?
I have a new Samsung Galaxy S9 which replaces a Samsung Galaxy S6 and I have two issues which are probably connected:

a) I cannot use the App "Wifi File Transfer Pro" - when I launch the App on the phone it gives an IP address to enter into my browser on the PC, but when I enter this address it will not bring up the page - the connection eventually times out; on the Galaxy S6 this works perfectly

b) I have an app I have written in Java which has components running on the phone and my PC, which I use for transferring various files between the phone and my PC - again this has worked perfectly for many years on the Galaxy S6, but on the S9 it fails to connect:  the phone component successfully wakes up the PC component which does its thing and then tries to connect to send the result, but the java command connection=new Socket(host, PORT) times out with the error message " Connection timed out: connect"

It looks like a firewall issue, but it's not the firewall on my PC since I've tried disabling that temporarily.   It may be a firewall issue on the Samsung S9 but I can't see how to configure that.   I've tried tweaking the Setting "Phone visibility" but that doesn't seem to solve the issue.

Any thoughts?
I need to purchase power adapters for two  Asus MX79 monitors.

Please provide me with the URL addresses of where I can purchase these adapters from.

I would prefer to purchase these power adapters from Amazon.

This is the model number of the monitor.

Asus MX79 monitor
I have an old psi which I want to convert to a 12v power supply for some led lights.
 The problem is that in cleaning out the dust before I got started the green wire has broken off the board.
 Where does it solder back onto as I cannot identify where it broke off from.

 Thanks for your help in advance.
I'm looking for some adapters that will allow me to connect and boot from M.2 drives by connecting these drives to Serial ATA (SATA) cables.

What adapters or connectors will allow this to be done?

Windows 10 1709

Windows Update is blocked via GPO with policies below:-

Computer Configuration > Administrative Templates > Windows Components > Windows Update

- Configure Automatic Updates = Disabled
- Do not allow update referral polices to cause scans against windows update = Enabled
- Do not connect to any windows update internet locations = Enabled

Computer Configuration > Administrative Templates > Windows Components > Windows Update  > Windows Update for Business

- Select when preview builds and feature updates are received = Enabled
- Select the windows readiness level for the updates you want to receive = Semi-annual channel
- After a preview build or feature update is released - defer receiving for 180 days

User Configuration > Administrative Templates > Windows Components > Windows Update 

- remove access to all windows update features = enabled
- configure notifications = 0 - do not show any notifications

But Windows still keeps trying to download and install updates despite it clearly showing in Settings > Windows Update that "Some settings are managed by your organization"

And still getting notifications about updates

What are we missing?????
There is a VB6 application that uses ADODB to connect to LDAP and do a lot of operations, there is an LDAP Attribute (field) called "co-unit" and when the application runs specifically on Windows 8 (it has been tested on other OSs and works 100%) generates an "Unspecified error (-2147467259)" error and after analyzing the source code it was discovered that the problem is that when trying to run the Querye it does not accept any field that contains in its name the hyphen, for example co-unit , no-drive, dt-creation, etc ...

I have already searched in numerous forums including MVPs and other professionals but I have not been able to find any solution, because it seems that this problem should never have occurred.

I would like to know if there is anyone who can help me and give a light to solve this problem, I have tried everything, changed components, tried to get the Attribute through ADSPath among other ways and none gave result giving the same error.

You are my last attempt to help.

I'm waiting for some help from someone.

Excerpt from code that generates error:

sqlStmt = "SELECT uid, co-unit, cn" & _
    "FROM 'LDAP: //" & m_LDAPServer & ":" & m_LDAPPort & "/ o =" & m_Org & "/ ou =" & m_OrgPeople &
    "WHERE uid = '" & m_User & "'" & "and objectClass = '*'"
    'executes the data string ...
A Microsoft Surface Pro 3 displays the message "Plugged in not charging" while connected to any known good dock but charges just fine while it is undocked and connected to a power adapter (which uses the same power connection that is used with the dock).

We have replaced the Surface Pro 3 dock power connection with several other known good power connectors and the same issue continues to occur.

Also whenever any other Microsoft Surface Pro 3 is connected to this dock these other Microsoft Surface Pro 3's charge just fine while they are docked.

What can be done to fix this issue so that the Microsoft Surface Pro 3 will charge while it is connected to the dock?
I have a new computer build and it does not seem to be working.  I push the power button and all the fans start spinning, the processor is clearly getting hot (when I put the fan on the processor it was solid and now some of the compound is on the processor) and the hard drive and cd drive spin, but it does not go beyond that.  I, unfortunately, do not have a system speaker (I have random Dell computers, but the speakers on those are five pin and this motherboard has four pins).  I plugged the computer into both a vga and hdmi video port but nothing displays at all.  The motherboard is: GA-78LMT-USB3 R2 with an FX-8300 AMD processor and 16 GB of 1333mhz DDR3 memory.  The case, not that it matters, I don't think is: ROSEWILL Micro ATX Mini Tower Computer Case, Steel and plastic computer case with 1x 80mm rear fan, Top I/O ports: 1x USB3.0, 2x USB 2.0 and Audio In/Out ports (SRM-01).
What are some good PCI Express peripheral cards that will allow M.2 SATA drives to be connected and accessible within Windows 10 and Server 2016 running on that computer?

I often need to connect laptop M.2 SATA drives to my Windows 10 desktop computer or Server 2016 server and have found the USB to M.2 SATA drive connectors to be quite flimsy and troublesome.

So I'm looking for some good PCI Express peripheral cards that will allow M.2 SATA drives to be connected to my desktop computer or server.

I have HP Z420 workstation with Windows 7 x64, AHCI drivers (warranty expired 5 days ago) which is not working after Bios update to the latest Bios (3.92). The computer starts and all of the fans start, all of the lights (on motherboard, etc.) are fine too. However, there is not POST beep and the power supply's fan keeps going slow and then fast, then slow and fast, then slow and fast, and then at full speed and then slow and fast.
* Removed all of the devices and cars and usb sticks from the computer (including graphics card)
* Removed all of the memory RAM sticks and left only one
* Tried different memory (but from the same PC) stick in other slots
* Followed the Clear CMOS instructions from HP manual
* Removed motherboard's battery
* Each time when trying something I would unplug the power cable and press the power button to clear left charge
* Tried another power supply which blew up (I mean the smoke started coming from that)
* Plugged original power supply and back to the square 1 so it does not look like the other power supply damaged anything

A. The question is how do I fix that motherboard?

Just to let you know: I obtained another motherboard and power supply from ebay, all used, and the computer is working fine, except:
1. the used motherboard has much older bios 3.18 and during the startup comes up with "incorrect microcode detected" error message, pressing F1 to boot makes it go away and the computer works fine and Windows …
What pins on an Intel S2600cp server system board are used for plugging in the connectors for the USB ports on the front of the server's case?

Attached are the manual and reference specs guide for the Intel S2600cp server system board.

I have built two servers containing Intel S2600CP server boards.

These server boards are connected to a Raidmax Cobra Power 1200W 80 Plus Gold Power Supply.

The problem is that these "Raidmax Cobra Power 1200W 80 Plus Gold Power Supplies" don't have the right kind of power connectors for connecting to the connectors on the Intel S2600 CP server system boards next to the two CPUs. They contain a six pin connector and a detachable 2 pin connector.

The main power connector that comes from these power supplies that connects to the server system board plugs in without any issues; the problem is that the two other smaller power connectors that plug into the server system board (next to the CPUs) have only six pins instead of the eight that are needed.

When just the six pin connector is connected to these two locations on the server system boards the server system boards won't power on and produce a lot of beep codes (and nothing displays on the monitor). The same thing happens when the other two detachable pins are connected alongside these six pin power connectors.

So I'm hoping that there are adapters or cables I can buy that will plug into these "Raidmax Cobra Power 1200W 80 Plus Gold Power Supplies" on one end and that will then plug into the two eight-pin connectors on the server system board (next to the CPUs).

What sort of adapters or cables are available that will allow me to use the "Raidmax Cobra Power 1200W 80 Plus Gold Power Supplies" with these…
How citrix xenapp works , what are the components required like cirix receiver? etc
I am wondering whether to buy a 240Hz monitor for my sons to use for gaming.  How does fps relate to refresh rate? One has a GTX 750Ti and the other has a GTX 960. Both of them say that they are capable of a 240Hz refresh rate but when they play their games they never seem to get an fps of more than about 170. Does that mean that the graphics card would be able to cause a 240Hz monitor to refresh at 240Hz but that the change in image would actually only occur 170 times per second - a bit like having the monitor sample 240 time per second an image that is changing 170 times per second?

Essentially, does this mean that until they get a graphics card which is capable of an fps that is closer to 240, then a 144Hz monitor would perform in a similar way to a 240Hz monitor?

Thank you
Can graphics cards be used with Intel Kaby Lake-G MCM or do you have to use the AMD integrated on the chip graphics?

See here:,5536.html

Note:  Make sure and scroll down on the page for info on the processors.  It is after the barebones info.
Here's a very simple one.

I need to build some weird adapter for a PC's VGA (15 pin, 3 row D-SUB / DE15 / HD15) port, and I want to buy a case for it with the correct screw type.
Wherever I read about that plug type, two types of screws are mentioned:

  • M3 (metric)
  • UNC 4-40

Any hint (link to some official spec sheet, etc.) what screw type is standard for the VGA port ?
I'm using the WMI Diag Tool 2.2 on a Windows Server 2008 R2. Been trying to figure out what the problem is. Seems I am missing classes that help monitor diagnostics on the server.
Here is the output from the file. This is the report. I also have the log file.

31989 13:27:14 (0) ** WMIDiag v2.2 started on Tuesday, March 20, 2018 at 13:18.
31990 13:27:14 (0) ** 
31991 13:27:14 (0) ** Copyright (c) Microsoft Corporation. All rights reserved - July 2007.
31992 13:27:14 (0) ** 
31993 13:27:14 (0) ** This script is not supported under any Microsoft standard support program or service.
31994 13:27:14 (0) ** The script is provided AS IS without warranty of any kind. Microsoft further disclaims all
31995 13:27:14 (0) ** implied warranties including, without limitation, any implied warranties of merchantability
31996 13:27:14 (0) ** or of fitness for a particular purpose. The entire risk arising out of the use or performance
31997 13:27:14 (0) ** of the scripts and documentation remains with you. In no event shall Microsoft, its authors,
31998 13:27:14 (0) ** or anyone else involved in the creation, production, or delivery of the script be liable for
31999 13:27:14 (0) ** any damages whatsoever (including, without limitation, damages for loss of business profits,
32000 13:27:14 (0) ** business interruption, loss of business information, or other pecuniary loss) arising out of
32001 13:27:14 (0) ** the use of or inability to use the script or documentation, even if Microsoft 

Open in new window

I am wondering if anyone can help me understand what can fix this problem.  The embedded picture is not my actual machine, but rather something I saw online.  On my machine,
 I see a lot of input drops and I am wondering what is causing that.  Is it that my computer processor (Quad Core Duo), a problem with my capture card (BlackMagic), a problem with the program (Adobe Live Media Encoder) or a problem with my Internet (50mbps)?  Screen capture
1. What are the screw sizes for an APC SMT1500RM2U Uninterruptable Power Supply (UPS) lid?

2. Where can I order these replacement screws from?

Someone else unscrewed the screws holding the lid cover on this UPS and didn't save them.

I would like to replace these screws but need to make sure I order or buy the right kind and size.
Issue with internet explorer 11 loading activex related components. Worked last week, and now our internal/external applications are not loading. Nothing has changed in our systems either. Specifically, the error is "this webpage wants to run "LEADTOOLS main active x control, which isn't compatible with internet explorers enhanced security features. If you trust this site, you can disable enhanced protected mode for this site and allow the control to run".

Has anyone come across this issue? First off we do not have enhanced security features enabled.

Any help would be appreciated.






Components are those devices that are internal to a computer -- the PC boards, the central processor (CPU), the memory (RAM), disk and video controllers and so on.