DB Dev Tools

Development in most programming languages is done with an editor or integrated development environment (IDE). Dev Tools covers issues with the use of that software, rather than the actual programming being written. XCode, Visual Studio and Eclipse are some of the more popular development tools.

Share tech news, updates, or what's on your mind.

Sign up to Post

I have a predefined powerpoint template that has charts in it (doughnut chart) . I have to alter the chart values in powerpoint template using the excel data. Is there a way to do this?

Thanks
Sheshi
0
Basically I have two timer calls in my framewindow's event timer for different purposes like this:
//timer1
Timer(60, this) //for doing something
if FileExists("file.htm") then
  //timer2
  Timer(0, this)
  //some additional code
end if

They seem to interfere. Is there some way they coexist? Or should I use the one minute timer for both tasks and hope for the best?
0
is anyone experienced in edirectory customization pls
0
I have installed Oracle 21c. I want to practice with SQL Developer. I have not paid for the product. How do I practice with it free?
0
I have to develop an app for MS Excel 2013. What do I need for that? Can I do that with Windows 7 and Visual Studio 2013 Professional?
0
vs2012 user
I have a combo box bound to data source
Is there a way to see at least 2 fields from the dataset in the dropdown mode before I select the dropdown item I want to commit to the field (left click the mouse)
Right click on the Item will do but I don't see that event
any help would be appreciated.
0
hi am having the following eror when i start my toad IDEERROR IN MY TOAD IDE
0
Hello Expert,

Working on if statement in Python

import time
import datetime
ts = time.time()
month = datetime.datetime.fromtimestamp(ts).strftime('%m')
print month
if month == 01:
    print "January"

Expected
01
January

Result
01

Actually this is two questions
1. Why does it not print out 'January'?

2. When an error in syntax is made the IDLE
returns a message like
Traceback (most recent call last):
  File "F:/Archive/Python/date_3.py", line 2, in <module>
    month = datetime.datetime.fromtimestamp(ts).strftime('%m')
NameError: name 'datetime' is not defined
But other times it doesn't return anything, it just
doesn't work. Why is that?

Thanks

Allen in Dallas
0
hi i have the following query  ,but am geting this error ora-01489: result of string concatenation is too long
how can i work around this

select
c.obj_name , obj_childs, obj_parents,d.Obj_type ,d.description,d.sub_system
from
(select  obj_name, LISTAGG(obj_child, ',') WITHIN GROUP (ORDER BY obj_child)  obj_childs
 from
 (select distinct c.obj_name,
          oc.obj_name obj_child
   from cal_obj c,
   cal_erd_link ec,
   cal_obj oc
   where ec.obj_parent(+) = c.obj_name  
   and   ec.obj_child  = oc.obj_name(+) 
 )
 group by obj_name
 ) c
,
(select obj_name, LISTAGG(obj_parent, ',') WITHIN GROUP (ORDER BY obj_parent)  obj_parents
 from
 (select distinct c.obj_name,
         op.obj_name obj_parent
   from cal_obj c,
   cal_erd_link ep ,
   cal_obj op
   where ep.obj_child(+)  = c.obj_name  
   and   ep.obj_parent = op.obj_name(+)
 )
 group by obj_name
 ) p
, cal_obj d
where c.obj_name = p.obj_name
and   d.obj_name = c.obj_name

how can i immpelent this functions in my sql
xmlagg
or this

select owner, type_name, coll_type, elem_type_name, upper_bound, length 
 from all_coll_types
 where elem_type_name = 'VARCHAR2';
e.g. on my db, I can use sys.DBMSOUTPUT_LINESARRAY which is a varray of considerable size.

or to_clob
select department, 
       cast(collect(name) as sys.DBMSOUTPUT_LINESARRAY) 
  from emp 
 group by department;

Open in new window

0
I have a Claims EOM Snapshot Dimension.  Every time I add new or changed data to this dimension, I receive errors when I go into SSAS and try to process my Cube.  It states that the ClaimsEOMKey doesn't exist, but in fact it does...at least it does in the equivalent database dimension.  How do I refresh the SSAS Dimension w/the new/changed data?  I refreshed the DSV, but that didn't help.
Please see attached...
Experts-Exchange-SSAS-Cube-Processing-Er
0
Hello experts,

Working on using IF statement in Python
Tutorial at
https://docs.python.org/2/tutorial/controlflow.html#if-statements

>>> x = int(raw_input("Please enter an integer: "))
Please enter an integer: 42
>>> if x < 0:
...     x = 0
...     print 'Negative changed to zero'
... elif x == 0:
...     print 'Zero'
... elif x == 1:
...     print 'Single'
... else:
...     print 'More'
...
More

This has the input and the output so removed output and got

x = int(raw_input("Please enter an integer: "))
if x < 0:
     x = 0
     print 'Negative changed to zero'
    elif x == 0:
     print 'Zero'
     elif x == 1:
     print 'Single'
     else:
     print 'More'

When I run the code in the IDE
it prompts for the integer But then
It does nothing just the >>> 

Why does it not execute the code after the
input?

Thanks

Allen In Dallas
0
We have so many ways that our users need to drill down to see their data.  I am creating various hierarchies to accomplish this.  However, I keep running into attribute values appearing more than once in some hierarchies.  I can understand why this would happen, but am looking for a solution as to how to avoid this.  Please see the attached...
Experts-Exchange-Hierarchy-Question.docx
0
Hello!
I am IT developer airline company
We are about to develop a tablet application for crew members, which allows to monitor passenger information on the board.

The idea is next – dynamically create interactive seat map of airplane.

Crew members would be able to click on particular seat, for instance 12B, and detail view shows passenger information.

We are not sure about platform and technology we want to use, the most probable platform is Windows 8.
, so we think That Xamarin can help us, but we want to make sure that it will satisfy our requirements.
Also, we have a license on Devexpress. Mostly, we use .net.

How do you think, is it safisfying enough technology for this task.

What controls I can use to draw an interface.  Do you have sample best practice solution for drawing seat map for similar tasks? What are your suggestions?

Something simmilar
http://www.seatguru.com/airlines/Air_China/Air_China_Boeing_737-800.php
0
Visual Studio is no longer showing my app on first build. I have to do a build sometimes 2 or 3 times before it shows my app. It was all working fine but then I stupidly not do a backup for 2 months and then used find and replace (never do that again). I went through the code and changed them all back or I think all of them. But now when ever I change any code I have to build it 2 or 3 times before it will show my app. Once it does show it the win form app it all works fine.

Please help this is driving me mad.
0
I am trying to set up a database to manipulate files and, when done, I need to export those files in a tab-delimited text format for import into another application. I found one solution posted on the exchange but I can't get it to work.
0
Hello, How are you?

I have this error:

Error      1      error C2536: 'Address::Address::Enemys' : cannot specify explicit initializer for arrays

class Address{
public:
	static Address& Instance(){
		static Address addr;
		return addr;
	}
	const DWORD Enemys[64] = { 0 };
}

Open in new window


I was searching in Google, and it says this is a bug.


I'm using Visual Studio Community 2013 Update 4.

What i do? I need to use singleton.

Ty!
0
Hi,

We are looking for a distributed cache application which could be installed upon our servers and share the data. we shall require a 1000 transactions per seconds pace of data transactions. we need the cache to have the ability to share the data in this pace, allow to add additional servers, run on Windows-2008-R2\2012.
We are looking for a known and proved cache storage, we prefer a free or a low cost application.
What could be recommened?

Thanks
0
Hi,

I am facing a major challenge. My team is based in city which requires almost 2 hours of commute daily on one side. I am proposing working from home for my team members if they deliver on expectation and deliver or beat the sprint velocity all the time.

My senior management is objecting to it for the following reasons

1. Severe impact on collaboration
2. Severe impact on innovation
3. Severe impact on productivity and misuse of the freedom

I don't quite agree to this and want to quote that open source software is built using distributed teams with no authority and is still able to innovate significantly.

What are your thoughts on this ? I don't want my team to burn out of commute and I would rather make them more productive by working from for at least 2 or 3 days in the week

please share all your experiences

happy new yea
-anshu
0
The question is very subjective but I find myself stuck in mud and I need fuel to think so I'll waste the smallest amount of time possible to become a "real" programmer and start finding a small junior job.

I've been fiddling for two years (coursera, code school, books, online resources) with Python and the good old LAMP stack (with superpowers given by jquery and jquery mobile).

Last week I've decided to start doing things with method and I've discovered yeoman and other incredible tools like AngularJS.

I felt like I've wasted months on doing things that AngularJS does in seconds and in a very clean and readable way.

It has been both great and terrible: am I wasting time trying to use old technologies?

Should I start focusin on the MEAN stack instead of LAMP?

What is the world looking for now?

I feel lost.

I would like to use Python instead of PHP to handle my backend but maybe it is not the right tool for fast and agile web development... Flask, Bottle, Django...

Then there's Ruby...

Everyone wants their applications to work on mobile too so there's Cordova, Phonegap... Headache!

So many differencies, so many questions, so many problems.

I've thought much about where to ask for what to do but Experts Exchange is the only place that gave me the rights suggestions about beginning to study and therefore I'm here, again, to seek help.

May your new years be filled with hacking and success!
0
I'm making a cross compiler using crosstool-NG and I've got as far as running configure, make, make install, ct-ng <my preconfigured toolchain> then when I try to do the ct-ng buid
I get an error saying:
Missing: 'i686-pc-linux-gnu-gcj' or 'gcj' : either needed!

what is i686-pc-linux-gnu-gcj? A library? A compiler? I can't find anything other that a couple vague references to it buried in some file listing doing a google search.
0
This is my first time using a RadHtmlChart and I have almost exactly what I need, but the final piece of the puzzle is eluding me. Below is what I'm trying to achieve. It's the red line I'm trying to get. Ideally I would also like the line labeled "Target", but I can live without that. I don't care how it's done. Turning the 90% line red, adding a line over the 90% line, adding another field to my SQL query if that would work, or pretty much any solution that will get me there.

Bar Chart
0
Hi Experts:

I have searched on this and am still not certain of what I need to do.

I have VS2010.
I have been asked to learn a complex .sln developed by another developer. I have the source code and opened the .sln; however, one of the projects (a .csproj) is returned with "this project is incompatible with the current version of Visual Studio".

After searching the web, I tried opening the .csproj to check/change the .net settings, but doing so opened the entire .sln (something I suspect with the complexity of the .sln). My version of .net is already 4.5.1 but I understand VS2010 likes 4.0

This has left me with the decision to 'upgrade' to VS2012.
I am old-school (I admit) and I thought I'd be able to buy and upgrade, but from what I understand, to get VS2012 I need to upgrade my MSDN license. Here's my question/problem:

1. How do I determine if I already have purchased an MSDN license w/ my 2010? It is 'Pro' and I've been looking hi and lo for some kind of indication that I do or do-not have a license. I installed it a long time ago and I honestly don't know. When I launch VS2010 and go to 'Help >> MSDN Forums" - it responds ... so at least it doesn't tell me I don't have one ..(?)
2. If I don't have an existing license ... how do I go about getting VS2012? It isn't an upgrade I guess, so much as a side-by-side installation. My searches indicate it'll run me about $500.

So what I need is some best-practices advice on how to get VS2012 (or VS2013). I …
0
How do I in VB.NET code pass a parameter to a DevExpress Dashboard when I load the DashboardViewer in code?  This is an existing parameter I created in the Dashboard that filters the data being loaded from the server.  Thanks.
0
Hi,

i am trying to use an xslt to convert .xml to .xml , but i am not sure how to


How do i change the following xml
<FS>
<Captions>
                                                <Caption id="1">Income</Caption>
                                                <Caption id="2">-Deductions</Caption>
                                                <Caption id="3">-Expenses</Caption>
                                                <Caption id="4">=Net income</Caption>
                                                <Caption id="5">Income limit to qualify</Caption>
  </Captions>
</FS>

to the below xml using an xslt

<FS>
<Captions>
                                                <Caption1>Income</Caption1>
                                                <Caption2>-Deductions</Caption2>
                                                <Caption3>-Expenses</Caption3>
                                                <Caption4>=Net income<Caption4>
                                                <Caption5>Income limit to qualify</Caption5>
   </Captions>
</FS>


Thanks in Advance
reddtsi
0
toad displaying table name in chineshi am using toad 10 my database table name are been display in chines,has anyone see this
0

DB Dev Tools

Development in most programming languages is done with an editor or integrated development environment (IDE). Dev Tools covers issues with the use of that software, rather than the actual programming being written. XCode, Visual Studio and Eclipse are some of the more popular development tools.

Top Experts In
DB Dev Tools
<
Monthly
>