DB Dev Tools

Development in most programming languages is done with an editor or integrated development environment (IDE). Dev Tools covers issues with the use of that software, rather than the actual programming being written. XCode, Visual Studio and Eclipse are some of the more popular development tools.

Share tech news, updates, or what's on your mind.

Sign up to Post

I have two groups of of C code and need to compile the first group with one set of compiler options and the second group with a different set of compiler options.  I am trying to do this with a single Makefile. The Makefile attached creates the dynamic library but uses the compiler options $CLFAGS0 for all source files instead of using $CFLAGS for the $SRCS set of source code and $CFLAGS0 for the $SRCS0 set of source code.

I am compiling with Solaris Studio 12.2 using dmake.

Makefile
0
I am getting "The current node cannot contain other nodes." on the AppendChild.
What am I doing wrong?  MainDoc contains valid xml.  I am just trying to add an error message at the end of it.
element = errDoc.CreateElement("myError")
element.InnerXml = "<ErrorMsg>" & Msg & "</ErrorMsg>" & _
                   "<Exception>" & exception & "</Exception>"
errDoc.AppendChild(element)
MainDoc = errDoc.OuterXml

Open in new window

0
y vb.net web application uses hyperlinks to navigate between pages.
When a user navigates between pages the data changed on a web form is then lost if they have not pressed the update button prior to navigating to the next page. i want to warn the users if data (usually textboxes) have been changed and they have not clciked the update button before the navigation to the next page.
I check for ispostback on the page and if not it refreshes the data from the last saved in the database.
0
Hi,
I have a table:

10	1
10	2
10	3
110	1
110	2
110	3
360	1
360	2
360	3
470	1
470	2
470	3
560	1
560	2
560	3
760	1
760	2
760	3
1180	1
1180	2
1180	3
1390	1
1390	2
1390	3
1690	1
1690	2
1690	3
2520	1
2520	2
2520	3
2900	1
2900	2
2900	3
2930	1
2930	2
2930	3
3380	1
3380	2
3380	3
6970	1
6970	2
6970	3
7170	1
7170	2
7170	3
7230	1
7230	2
7230	3
7830	1
7830	2
7830	3
8040	1
8040	2
8040	3
9050	1
9050	2
9050	3
10500	1
10500	2
10500	3
11450	1
11450	2
11450	3
11450	6
11900	1
11900	2
11900	3
11900	6
12320	1
12320	2
12320	3
12320	6
13650	6
14220	6
14710	6
14870	6
15520	1
15520	2
15520	3
15770	1
15770	2
15770	3
15800	1
15800	2
15800	3
15840	1
15840	2
15840	3
15850	1
15850	2
15850	3
15900	1
15900	2
15900	3
18760	4
18760	5
18760	6
18970	4
18970	5
18970	6
19020	4
19020	5
19020	6
19160	4
19160	5
19160	6
19310	4
19310	5
19310	6
19390	4
19390	5
19390	6
19440	4
19440	5
19440	6
19570	4
19570	5
19570	6
19680	4
19680	5
19680	6
19850	4
19850	5
19850	6
20260	4
20260	5
20500	4
20500	5
20500	6
20760	4
20760	5
20760	6
20810	4
20810	5
20810	6
20860	4
20860	5
20860	6
20950	4
20950	5
20950	6
20960	4
20960	5
20960	6
21010	4
21010	5
21010	6
21020	4
21020	5
21020	6
21060	4
21060	5
21060	6
21120	4
21120	5
21120	6
21340	4
21340	5
21410	4
21410	5
21430	4
21430	5
21440	4
21440	5
21450	4
21450	5
21460	4
21460	5
21550	4
21550	5
22120	4
22120	5
22150	4
22150	5
22260	4
22260	5
22310	4
22310	5
22430	4
22430	5
22670	4
22670	5
23170	4
23170	5
23200	4
23200	5
23280	4
23280	5
23480	4
23480	5
23510	4
23510	5
23560	4

Open in new window

0
Hi Experts,

What is the  limitation on the stack size associated with the TCL thread?
I'm facing a consistent problem with "allocation (malloc)" after some time of continuously running script.

I'm using the following initialization for the TCL framework:
	Tcl_FindExecutable(arg[0]);
	m_pTclInterp = Tcl_CreateInterp();
	Tcl_Preserve(m_pTclInterp);

Open in new window


Thanks.
0
Hi.
why two different procedures but similar in their content, both with select * from table return different results for the entity framework 6.1 from database? Both have result (0) at the end. one returns an integer and the other returns a ObjectResult.

thx in advance

this is the working stored procedure:

SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
ALTER procedure [dbo].[sp_Pessoas]
@PessoaID            integer=0,
@CDTipoPessoa        char(1)='',
@PessoaEmpresaID     integer=0,
@NomePessoa          varchar(100)='',
@Fantasia            varchar(50)='',
@CodigoExterno       integer=0            
as

if  @CodigoExterno  is  not  null
    if  @CodigoExterno>0  and  @PessoaID=0
          set  @PessoaID=DBASE.dbo.PessoasConverteCodigoExterno(@CDTipoPessoa,@CodigoExterno)

select *
  from DBASE.dbo.Pessoas (nolock)
 where (@PessoaID=0         or  PessoaID=@PessoaID)                   and
       (@CDTipoPessoa=''    or  CDTipoPessoa=@CDTipoPessoa)           and
       (@PessoaEmpresaID=0  or  PessoaEmpresaID=@PessoaEmpresaID)     and
       (@NomePessoa=''      or  NomePessoa like '%'+@NomePessoa+'%')  and
       (@Fantasia=''        or  Fantasia   like '%'+@Fantasia+'%')        
 order by NomePessoa
 
return(0)

and this is the result as expected:
var resultado = DataContextFabrica.GetDataContext().sp_Pessoas(pessoaID, "", 0, "", "", codigoExterno).FirstOrDefault();


this is then, the not working sp:

SET ANSI_NULLS ON
GO
SET …
0
Hi,

I'm trying to connect to a database server that has a static IP.
If you do it with pgsql3 software works fine, but it doesn't work if you try with the Codeigniter database library.
It doesn't shows any errors, only a white page on everything that is on the same controller (the one which I'm using for the database connection).

Regards!
0
Hello,

We are currently a Microsoft server shop and now trying out a proof of concept with an IBM Netezza server. From what I understand IBM Netezza server doesn't have the same kind of interface or friendliest interface as you would find with a MS SQL Server.

Are there any 3rd tools out there that can interact with Netezza for development? Or would it be better to do development in MS SQL and the port everything over to the IBM Netezza server?

LJ
0
I've been banging my head against a brick wall for what seems like forever.  This is what I have done :

Written a VB.Net console application (lets call it myvb.exe) which accepts a number of parameters and creates an Excel 2010 workbook
Created an SSIS package which iterates a number of records in SQL Server and executes myvb.exe

This package works successfully when I run from BIDS.  It works successfully when I publish the package into SSIS.  It works successfully when I run from a command prompt using "DTExec.exe".  What it doesn't do, is run as a scheduled job using SQL Server Agent.  Well, strictly speaking, it does run, I get no errors, but the expected Excel files do not get created.  Task manager shows me that Excel instances are being created/destroyed on the fly.

The agent is running under my logged on account, so there should be no issue there (hopefully).  It is running on the same machine from which I designed all the elements, so there is no issue with a different setup.  It doesn't use UNC path, the application is run directly from the c:\ drive.  It is set to run using 32-bit runtime, hopefully that eliminates an issue we've come across with Office on the production server.  I've tried turning on package logging, but it tells me little else other than when each iteration starts and finishes.  I've added scripts tasks to write what is passed to the exe to a log file, all commands look OK.

I'm at a loss.  I'm obviously …
0
Hi I am trying to get pagecount in livecycle designer es4

this.rawvalue = xfa.layout.pageCount() - at the layout:ready

but i am not getting any value for the field on the form.

but when i am trying to get the current page by writing

this.rawvalue = xfa.layout.page(this) - at the layout:ready  it showing up correctly.

can somebody let me know if there is something wrong on the pagecount method i am using.

thanks
de1209
0
Hi , I am trying to concatenate addr fields for the text field in the live cycle designer using java script  as below

this.rawValue = xfa.resolveNode("#subform[1].CAOName").rawValue + "\n" + xfa.resolveNode("#subform[1].Addr1").rawValue || "\n"
                   if((xfa.resolveNode("#subform[1].Addr2").rawValue)!= null)
                    {
                    xfa.resolveNode("#subform[1].Addr2").rawValue}
                    else
                    {xfa.resolveNode("#subform[1].City").rawValue||xfa.resolveNode("#subform[1].State").rawValue||xfa.resolveNode("#subform[1].Replyzip").rawValue

Open in new window


but i am only getting the CAO name and addr1 on my forms even though i have values for addr2, city, state , zip

can somebody help me to understand if the formula in have in the script layout is correct.


Thanks
de1209
1
I an using default_where.

SET_BLOCK_PROPERTY('qc_poch_again',default_where,'procedure_id = v_poch_procedure_id and term_date is null and EQUIP_TYPE_ID = :parameter.equip_type_id1 and qc_type_id = :qc_daily.qc_type_id AND qc_subtype_id = :qc_daily.qc_subtype_id');
                   GO_BLOCK('qc_poch_again');               
               EXECUTE_QUERY;


 But wanted to know if I can use procedure_id in (1205,1224)

'procedure_id = v_poch_procedure_id
0
Hi Expert,

I need help here I'm using this PS script for sending email if any new files arrived in a folder, not sure why I can't get any email when adding files in folder and run the script.
Param (
	[string]$Path = "D:\ABC\",
	[string]$SMTPServer = "172.31.32.203",
	[string]$From = "abc.efg@abc.com.au",
	[string]$To = "abc.efg@abc.com.au",
	[string]$Subject = "New File Uploaded to FTP Site"
	)

$SMTPMessage = @{
    To = $To
    From = $From
	Subject = "$Subject at $Path"
    Smtpserver = $SMTPServer
}

$File = Get-ChildItem $Path | Where { $_.LastWriteTime -ge [datetime]::Now.AddMinutes(-1) }
If ($File)
{	$SMTPBody = "`nThe following files have recently been added/changed:`n`n"
	$File | ForEach { $SMTPBody += "$($_.FullName)`n" }
	Send-MailMessage @SMTPMessage -Body $SMTPBody
	
}

Open in new window


I added SMTP server and use the default IP address, and port 27. I open outbond connection in firewall for port 27.
Can someone help here.
Thanks in advance
0
I want to put a time stamp in a field when the date picker chooses a date.
0
I asked a question in July because I was getting deployment errors. "Error: Failed to decrypt an encrypted XML node because the password was not specified or not correct. Package will attempt to load without the encrypted information." The package in the previous question ran fine after this error, because I learned later the package wasn't even using the connection string generating the error.

http://www.experts-exchange.com/Database/MS-SQL-Server/Q_28477521.html

Now I have another package that is using the connection strings in Connection Manager. This one generates the same error and will not work on the server.

If I uncheck the box "Validate package after installation", I can deploy to the server fine and everything seems to run fine. InsallationWizard.jpg
My question is: what exactly is this validating in the package and can I safely uncheck it during deployment. All of my searches show me how to use it, but I can't seem to find out why.

Thanks,
Jerry
0
Hi

I've been doing some research to find a 3rd party control which I can reference in my web app, I need the control to help me compare documents side by side on the screen.

Does such a third party tool/control exist?

Kind Regards
0
In C# I have a report created in Active Reports 3 and I need to save it as a pdf file instead of sending to a printer
0
I need to adjust the following script that I found to import from multiple .csv files to one excel sheet. each of the csv's have only one column ranging from about 65 - 100 rows. I would like to have a single sheet and not a workbook with multiple sheets. I should have about 111 -118 csv files to import from. The line I keep getting the error on is the          'Copy data                  Range("F1:F8").Copy wbkNew.Sheets("Master").Cells(1, NC)   Line.

Option Explicit

Sub Consolidate()
  'Open all Excel files in a specific folder and merge F1:F8 master sheet
  'Moves imported files into another folder
  'JBeaucaire (12/7/2009)     (2007 compatible)
  Dim fName As String, fPath As String, fPathDone As String, OldDir As String
  Dim LR As Long, NC As Long
  Dim wbkOld As Workbook, wbkNew As Workbook, ws As Worksheet

 'Setup
     Application.ScreenUpdating = False
     Application.EnableEvents = False
     Application.DisplayAlerts = False

     Set wbkNew = ThisWorkbook
     wbkNew.Activate
     'Sheets("Master").Activate   'optional, edit as needed

     If MsgBox("Clear the old data first?", vbYesNo) = vbYes Then
         Cells.Clear
         NC = 1
     Else
         NC = Cells(1, Columns.Count).End(xlToLeft).Column + 1
     End If

 'Path and filename
     OldDir = CurDir                 'memorizes the user's current working path
     fPath = "\\<servername>\share\General_Use_Documents\GPOReporting\you\"              'path with import files
     fPathDone = 

Open in new window

0
Hi,

I just want to create new packages in VS2010(that's what was deployed with my machine). However, I dodn't see the option to add an SSIS Integration pacakge. I see alot of database options, but no way to add an SSIS package.

Is this even possible ?
0
I have an average size VB.NET solution made out of 1 Windows application and 3 libraries. When compiling the solution, the libraries compile at what I consider a normal speed (even if they have been modified), but the compiler seems to hang on the application.

Bigger applications compiles 4 to 5 times faster.

Does anybody know of factors that can slow down the compilation time of a Windows application?
0
I have eclipse 4.4.0 on my win 7 machine and was able to create a hello world application under windows (can run it from a command line window)

How do I get to upload this application to my samaung tab 4 android device?


How in general do I develop some useful apps for android using my eclipse ide?


I am under impression I need to set up some kind of virtual device emulation on windows machine to be able to test/develop app for tablet on the windows box before "installing" it on the tablet.


On web I see all kinds of vague references to sdk managers etc but cant see the answers... thanks
0
Hello,

I thought this would be easy but....I'm trying to create an .MSI file for deployment of a winform application in Visual Studio 2010.

Using:
Visual Studio 2010
Visual Studio 2010 Installer
Single Project called "MyProject"


From what I read in various tutorials and (GASP) the instruction manual for Dotfuscator, it seems it isn't integrated into the build process so I have to do it manually.  OPening Dotfuscator and creating the new .exe was trivial but now where do I go?  I tried replacing the original .exe in the BIN, OBJ, debug, and Release folders.  When I try to deploy that MSI, or even build it I get an error that the Hashes don't match.  SOmewhere a tutorial said to rehash the new dotfuscated assembly but I couldn't figure out how or where to do that.

What I'm looking for is a 'for dummies' checklist for building an MSI with 2010 Installer and Dotfuscator CE.  

Any help or good videos out there?

Thanks!

Zip
0
I have problems referencing powershell functions from within Visual Studio 2008 or 2010. I have imported the
System.Management.Automation.dll but it still cannot find references to:

        Dim connInfo As WSManConnectionInfo
        Dim mycommand As PSCommand, pscmd As PowerShell
        Dim ws As System.Management.Automation.Runspaces.run

Also it cannot find AuthenticationMechanism or RunspaceAvailability so I am unable to build the project

I tried removing and re-adding references with no luck.
I used to work ok before but it lost all the references for some reason. I even went back to an earlier version of the project.
I tried creating a new project with the appropriate references.

Are there different versions of System.Management.Automation.dll ?
 Mine is 6.0.6000.16386 dated 12/01/2007
0
Hello,
I am developing some big project (300K+ lines of code).
The all code is in C.

Code repository is on remote server based of fedora.

Now I'm on Windows(for some reason I can't change, the OS to Linux).

Now the requirement is the next.

I need to modify code from my Windows and make it more convenient and smart way.
Currently I use these software:
1. sshfs  to mount remote server on virtual box fedora  in windows. (pretty complicated)
2. codeblocks,  to find declaration and definitions.

So as you see it's pretty complicated to modify source code also it's very slow to save or browse remote files on codeblocks.

Thank you.
0
how can I chain 2 crystal reports together?  I have 2 separate reports and would like for both of them to be displayed in the report viewer, one after the other.
0

DB Dev Tools

Development in most programming languages is done with an editor or integrated development environment (IDE). Dev Tools covers issues with the use of that software, rather than the actual programming being written. XCode, Visual Studio and Eclipse are some of the more popular development tools.

Top Experts In
DB Dev Tools
<
Monthly
>