[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x

DHCP

10K

Solutions

14K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).

Share tech news, updates, or what's on your mind.

Sign up to Post

I had a Hyper V host that wouldn't boot, but I had some backups of the VMs on another machine that I fired up.  Two of the VMs are DCs, one is the DHCP server and the other the DFS root.  Once the backup VMs booted, I was able to ping both of them.  Things seemed normal until I realized that users were not getting DHCP.   I tried clearing the arp cache on our switches, thinking that those machines couldn't find the DHCP server, but that didn't work.  I even reset one workstation's NICs, but that didn't work either.  Nothing I tried would cause the machine to get an IP assigned.  Only after I assigned a manual IP did that workstation seem to be back to normal.

I also noticed that some of our DFS mapped drives didn't work either, even though the DFS root was up and running and I could ping it.

In the meantime, I was able to get the original Hyper V host up and running again, so I shut down the backup VMs and started up the original VMs.  DHCP and DFS started working immediately!  Can someone help me understand why this happened, why the backup VM wouldn't hand out DHCP requests?  Or why the DFS root didn't seem to work either?  It's kind of useless to have backup VMs if they won't do the jobs they're supposed to...

I am fully up and running with all the original Hyper V host and VMs once more, so the fire has been put out for now.  But, I'm worried that the next time I actually need those backup VMs to work that I'll be in the same situation once more.  Help?
0
Microsoft Azure 2017
LVL 12
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

I need a documented formula for windows 2016 domain controller sizing.

I want to have three domain controllers running windows 2016. The servers will also run DNS, DHCP services on all domain controllers and and CA on one dc.

I want a documented formula for sizing if challenged in the design review.

I am proposing

4 cores for each dc
24 GB RAM
100 GB disk.

just want some documented formula.
0
I setup a new 2016 server to be our dhcp wifi server. I went through all the steps to export the dhcp file of the 2008 r2 server and then did the import to the 2016.
All seemed to be ok and I see all of the reservations and scope on the new server and the ipv4 and 6 both have green check marks but when I run the authorize managed servers, it says The DHCP server could not contact Active Directory.. I get this when I run Netsh dhcp show server..

Do I need to make any other changes?
0
Hi,
I'm having some problems regarding a Zyxel ZyWall USG 200. And let me be clear from the start; I am far away from being a network expert :-o

Anyways - on LAN1 I have connected a switch to which I have all the clients, AP's, printers etc in the company. On the DMZ-port I have connected our IP telephone system.

On the LAN side I have en Windows server working as a DHCP server - the subnet is 192.168.72.0/24.
On the DMZ side I'm using the build-in DHCP server on the specific port on the Zyxel USG - the subnet is 192.168.73.0/24

I have made some firewall rules which opens for telephone traffic from and to WAN. Besides that I have used the default settings from Zyxel.

My problem is that some clients gets an IP address from the DMZ zone - and NOT from the server on the LAN side.

Hope somebody can help - and please do ask questions if you have any :-D

Thanks in advance.

Best regards
Henrik
0
Hi Folks,
How do I get AD to store macaddresses of all computers in a domain. It seems an obvious thing to do, and there is a macaddress attribute in the default schema, but it doesn't get populated. Do I have to somehow marry DHCP (which stores macaddresses) and AD ?
The reason I want to do this is I am using Veyon and want to be able to WOL a group of machines without having to manually gather all their macaddresses. Thanks in advance.
0
I am having a problem with Windows Deployment Services & DHCP.

Background:
I have installed and set up WDS on many many sites over the years - I have never encountered the problem that I am facing right now, and I have put hours of work into trying to solve it. I really hope someone here can help. I am using the same method i've used time and time again - but this time, something has gone wrong.

The issue:
Simply put, I cannot get a a Gen2 Hyper-V VM to boot through PXE. It sits at the "Performing DHCP Negotiation...." for a while, and then aborts.
I have also tried with a Physical PC in UEFI Mode - the same behaviour applies, it times out.

Legacy Mode, or Gen1 VM's will successfully boot via PXE, but not Gen2/UEFI.

The setup:
I am running Server 2016 fully up to date, with Hyper-V

On this, I have 3x Windows Server 2012 R2 VMs
  • DC01.ad.local
  • FS01.ad.local
  • WDS01.ad.local

DHCP Role is installed on DC01
WDS Role is installed on WDS01
Everything is in one subnet (192.168.16.0/24)

What I have tried, unsuccesfully:
  • Turning Off IPv6
  • Removing WDS from WDS01 and installing it on DC01
  • Building a 4th VM with Server 2016 (DC02) and installing DHCP and WDS Roles and setting up again from scratch
  • Manually creating DHCP Options (I've never had to do this in the past, and i've set it up like this many times)
0
I have DC and DR site for exchange server 2010.

DC site is working fine but now I am making a function to the DR site. But when I am adding DR site mailbox to same DAG i.e DAG 100 (from Manage DAG membership Section ).

It is a throwing error.

add-databaseavailabiltygroupserver started on machine DCMB1.
[2018-10-11T12:43:20] add-dagserver started
[2018-10-11T12:43:20] commandline:         $scriptCmd = {& $wrappedCmd @PSBoundParameters }
[2018-10-11T12:43:20] Option 'Identity' = 'DAG100'.
[2018-10-11T12:43:20] Option 'MailboxServer' = 'DRMB1'.
[2018-10-11T12:43:20] Option 'DatabaseAvailabilityGroupIpAddresses' = ''.
[2018-10-11T12:43:20] Option 'WhatIf' = ''.
[2018-10-11T12:43:20] Process: w3wp w3wp.exe:5972.
[2018-10-11T12:43:20] User context = 'NT AUTHORITY\SYSTEM'.
[2018-10-11T12:43:20]   Member of group 'Everyone'.
[2018-10-11T12:43:20]   Member of group 'BUILTIN\Users'.
[2018-10-11T12:43:20]   Member of group 'NT AUTHORITY\SERVICE'.
[2018-10-11T12:43:20]   Member of group 'CONSOLE LOGON'.
[2018-10-11T12:43:20]   Member of group 'NT AUTHORITY\Authenticated Users'.
[2018-10-11T12:43:20]   Member of group 'NT AUTHORITY\This Organization'.
[2018-10-11T12:43:20]   Member of group 'BUILTIN\IIS_IUSRS'.
[2018-10-11T12:43:20]   Member of group 'LOCAL'.
[2018-10-11T12:43:20]   Member of group 'IIS APPPOOL\MSExchangePowerShellAppPool'.
[2018-10-11T12:43:20]   Member of group 'BUILTIN\Administrators'.
[2018-10-11T12:43:20] Updated Progress 'Validating the …
0
Dear experts, if the Access switch is unconfigurable of DHCP snooping, can we do it on Core switch? (The Dhcp is on Core)

Otherwise, how can we mitigate the rogue DHCP? Thanks!
0
Good morning all, I have a SBS 2008 server with some major issues (this is what wont work, IIS servcies, DHCP services. DNS services, many other services also wont run including windows backup, I cant log into the domain or access any IIS sites via any method ive tried. But here is my question., I just need some files that were stored on the companyweb hosted on the server but I have no idea where I can access them to just copy them off. Ive a new server doing everything the old one does and a new site will be hosted there but Im trying to find the local directories where some .xls files are that used to be accessed via the company web. Thanks in advance for any help. Chris. (the server is "running" but theres little I can actually do with it.
0
I have configured a Cisco 4321 router. A Windows PC can successfully access the internet when using dhcp, but when I configure the PC with Static IP, then it can only ping a website e.g. google.com, but cannot browse the internet. I do have a static route and NAT enabled but not sure why it will not resolve DNS request on the Cisco when not using dhcp. I'm new to this so I'll need clear guidance. Thank you.

Here is the config:
!
!
ip name-server 192.168.15.1 139.130.4.4 8.8.8.8
ip dhcp excluded-address 192.168.15.1 192.168.15.99
ip dhcp excluded-address 192.168.15.200 192.168.15.254
!
ip dhcp pool dhcp-pool-1
 import all
 network 192.168.15.0 255.255.255.0
 dns-server 192.168.15.1 139.130.4.4 8.8.8.8 
 default-router 192.168.15.1 
!
!
!
!
subscriber templating
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
diagnostic bootup level minimal
spanning-tree extend system-id
!
!
!
redundancy
 mode none
!
! 
! 
!
!
interface GigabitEthernet0/0/0
 description $ETH-WAN$
 ip address XXX.XXX.XXX.XXX 255.255.255.252 (X is the Static WAN IP assigned by the ISP)
 ip nat outside
 media-type rj45
 speed 1000
 no negotiation auto
!
interface GigabitEthernet0/0/1
 description MAIN LAN
 ip address 192.168.15.1 255.255.255.0
 ip nat inside
 ip nbar protocol-discovery
 negotiation auto
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 ip address 192.168.16.1 255.255.255.0
 negotiation auto
 no mop enabled
!
ip nat inside source list NAT-LIST-LAN interface GigabitEthernet0/0/0 

Open in new window

0
Exploring SharePoint 2016
LVL 12
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

3COM BASELINE 2824-SFPHi,

 I have 3COM BASELINE 2824-SFP switch and like to access it via IP address. But I don't see it in DHCP server and I have not assigned a static IP address to it in the past.
 I ran Advanced IP scanner and I see my two CISCO switches, but I don't see 3COM switch.
 What can I do to make it receive a dynamic IP address from DHCP server?

Thanks.
0
We have a Windows 2008 DHCP/DNS/AD server which I'm not pointing the blame at, but something is up with DHCP.  We retired some other servers and updated the DHCP scope to hand out new DNS server assignments.  Strange thing is, clients will still, randomly, have the old DNS servers assigned to them.  This happens during the workday when a DHCP lease is renewed.  Suddenly, a user will lose connectivity.  ipconfig /release and renew and problem is gone for the moment.  Prior to the ipconfig /release and renew, ipconfig /all shows the proper DHCP server, a legitimate IP, mask and gateway, but the 2 old DNS servers.

We've worked hard to ensure that there are no conflicts with the wifi controller, rogue APs and so forth.  ipconfig /all is consistently showing what I described above.  We do not find any rogue devices or anything of that nature.
0
Hi,

We are running out of DHCP IP addresses, the lan is on a 192.168.23.0/24 network
default gateway 192.168.23.5
subnet mask 255.255.255.0

I am looking at supernetting using a 255.255.252.0 /22 subnet to give 1022 useable addresses.

Is it as straight forward as changing the subnet on the router to 255.255.252.0, deleting the DHCP scope on windows server, recreating the scope between 192.168.20.1-192.168.23.254?

And then changing any static devices such as servers , printers, waps, etc to have a subnet of 255.255.252.0 or is there more to it than this, or any special considerations?

Thanks
0
Weird one - demoted a domain controller - 1 of our SSO applications failed to allow logon for "some" users. - until we put in the FQDN rather that just the server name

we had a dhcp scope of domain.com.au  being pushed out for 2 years - with no sso issues. - now however we had to change the DNS in the scope option to ad.domain.com.au to reflect the actual AD domain name this resolved the issue. - I understand that this is what it  should have always been - but why did this suddenly become an issue after dc demotion 2008 r2?
0
The BAD_ADDRESS  leases on dhcp server. Does this mean that he have a duplicate ip address somewhere?
0
Need to purchase network switch for a school, and we are looking to implement vlans, with the switch doing dhcp for different vlans, on different ports. Prefer something with a friendly gui, as I am new to this, and CLI is not my strength. Any suggestions for hardware, for this criteria, will be appreciated.
0
We're looking to install the WDS role on a server to host the keys for BitLocker's network unlock feature.  Will only be using WDS for the unlock, nothing else.  Network unlock is our only option since pre-boot PINS are not an option.  We have about 50 desktops scattered throughout different locations and the goal is to enable network unlock with BitLocker.

We'd like to install the WDS role on multiple hosts to avoid a single point of failure.  If one WDS host goes down, this would prevent our desktops from booting which would be very bad.  What do folks do in this situation to allow for redundancy?

Next question.  
We're in AWS.  The concern is that WDS relies on DHCP and since DHCP is hosted in AWS, will this cause problems with WDS?  Keep in mind, we're only using WDS for network unlock.
We'd like to host a server on prem for WDS but this is not an option at this time.

thank you
0
Cisco 8811 phone. The old IP address is still showing in Call Manager and I don't know how to get Call Manager to shake it out, and grab the new IP address.

Cleared dhcp bindings. The MAC for the old phone is not showing. The phone is plugged directly into the wall jack and not daisy chained to the PC.

Additionally, configured the phone and tested it in the shop before brining it on site.
0
I am wondering the best way to configure this scenario:

I have 2 VLANs - 10.106.4.0/24 and 10.100.134.0/24.

Both are configured on a Juniper EX2300 switch. That switch is connected to 2 firewalls (Cisco ASA 5506) with interfaces at 10.106.4.1 and 10.100.134.1 respectively.

VLANs are set up with addresses of 10.106.4.254 and 10.100.134.254

I have one Windows 2016 server providing DHCP addreses at 10.106.4.200

A couple of questions:

1. How can I set up the next hop for the switch VLANs so that traffic passes from 10.106.4.254 to 10.106.4.1 and from 10.100.134.254 to 10.100.134.1

2. Can the server at 10.106.4.200 provide DHCP scope for both VLANs? Will I need relays on the EX2300 for both VLANs or will the one for 10.106.4.0/24 subnet auto resolve and the one for 10.100.134.0/24 require a relay? How do I set this up on the Juniper?

Any help and suggestions would be great. The reason for the 2 firewalls is one is connected to a franchisee who refuses to allow any other traffic on their network (10.106.4.0/24) apart from workstations attached to their subnet. All other traffic (phone, surveillance systems, etc.) must use the other firewall and VLAN.
0
PMI ACP® Project Management
LVL 12
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

What if only get an gateway IPv6 is fe80:: by ISP modem connected when, it offering dhcpv6 acclaimed ?


ISP using an Enterprise Type of DHCPv6 service for some clients only , would be resumed or reasonable for the "unknown companies" associated with my ethernets mac address in the ipv6 addresses ?



Sincerely

BleuOisou
0
Dear Experts, I need suggestions on this network design. Is there anything we need to consider for improving HA, security, performance? Could you please help? Many thanks!

net.PNG
Core SW1, SW2: Cisco 3850 IP service
Access SW1, SW2: Cisco 2960 LANBase

- Between C1 and C2: EtherChannel Trunking native vlan 88
- Between C1 and C2, C1 and A1, A2, C2 and A1, A2: trunking interfaces native vlan 88
- C1: VTP Servers, other switches are VTP clients, version2
- VLAN 10 (LAN), 11 (LAN), 88 (management) synchronize between switches

- C1:
STP root primary for VLAN10, secodary for VLAN11
HSRP Active for  VLAN10, HSRP Standby for VLAN11 (standby .254)
DHCP pool VLAN10A, VLAN11A, default GW is .254, exclude address .1 - .50 and .53 - .254  (so 2 addresses .51, .52 are available, just for test)

- C2:
STP root primary for VLAN11, secodary for VLAN10
HSRP Active for  VLAN11, HSRP Standby for VLAN10
DHCP pool VLAN10B, VLAN11B, default GW is .254, exclude address .1 - .250 and .253 - .254  (so 2 addresses .251, .252 are available, just for test)

- Access switches: sw mode access / define VLAN on interfaces connected to PCs
0
Im wondering can someone help,
I recently installed a new domain controller and moved dhcp, dns services onto it and thats all working fine. I also migrated the old domain controller onto it. It says it has all the fsmo roles. However when i shutdown the old domain controller i cant connect to any active directory services on the server.

I see this error in the logs but i cant seem to resolve it. Any active directory wizards that can help me ? Windows 2012 is the new server


This server is the owner of the following FSMO role, but does not consider it valid. For the partition which contains the FSMO, this server has not replicated successfully with any of its partners since this server has been restarted. Replication errors are preventing validation of this role.
 
Operations which require contacting a FSMO operation master will fail until this condition is corrected.
 
FSMO Role: DC=mycompanyDC=local
 
User Action:
 
1. Initial synchronization is the first early replications done by a system as it is starting. A failure to initially synchronize may explain why a FSMO role cannot be validated. This process is explained in KB article 305476.
2. This server has one or more replication partners, and replication is failing for all of these partners. Use the command repadmin /showrepl to display the replication errors.  Correct the error in question. For example there maybe problems with IP connectivity, DNS name resolution, or security authentication that…
0
I am connecting two sites via fiber into Cisco SG300's.

Each network has it's own subnet 192.168.100.0/24 & 192.168.200.0/24 respectfully.

How can I configure the switches to prevent the respective DHCP servers from crossing over the interconnect?
0
We are a small k-12 school with about 150 school devices plus personal staff devices. Students are not allowed on the network.

I have filters activated on the windows 2012 r2 standard server and need to approve and enter the mac address of permitted devices to receive an address from the DHCP server.

I connected to our dd-wrt router and found a few computers using more bandwidth than they should.

One of the computers using too many resources belonged to one of the staff members. I went to see what that person was doing and I found the laptop powered off and plugged into a charging cart. The teacher stated that the laptop had been off for 2-3 hours, yet the dd-wrt >> Status >> LAN >> Active Clients showed the device had over 500 connections to the internet.

Question:  Is that even possible to see a device showing active on the network but is powered off?  My expectation is NO unless the computer was not truly off.

And I do believe it was powered off. I stood there when she turned it on and booted it up.  I double checked the mac address and it did match. The next time I looked at the active devices, the laptop was no longer on the list.

Thank you.

Jerlo
0
We are a small k-12 school with about 150 school devices plus personal staff devices. Students are not allowed on the network.

I have filters activated on the windows 2012 r2 standard server and need to approve and enter the mac address of permitted devices to receive an address from the DHCP server.

Today the network was slow and a ping test showed 18% lost packets. I connected to our dd-wrt router and found a few computers using more bandwidth than they should.

On the router I can see the IP and the mac address of the devices. The ip address was on handed out by the DHCP server.

Yet when I went to the server >>DHCP>>Address leases, there were several addresses that I could see on the router but I could not see on the leases for the DHCP server.

I did find them using the mac address on the filter list, so they were approved to receive an address, but I could not specifically see them on the lease list.

I thought perhaps I had a second device handing out addresses, but DHCP function is disabled or not installed on the router and other servers. Therefore I do not believe another device was handing out addresses.

Question:  Is it possible to have an incomplete IP address list in the lease section of DHCP?

Thank you.

Jerlo
0

DHCP

10K

Solutions

14K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).