DHCP

10K

Solutions

15K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).

Share tech news, updates, or what's on your mind.

Sign up to Post

Dear experts, if the Access switch is unconfigurable of DHCP snooping, can we do it on Core switch? (The Dhcp is on Core)

Otherwise, how can we mitigate the rogue DHCP? Thanks!
0
Good morning all, I have a SBS 2008 server with some major issues (this is what wont work, IIS servcies, DHCP services. DNS services, many other services also wont run including windows backup, I cant log into the domain or access any IIS sites via any method ive tried. But here is my question., I just need some files that were stored on the companyweb hosted on the server but I have no idea where I can access them to just copy them off. Ive a new server doing everything the old one does and a new site will be hosted there but Im trying to find the local directories where some .xls files are that used to be accessed via the company web. Thanks in advance for any help. Chris. (the server is "running" but theres little I can actually do with it.
0
I have configured a Cisco 4321 router. A Windows PC can successfully access the internet when using dhcp, but when I configure the PC with Static IP, then it can only ping a website e.g. google.com, but cannot browse the internet. I do have a static route and NAT enabled but not sure why it will not resolve DNS request on the Cisco when not using dhcp. I'm new to this so I'll need clear guidance. Thank you.

Here is the config:
!
!
ip name-server 192.168.15.1 139.130.4.4 8.8.8.8
ip dhcp excluded-address 192.168.15.1 192.168.15.99
ip dhcp excluded-address 192.168.15.200 192.168.15.254
!
ip dhcp pool dhcp-pool-1
 import all
 network 192.168.15.0 255.255.255.0
 dns-server 192.168.15.1 139.130.4.4 8.8.8.8 
 default-router 192.168.15.1 
!
!
!
!
subscriber templating
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
diagnostic bootup level minimal
spanning-tree extend system-id
!
!
!
redundancy
 mode none
!
! 
! 
!
!
interface GigabitEthernet0/0/0
 description $ETH-WAN$
 ip address XXX.XXX.XXX.XXX 255.255.255.252 (X is the Static WAN IP assigned by the ISP)
 ip nat outside
 media-type rj45
 speed 1000
 no negotiation auto
!
interface GigabitEthernet0/0/1
 description MAIN LAN
 ip address 192.168.15.1 255.255.255.0
 ip nat inside
 ip nbar protocol-discovery
 negotiation auto
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 ip address 192.168.16.1 255.255.255.0
 negotiation auto
 no mop enabled
!
ip nat inside source list NAT-LIST-LAN interface GigabitEthernet0/0/0 

Open in new window

0
Hi,

We are running out of DHCP IP addresses, the lan is on a 192.168.23.0/24 network
default gateway 192.168.23.5
subnet mask 255.255.255.0

I am looking at supernetting using a 255.255.252.0 /22 subnet to give 1022 useable addresses.

Is it as straight forward as changing the subnet on the router to 255.255.252.0, deleting the DHCP scope on windows server, recreating the scope between 192.168.20.1-192.168.23.254?

And then changing any static devices such as servers , printers, waps, etc to have a subnet of 255.255.252.0 or is there more to it than this, or any special considerations?

Thanks
0
Need to purchase network switch for a school, and we are looking to implement vlans, with the switch doing dhcp for different vlans, on different ports. Prefer something with a friendly gui, as I am new to this, and CLI is not my strength. Any suggestions for hardware, for this criteria, will be appreciated.
0
Cisco 8811 phone. The old IP address is still showing in Call Manager and I don't know how to get Call Manager to shake it out, and grab the new IP address.

Cleared dhcp bindings. The MAC for the old phone is not showing. The phone is plugged directly into the wall jack and not daisy chained to the PC.

Additionally, configured the phone and tested it in the shop before brining it on site.
0
Dear Experts, I need suggestions on this network design. Is there anything we need to consider for improving HA, security, performance? Could you please help? Many thanks!

net.PNG
Core SW1, SW2: Cisco 3850 IP service
Access SW1, SW2: Cisco 2960 LANBase

- Between C1 and C2: EtherChannel Trunking native vlan 88
- Between C1 and C2, C1 and A1, A2, C2 and A1, A2: trunking interfaces native vlan 88
- C1: VTP Servers, other switches are VTP clients, version2
- VLAN 10 (LAN), 11 (LAN), 88 (management) synchronize between switches

- C1:
STP root primary for VLAN10, secodary for VLAN11
HSRP Active for  VLAN10, HSRP Standby for VLAN11 (standby .254)
DHCP pool VLAN10A, VLAN11A, default GW is .254, exclude address .1 - .50 and .53 - .254  (so 2 addresses .51, .52 are available, just for test)

- C2:
STP root primary for VLAN11, secodary for VLAN10
HSRP Active for  VLAN11, HSRP Standby for VLAN10
DHCP pool VLAN10B, VLAN11B, default GW is .254, exclude address .1 - .250 and .253 - .254  (so 2 addresses .251, .252 are available, just for test)

- Access switches: sw mode access / define VLAN on interfaces connected to PCs
0
We are a small k-12 school with about 150 school devices plus personal staff devices. Students are not allowed on the network.

I have filters activated on the windows 2012 r2 standard server and need to approve and enter the mac address of permitted devices to receive an address from the DHCP server.

I connected to our dd-wrt router and found a few computers using more bandwidth than they should.

One of the computers using too many resources belonged to one of the staff members. I went to see what that person was doing and I found the laptop powered off and plugged into a charging cart. The teacher stated that the laptop had been off for 2-3 hours, yet the dd-wrt >> Status >> LAN >> Active Clients showed the device had over 500 connections to the internet.

Question:  Is that even possible to see a device showing active on the network but is powered off?  My expectation is NO unless the computer was not truly off.

And I do believe it was powered off. I stood there when she turned it on and booted it up.  I double checked the mac address and it did match. The next time I looked at the active devices, the laptop was no longer on the list.

Thank you.

Jerlo
0
We are a small k-12 school with about 150 school devices plus personal staff devices. Students are not allowed on the network.

I have filters activated on the windows 2012 r2 standard server and need to approve and enter the mac address of permitted devices to receive an address from the DHCP server.

Today the network was slow and a ping test showed 18% lost packets. I connected to our dd-wrt router and found a few computers using more bandwidth than they should.

On the router I can see the IP and the mac address of the devices. The ip address was on handed out by the DHCP server.

Yet when I went to the server >>DHCP>>Address leases, there were several addresses that I could see on the router but I could not see on the leases for the DHCP server.

I did find them using the mac address on the filter list, so they were approved to receive an address, but I could not specifically see them on the lease list.

I thought perhaps I had a second device handing out addresses, but DHCP function is disabled or not installed on the router and other servers. Therefore I do not believe another device was handing out addresses.

Question:  Is it possible to have an incomplete IP address list in the lease section of DHCP?

Thank you.

Jerlo
0
Dear experts, DHCP on Cisco core switch vs on Windows server 2012, which one is better? Can you please suggest pros and cons? We have 500 users, 2000 IP addresses and 20 subnets. Many thanks!
0
As always I would like to begin by thanking everyone who takes the time to answer this question with their expert insights.
I have a 2008R2 Domain Controller that hosts a variety of DHCP scopes that I need to migrate off it as we are demoting and replacing that server. However, no matter which command syntax (through power shell) I try for the netsh I cannot get it to export the settings from TGHDC2 (domain controller) and I continuously get an "Access Denied" error and it immediately stops the DHCP service and does not restart it but it does come back on if I restart it manually..

I have verified that the account (domain administrator account so it should have all required privileges) I am using is a member of the local servers administrator group, etc.

I have another 2008R2 DHCP server (member server only) and I tried to run the exact same command (same domain administrator account) on it and it ran without complaints and it did not stop the DHCP service at all.
 
The one on TGHDC2 also reports this error (1056) which is odd since neither of them have an account specified under this setting and yet it does not impact the other DHCP servers ability to export scopes using netsh.

 "The DHCP service has detected that it is running on a DC and has no credentials configured for use with Dynamic DNS registrations initiated by the DHCP service.   This is not a recommended security configuration.  Credentials for Dynamic DNS registrations may be configured using the …
0
We just switched to a different ISP provider a few days ago. Since then, there have been several Bad Address entries in the DHCP server (Windows server 2012). After deleting them, they'll appear again in an hour. Their Mac addresses are not shown in the address lease.

I used the DHCPFind to check if there's any other DHCP server on the network. The result is attached.

How do I find out what device(s) is causing the issue? Or How to fix this issue?
DHCPFindResult.JPG
0
If we were to setup two 2012 DHCP servers as a hot-standby scenario (see article below) we would also have to point the Cisco switch IP helper address to both servers and then both would get the unicast or broadcast message through the switch when a client (desktop) looks for an IP, because if we do not then the standby DHCP would never be notified of address needs when the active one goes down. However, if we do then what mechanism is in place to prevent both DHCP servers from replying? Would they consult each other first or how would that work, because if they both reply then it isn't standby, but rather load balancing which is not what we need. Pretty sure someone has tried this and made it work. As always very much appreciating all insights and time. Cheers
https://community.cisco.com/t5/other-network-architecture/multiple-ip-helper-address-on-a-single-interface/td-p/404497
http://thesolving.com/server-room/how-to-configure-dhcp-failover-on-windows-server-2012-r2/
0
I bring my (Windows 10 Pro) laptop around to do support in a few different networks - some with DHCP and some where a fixed IP-address is needed. Have tried to find a way to make shortcuts to set the fixed addresses (or set the network adapter back to dhcp), but haven't found a way to do it. Thinking of commands in a batch-file. Any suggestions?

-Olaf-
1
Hi Experts,

on one of my network segments I use a DHCP server.
Now I have to install WLAN for GUESTs and I want to use another VLAN.
How to configure my DHCP server to serve also my VLAN ?
1
Have 2 DHCP Servers in a multi-vlan network.
I've setup 2 DHCP servers on a flat VLAN and split up the scopes and have usually found them to work.  Some clients will go to one dhcp server to get the IP's while others will show up on the 2nd DHCP server.

I set the same configuration this time on 2 servers, splitting the scope but found 1 server servicing the dhcp request while the other is empty---services an all seem to be running but no ack on requests.    any suggestions?
0
Hi Experts

I am looking for a router capable of delivering a DHCP range of  /19 or above, with DSL and ethernet WAN ports |(VDSL) for large applications.  On-board wifi is not required.  L7 firewall an advantage
Can you advise?  Many thanks in advance
0
I am managing two separate locations, both have a single 2008 R2 DNS/DHCP server and they both hold the FSMO roles. I want to create a secondary DNS/DHCP server at each location for redundancy. Here is where my problem lies, I have 2 servers running server 2012 R2 to use as the secondary. I have had no issues setting up redundant DNS with the 2008 and 2012 boxes. I've hit a roadblock with DHCP and i'm not liking what Google has to say.

Ideally i'd like to run a DHCP hot standby with the 2012 box. Load balance is an option as well if needed. One site would have no issues running a split scope as i only have ~60 devices. The other location has almost 200 devices, a split scope would be difficult to pull off.

I cannot upgrade the 2008 r2 boxes but i can downgrade the 2012 r2 boxes to 2008 r2.

Any thoughts or ideas would be appreciated.

Thanks,

Tom
0
Hello,
I need to run a PXE environment, which is working with ThinStation, but i only want specifiied computers to load the PXE. Is there a way of doing that with DHCP reservations on Win2012r2?

Thanks,
0
Single Windows 2012 Server R2 as a DC with DHCP and DNS running - no other servers on the network. NSLOOKUP works perfectly resolving to correct client IP addresses and reverse works as well, but no entries are populating in the DNS Manager GUI.  Event viewer mentions event ID 800 stating the A record for the primary server in the zone's SOA record is not available on this DNS server.
0
Hi All,

I need some assistance setting up the below. I've got 3 "subnets" to set up internally. All must be able to reach the internet through the suppliers router.

The networks are 2x /26 and 1x /27. VLANS 601 & 603 are desktop pc's. VLAN 602 will be Cisco phones. 601 and 603 do not need any seperation, they're just to cover the seperate DHCP ranges. DHCP will be provided by an external source (hopefully) through a VPN setup on the ASA Firewall. I'm looking to setup outside interface, inside interface and access for all vlans.

Is anyone able to provide a sample config on how I could get this working?

Network Overview
Thanks,

J
0
I am having issues with my DHCP server having BAD_ADDRESS entries for a large number of addresses.  The Unique ID ends to be the reverse of the IP address in hex form. I have Conflict detection attempts set to 2.  It is only happening on the Scope attached to the secured wireless.  It seems to be about one bad address per minute or so. I've looked at the event logs on that server that I can find and there aren't any that match the time for the Lease.  Any troubleshooting tips?
0
Hello Everyone,

Need to dig up an old issue briefly. The last time I tried to migrate a DHCP scope to an existing DHCP server (authorized and servicing scopes, but not in the same range as the ones being migrated over) I got an error “Error while importing option 6. This option conflicts with the existing option". Apparently this is the case because the already existing server added the entries for 006 DNS Server and 015 DNS Domain Name when it was installed/authorized. At the time the best recommendation I could find was to delete those two entries from the DHCP server options and then run the import (obviously DHCP scope would be exported from the source server) again. The last time I got around it because I had a server we could move the DHCP to that never had DHCP before and thus no previous entries existed. This time I have to move it to an existing DHCP server. However, I would like to understand what is the risk of deleting those two entries and has anyone ever done that step?

The other option would be to export only the v4 aspect of the scope since (as far as I understand it) the option for exporting specific scopes is split into v4 and v6 subcommands. So running something like this: netsh dhcp server v4 export c:\dhcp "192.168.1.0" might work because including the v4 portion of the command allows for the export of a single scope.  This also gets around the "class conflicts with an existing class" error message that is returned when you try to import an entire …
0
Hi Experts,

I recently purchased a new MacBook Air for myself so my knowledge of how to configure things in it is pretty elementary, if non-existent.

Hours of scouring the web reading articles and watching YouTube help videos have enabled me to successfully connect my MacBook Air to the shared folders on my Windows 10 Pro machine,

My problem is that I can only access my MAC from the Window 10 machine by the MAC's IP address, which is assigned by DHCP so will eventually change. I don't want to make it a static IP unless there is absolutely no other way around it.

When I go to Networks on my Win 10 Pro machine, the MacBook Air does not appear as a computer to select. Nor does it's IP address. I need to manually access it by \\192.168.1.xxx

I can ping the MAC's IP address, but not its machine name. I can see my own Windows 10 Pro machine appear in Network (File Explorer) though, just not the MAC. I can also access the shared folders on the MAC when I access it using the IP address.

Things tried to resolve so far:
  • Set the "Function Discovery Provider Host" Service to Automatic Start (Delayed) and made sure it is running
  • Set the "Function Discovery Resource Publication" Service to Automatic Start (Delayed) and made sure it is running
  • Temporarily Disabled Firewalls on both MAC and Windows computers - made no difference
  • Have done an "ipconfig /flushdns" on the Windows machine - made no difference
0
I dont have too much experience with VLAN Tagging so need a little help,  I have a Draytek Router and a Draytek AP, I have setup a Wifi Network for Staff which goes through LAN1 which works fine through both the Router and AP, I've then got a Guest Wifi network through LAN2 using a VLAN Tag of 10 which ive set on both the router and AP, the problem is there is a Netgear Smart Switch in between which I think is stopping the tagged traffic and I'm not sure how I need to setup the Netgear to allow the traffic, the guest network works fine on the Router but not on the AP the devie thats connected cant get an IP address from the DHCP Server (Draytek Router),  The router and AP are setup as follows: (Just in case you cant open the link I've also put pictures from the guide as you need a login to see the page)

https://www.draytek.co.uk/support/guides/kb-wireless-guestnetwork-ap
1.PNG
2.PNG
3.PNG
4.PNG
5.PNG
0

DHCP

10K

Solutions

15K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).