We help IT Professionals succeed at work.

DHCP

10K

Solutions

15K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).

How many domain controllers per site?
I have a configuration with 3 sites and 6 DC servers. There are 2 servers for each site that provide AD, DNS, WINS, DHCP services. In order to have a redundancy of these services it is necessary to have 2 servers for each site, correct?
my configuration:

  • 1 domain (named (GF)
  • 1 Active directory
  • 3 sites (named C, F, V), in 3 different subnet connected by VPN
  • 6 servers (named AD1, AD2, AD3, AD4, AD5, AD6), 2 servers each site (AD1,AD2 in C; AD3, AD4 in F; AD5, AD6 in V)
  • All servers all servers provide DNS, WINS, DHCP, AD services:
  • o      Servers AD1, AD2 provide DNS, WINS, DHCP, AD services to the subnet in site C
    Servers AD3, AD4 provide DNS, WINS, DHCP, AD services to the subnet in site F
    Servers AD5, AD6 provide DNS, WINS, DHCP, AD services to the subnet in site V
  • AD1 server is the primary domain controller (Operation Masters Role)
0
Hi,

I have two DHCP servers running under windows server 2016. My question is how can I deny any other unauthorized DHCP server in the network? The server are connected to Cisco 9300 switch then to core switch 6807

Each server has two LAN's with an IP address
Server1
192.168.0.248
192.168.0.249

Server2
192.168.0.250
192.168.0.251

Thanks
0
So one of my peers setup a 2016 on a VLAN/Subnet. He came to me the network guy to try and figure out why only 40 or leases had been assigned to his VMs. The subnet is a /23 with 512 potential addresses and 20 or so reserved. There's no helper address here - just a party on the VLAN. So I hopped onto the DHCP server to make sure he configured the
IP address OK etc. But what surprised me was when I ran arp -a I found like 450 addresses associated with MACs already. The DHCP manager showed only 40 or so assigned. Anyone have a thought how all of these addresses might have gotten assigned to the mac addresses while the DHCP server failed to make a note of it? I pinged a few of the addresses from the arp -a and could not reach them. These are VDI desktops to-be. If the addresses are not pingable DHCP should go ahead and assign an address right? It's not concerned with what's in the arp cache right? Or no??
0
Hi peoples - my scenario is this: I want to setup my router to forward rdp traffic across my router to my server.
1. All incoming traffic from ISP going to G 0/0.
2. Want RDP traffic from 10.1.x.x: 3389 to be forwarded to the server.

What commands would I have to set up on the router to achieve this?

Thanks in advance for any help!!
0
Experts,

I am fairly well versed in what my options are here, however I wanted to throw this out here for due diligence sake.

What options are available for DHCP High availability in a "Microsoft Clustered" environment. I have approximately 20 different scopes in my organization that are distributed by 6 DHCP servers.  

I would like to if possible have all those scopes in HA on all my Hypervisors within my Cluster.

What I am looking for in this is the following:

1:Options
2:Instructions for implementation.

Thanks in Advance,

ITguy565
0
I am having a problem with my DHCP server or should I say my network. I have had an old Windows 2003 DC on my network which used to control DNS, DHCP, WINS, Etc.. but over the years I have moved those services off that server and on to new servers (Windows 2008 R2 and Windows 2012 R2) and everything has been working great.

Over the weekend I decided to decommsion that server and move the FSMO roles over to one of the newer servers (Windows 2012R2) and raise the domain from 2003 to 2008R2 since I still have 2008R2 DC's on my network. Everything seemed to go fine but now I am experiencing issues with some of the workstations.

When I look at the configuration of the workstation it is set to DHCP but when I run ipconfig /all it shows the old DC that I decommissioned as the DHCP server and the DNS servers that are on those workstations are incorrect. When I manually add the DNS to the network config it works fine but if I remove then we are back to square one. I have ipconfig /release and ipconfig /renew with no success. I looked at my DHCP scope options and Reservations and found that some of the problem machines were on the reservations list so I deleted those machines, restarted/powered off but when they come back up still the same symptoms.  

What can I do to fix this issue or where do I start?
0
How do i verify the domain of a linux server which it belongs to .When logging through  putty nothing comes up .As I m new to this kind of topics I 'm ready for a session from a expert if anyone is willing to .I'm based out in USA .
0
Environment:

2008 FFL/DFL - 3 DCs

-HOMEDC01 - 2008 SP2 - DNS, GC

-HOMEPDC -  2008 R2 SP1 - FSMO, DHCP, DNS, WINS, GC

-HOMESDC (VM) -  2016 - DNS, GC

IPV6 enabled on all per articles found online.

DC01 has been on the network for years and did everything before.  Then I brought up PDC a few years ago and transferred over all roles from DC01.  2 weeks ago I brought up SDC and set it up with DNS.  Everything looks to be in order and the plan was to demote DC01 and retire it.  I shut down DC01 for a few days and all of a sudden we started experiencing extremely slow loading times for any webpages.  I brought it back up and everything went back to normal.

I made the necessary adjustments in DHCP to only provide PDC and SDC to clients for DNS.

I ran dcdiag /test:DNS /DNSALL /e /v to see whats going on and the only thing I can see is that root hints only seem to be showing up on DC01 in the output.  I check DNS on PDC and SDC and they both have them, so not sure why they show up for only one server in the output.  Is that my problem?  What am I missing? (see attached output run from SDC, I also ran it on the other 2)

When I had DC01 off, before turning it back on, I ran nslookup and got major delays/time-outs the first time around but then would get a response eventually.  Tried clearing cache on both PDC and SDC and re-registering both.  No change.

Any direction or insight would be greatly appreciated.  TIA
DCDIAG-DNSV.txt
0
My CIO came to me and suggested we investigate moving our domain controller to the cloud.  His rational is that we use it for authentication from all of our devices.  We have several sites that have their own internet connection, but we have a VPN connection from each of the sites for authentication.  He thinks that when people log in it slows down our internet, so with that said he wants us to look into it.

I have done some research and everyone says AWS or Microsoft Azure AD Services, but I have no clue where to start.  I also understand that this migration does not take into affect the GPO's which we rely on.  Our domain server houses not only our AD, but our DHCP and DNS.  Can someone point me in the right direction so I can at least start to make some sense out of this project.
0
Hello Experts

I was having internet issues and had to connect directly to my COX Panoramic router, bypassing my Linksys Router.  They are on separate networks (Linksys 192.168.1.xxx ;

COX  192.168.0.xxx)

Now that I have it all back together, I can't access my Buffalo NAS Drives.  They are LS220DE housings with 2ea 1TB RAID Drives

I pulled the drives and held the reset button for 10 seconds like the quick setup said to do. I still can;t access the drives.  They show in a scan with DHCP addresses, but the connection times out.

Any ideas?

Thanks

thedslguy
0
I have a new (?) AIR-CAP2602i-A-K9 access point.  I am trying to get it to connect to a Wireless LAN Controller (WLC2504).
It is not discoverer, and in the access point console, it gives the message, “%CAPWAP-3-DHCP_RENEW: Could not discover WLC using DHCP IP. Renewing DHCP IP.  Not in Bound state. “
I have tried to plug it into my laptop and enter a series of default IP addresses to get to the web console with no luck.
I have reset it a couple of times.
I have tried using archive download-sw /force-reload /overwrite tftp://192.168.130.106/ap3g2-k9w8-tar.153-3.JF12.tar to load a new image.
I have tried setting a static IP and entering the IP of the controller without luck.
The image on it is AP3G2-RCVK9W8-M.  I want it to eventually have image ap3g2-k9w8-tar.153-3.JF12.tar, like the other access points on my controller.
I have read several articles and have tried many suggestions.  I am at a loss as to how to utilize this AP.
0
HyperV  VM  IP addressing questions.

I have setup a test server i want to take live and have made some progress but wondering about IP addressing under the circumstances below.


My server is Windows Server 2016 Standard and it's the host.
It's ipV4 is set to automatically detect from an ethernet port on my wireless router.

That ethenet from the router is connected to the built in ethernet port on my server.
It's ip from the wifi box is 192.168.1.4
Gateway is 192.168.1.1

I added a Hyper V Switch that is connected to a hardware ethernet card installed INSIDE the server

I have a VM of Windows Server 2016 Standard.
I have added the following roles:  AD, DNS, DHCP

So I want my test laptop to connect to the AD Domain to be in the 10.0.0.?  range

Overall, I want to know how i need to setup all the ip addressing, such as:

What ipv4 address should the Hyper-V Switch be? (Its on that ethernet card I added and I have the Hyper-V Switch pointed to that card)
What ipv4  and DNS scope info so I need as it relates to the AD, DNS and DHCP (scope?)
0
DHCP problems on VM with Active Directory Role, DNS Role, DHCP Role

This is a test server that I want to take live after I resolve issues.

So I have 2016 Server Standard with one Hyper-V VM installed.
It has the following roles: Active Directory, DNS, DHCP

I have a test laptop with Windows 10.
My test internet connection is coming from my offices Wifi Router (DHCP enable) via an ethernet port on the back of the router.

Until I installed the DHCP role ... my laptop would connect to the domain with the laptops ipV4 set for automatic IP and DNS set specifically for the IP of VM

After the DHCP Role , my laptop won't login to the domain.
If I look at ifconfig, there's an IP but no gateway and no internet
I tried setting the ipv4 to automatic for IP and DNS but still no gateway and no internet

Help
0
Not sure if I have setup QoS for VOIP correctly to interact with RingCentral on my switch.

I know almost nothing about this aspect.  Switch is Aruba 2540.

RingCentral is seeing jitter when they diagnosed it, I want to make sure that the switch is prioritizing the voip traffic at the best priority over data but I have no idea if this is the right way to do it, or if there is a best-practice type of approach?  The phones are on vlan 10, phone plugs into switch, pc plugs into phone, PoE is used.  In this instance I just want to confirm the switch is properly configured to prioritize traffic, if the problem is upstream, it's upstream, I am just concerned about the switch at this point.

I don't know what the dscp mapping table looks like so maybe ultimately I'm missing the priority?

hostname "zzz"
module 1 type jl356a
qos type-of-service diff-services
ip default-gateway 192.168.xx.xx
ip route 0.0.0.0 0.0.0.0 192.168.xx.xx
snmp-server community "public" unrestricted
snmp-server contact "zzzzz" location "zzzzzzz"
vlan 1
   name "PCS"
   untagged 1-28
   ip address 192.168.xx.xx 255.255.255.0
   exit
vlan 10
   name "PHONES"
   tagged 1-24
   ip address 172.168.xx.xx 255.255.255.0
   ip helper-address 192.168.xx.xxx
   qos dscp 101110
   voice
   exit
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
no dhcp tr69-acs-url
password manager
password operator
0
When I setup a new server is it better to have dhcp and DNS running off the router instead of the server.

The reason why I ask is if the server ever goes down they will still be able to have internet.

Especially if our client is far away.
0
Receiving a ton of "who has 10.0.30.30? Tell 10.0.30.1"
30.1 gateway
30.30 first IP in dhcp pool.
IP has not been assigned in scope (its available).
Wireshark showing broadcast source of gateway SG300-52P.
However SG300-52P arp table has no reference (guess that's obvious from the packet info).

Not sure how to find where this request is coming from and/or how to turn it off.
0
I have a simple network, all flat, using default vlan 1 on my LAN.  I do have 2 switches that have a different vlan to separate my camera traffic.


I am implementing 2 more switches, stacked, (vlan 90) that I need them to be able to access the rest of my current network, vlan 1.
I'm going to create the new vlan on the core switch and add an IP address to it.  I know that all my uplink ports need to also be trunk ports,
so it can pass all the vlans,  I'm guessing, all I need to do is add the new vlan on every current switch in my network and that's all I have to do from a
networking standpoint.  I also need to add the IP helper command on my core switch, so I can pass the DHCP info to my DCs.  Am I missing anything else
I need to do?

In regards to my AD, I'm running windows server 2012R2 for all 3 of my domains.  I'm running DHCP and DNS.
So I'm assuming I need to create a new lookup zone for this new vlan and IP range.
Besides that, am I missing anything?  What else would I need to do?

Is there anything else I need to do to make this happen?

vlans
0
Hello everyone,
Today we worked on installing a new server at an office that has around 50 users.  We planned out and deployed a server migration from Server 2008 R2 to Server 2019.  

All worked well, FSMO, DHCP, DNS, everything moved over without a hitch.  After modifing the login script to recognize the new file server, all users were able to login without any problem and access files.

That all changed about an hour later.  A network connection was disconnected from the new server.  And ever since then, the computers have slowed to pas a crawl.

Like it literrally takes 15-20 mins just to LOG IN!  
Once logged in, you simply can't click any applications or even the start menu.  They aren't locked, just every operation takes minutes when they should be mili-seconds.

I started investigating.  One issue I found was the GPO objects didn't move from the old server.  So when I tried to modify them in the GPO manager, it gave errors saying it couldn't be found.  So I copied them out of SYSVOL on that old server.  Great.  I was now able to edit those GPOs.  

I cleaned up some DNS entries, but I cannot find anything in the event log of any of the servers to indicate any problems.  Since the workstations are soooooooooooo slow, I can't even open the event viewer to see what is going on.  Every command I send it, times out.  I can't find any errors in DNS or DCDIAG.  

Please help
0
Is it a good idea to have an SCCM distribution point serve as a DHCP server as well?   Why or why not?
0
Hey everyone - I am trying to get my router up and running and having a slight issue getting it to connect the internet ( to the ISP ). My basic idea is connecting G0/0 going out to the ISP (Wan), G0/1 to my server. I know im missing something. I've included my running config.
Any help would be appreciated!!

Current configuration : 1735 bytes
!
! Last configuration change at 16:01:56 GMT Tue Jan 21 2020 by admin
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Core_Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
clock timezone GMT -8 0
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 10.24.1.1 10.24.1.10
!
ip dhcp pool core
 import all
 network 10.24.1.0 255.255.255.0
!
!
ip domain name xxxx.net
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2821 sn FTX1311A0C3
username admin privilege 15
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 description PrimaryWANDesc_
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.24.1.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 no ip address
!
interface …
0
I want to connect a fresh Meraki switch to a Cisco ISR. By default the ports on the Meraki are native VLAN 1 and type Trunk. If I make the native VLAN 10 on the ISR's port attaching to the Meraki switch that would create a native VLAN mismatch - but still the two devices should be able to talk to each (assuming I have a DHCP scope on the ISR for VLAN 10).

If I have an ISR (say 4331) configured with inside trunked interface as follows:

Hostname(config)#interface FastEthernet0/1
Hostname(config-if)#no ip address

Hostname(config-if)#no shutdown

Hostname(config)#interface FastEthernet0/1.1
Hostname(config-if)#encapsulation dot1Q 1 native
Hostname(config-if)#ip address 10.10.100.1 255.255.255.0


Hostname(config-if)#interface FastEthernet0/1.2
Hostname(config-if)#encapsulation dot1Q 2
Hostname(config-if)#ip address 10.10.200.1 255.255.255.0

ip dhcp pool MGT
 network 10.10.100.0 255.255.255.0
 default-router 10.10.100.1
 domain-name acmefoo.com
 dns-server 8.8.8.8 4.2.2.2
!
ip dhcp pool DATA
 network 10.10.200.0 255.255.255.0
 default-router 10.10.200.1
 domain-name acmefoo.com
 dns-server  8.8.8.8

The meraki should pick up an address from DHCP for VLAN 10 10.10.100.0 owing
to the fact that those frames would be untagged despite the fact that the default
native vlan on the Meraki is on. Correct?
0
Hello,
I would like to ask why a client sees in network card details that the lease of ip address is less than 2 hours, while in dhcp server (windows server 2016), it is set up for 6 days, the lease period.
Thank you
0
I am setting up a new Windows 2019 Server for a customer.  The way I was taught in the past was to add the role of DNS server to the DC and use the router for the DHCP to the PCs.  I have done it successfully on several servers but it seems convoluted and possibly not correct and efficient.  I do have one customer where the DC is both the DHCP server and DNS server and have not had any issues.  The DNS is configured properly with the interfaces and forwarders and DHCP turned off in the SonicWall.  DHCP is configured with the scope and all of the correct parameters.  I would like to get some opinions as to which way to go.  It seems to me it would be best practice to allow the DC to do both.  What are the pros and cons (if any) using this method?
Thank you in advance,
Phil
0
DHCP  for Wired and Wireless Devices

I would like to have an Expert explain the path Wired and Wireless devices take to get IP address from DHCP  


I put a diagram below, it might not be the right path that devices take to get IP address, but it can be corrected by an Expert.


Thank you


d
0
SBS 2011 standard to Windows Server 2016 Essentials migration
Microsoft's docs recommend to move the DHCP funtion to the router.
Is there a good reason for this as opposed to moving it to the 2016 server?
Has anyone had favorable/unfavorable results either way?
If on 2016, can the existing scope/parameters be moved easily from SBS?
0

DHCP

10K

Solutions

15K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).

Top Experts In
DHCP
<
Monthly
>