[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More







The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).

Share tech news, updates, or what's on your mind.

Sign up to Post

When deploying an image over PXE I'm getting errors PXE-T04 and PXE-P36.  I have tried to start from scratch on the imaging server with no luck.  I'm have installed DHCP and WDS on the imaging server.
Bootstrap 4: Exploring New Features
LVL 12
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

I have a Ubiquiti USG device here.

Its a quite simple setup.

-  Its WAN1 port is connected to my modem-router.
-  its LAN 1 port is connected to an Ubquiti Edge Switch

I can get internet perfectly if i plug cable from modem into switch. However, when internet goes thru the USG device to Switch - I get no internet.

It is as if the USG is blocking internet to the switch.

The USG is acting as DHCP server. What could be blocking the internet in the USG? Any suggestions would be much appreciated.
My company will be moving in a few weeks and as part of the move, I'll be phasing out two old domain controllers. Before I do that, I plan to move DHCP services to the new DCs. I tried to set this up while at our current location, but then realized that the IP Helper on our switch points to the old domain and this was (likely) preventing our new one from responding to and distributing addresses.

So my question is - if I just set up the new office with the IP helper for my VLANs on new switch hardware pointing to the new DC/DHCP server, am I likely to run into issues? (The old DCs would still be available but I'd hope not responding to DHCP/ DNS requests.)

Or, should I really look to tweak the switch settings in the current location to include the new DHCP server before I move?

Question from a Quallys report QID is 119518
I am missing configuration info in the network dialog box.
MissingThe computer used to get on the Internet but was using a rogue router that had been set up with DHCP.  We turned off DHCP on that router so we can use our main router.
Now the Ubuntu 18.04 machine won't grab an IP address.
Experts - have what should be a fairly simple setup, comprising an HP 1920S switch - a Ubiquiti Access Point - and a TZ-400 Sonicwall. Trying to get public/guest WiFi running on VLAN-100, but users not pulling an IP address. Works fine on the Private WiFi network, running on default VLAN-1.

I have this near same setup working at other locations I've done so far - with the only difference between this non-working site and the working sites, is the switch in this non-working site is an HP 1920S switch - whereas other sites have rebranded Aruba switches installed that support CLI.

I've worked with Sonicwall support earlier today and they're not seeing the guest wifi DHCP request hitting the Sonicwall X0:100 interface when a user attempts to connect to the public wifi. They've confirmed the configuration is correct on the Sonicwall.  SHould be OK as it's basically a mirror configuration from other sites that are working.

So this is what I have so far:

**DHCP**   Managed by Sonicwall

DHCP assignment for private internal/wifi office 10.10.x.x and is working,
DHCP assignment for public WiFi is 172.16.1.x and is not working.

** VLAN Info **

Private WiFi and internal office traffic all running on default VLAN-1
Public WiFi is configured to run on VLAN-100.

** Switch Info **

Port #1 is the Sonicwall
Port #2 is the Ubiquity Access Point

Sonicwall support thinks it's an issue upstream, most likely the 1920S switch.  The 1920S only allows GUI. …
Dear Experts,

i am using ESXi 6.5 with VCSA, I have multiple vlan environment and my dhcp server is a windows  vm. my problem is that broadcast from other vlan does not reach to dhcp server.

so i am thinking that if i make port of the vm as trunk so that it can receive requests from other vlans as well.

Please advise how can i do that, or if someone has some other way to do it.

We use Mitel 5212 IP Phones. we are trying to get them to work on a custom VLAN setup on a watchguard m500 firewall. We have created the custom vlan and the ip scope which works fine. I have mimicked the DHCP options from our windows based dhcp server, however this didn't work. On the DHCP windows based DHCP server the options are:

128 Mitel TFTP xxxx.xxxx.xxxx.xxxx
129 Mitel RTC xxxx.xxxx.xxxx.xxxx
130 Mitel IP Phone Identifier MITEL IP PHONE
132 VLAN for Mitel IP Phone 0x3
133 priority for Mitel IP Phone 0x6

On the firewall dhcp scop options 9All custom)
Code       Name                                 Type            Value
128         Mitel TFTP                           IP                  xxxxxx
129         Mitel RTC                            IP                    xxxxxx
130        Mitel IP Phone Identifier  Text              MITEL IP PHONE
132        VLAN for Mitel IP Phone   Hex              3
133        Priority for Mitel IP phone Hex             6

When the phone eventually boots it gets a crazy VLAN id. Any clues as to what I am issing, or a how to guide on getting the IP phones to work?

I have a small business that wants to move entire server to cloud.

I am new to this and wanted to know what are the steps to setup an offsite server?
I may not be using the correct terminology so bear with me.

I have a customer who has 10 windows 7 pro and 5 windows 10 pro machines 3 Network Printers. They use Quickbooks and have their files on the server. This is a single server that does DHCP, DNS, File and Print Services.

I want to setup on Azure a 2012 or 2016 VM where i can make it a DC and setup the shares and move all the customers files and applications on the Azure VM. I want to eliminate their onsite server.
I would setup their firewall as the DHCP Server.

I understand that the internet connection plays a big part but lets assume they have a High Speed Fiber Connection say 100M

Can this be done and what are the cons to doing this.
I am going to be Migrating a SBS2003 server to a Server 2012 standard R2 server.

I have been looking online for step by step directions to get this done.
They had another IT company that setup the 2012 server in VMware.
They already replicated active directory and DHCP and DNS on the 2012 server.
The SBS2003 server is on a physical Machine so what we intend on doing is back up the SBS server into a VHD or VHDK using disk2vhd. and attaching it to VMware as a guest. so if anything goes wrong we can just put the physical server back online.

We will also be setting up StorageCraft backup before starting the migration so if I need to restore the 2012 server in case something goes wrong and we have to start over.
Python 3 Fundamentals
LVL 12
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

Bandwidth allocation - we are trying to increase our dburg bandwidth, currently its at 25%, we have class-default at 17%. Can we drop class default to 10% and increase dburg to 33%. Will it cause performance issues on our router? to better help we have a 500MB pipe

below is the router config

ip dhcp pool ccp-pool
 import all
ip domain name domain.com
ip name-server
ip cef
no ipv6 cef
multilink bundle-name authenticate
class-map match-any domain
 match access-group name VPN-TO-NY
class-map match-any VoIP
 match access-group name VoIP-NY
class-map match-any Broadcast-Video
 match ip dscp cs5
class-map match-any Outbound-Priority
 match access-group name VoIP-Bos
 match access-group name Polycom-Bos
 match access-group name TO-SFB
class-map match-any Bulk-Data
 match ip dscp af11  af12
class-map match-any Multimedia-Steaming
 match ip dscp af31
class-map match-any Interactive-Video
 match ip dscp cs4
 match access-group name Lync-out
class-map match-any Net-Control
 match ip dscp cs6
class-map match-any Multimedia-Conferencing
 match ip dscp af41
class-map match-any OAM
 match ip dscp cs2
class-map match-any Inbound-Priority
 match access-group name VoIP-NY
 match access-group name Polycom-NY
 match access-group name From-SFB
class-map match-any Transactional-Data
 match ip dscp af21
class-map match-any Voice
 match ip dscp ef
class-map …
Hey Folks, were trying to move DHCP off of our Firewall right now over to our Server that is running DHCP. I take it that as long as we have identical scopes including the reserverations and changing lease times for our machines to get new DHCP leases, we shouldn't see any issues arise. Is there anything else to take into consideration before proceeding?
I have one DC  with DHCP and DNS all in one. I am trying to connect a phone but it does not get an IP from the DHCP, Rebooted the server still getting (The DHCP service failed to see a directory server for authorization) error.

The phone (Cisco IP phone SPA 504G)  just sits on utilization network.
All other devices get IP and the lease time is set to 1 day.  It is when I try and add a new phone.
cannot ping my cisco switch - its a Cisco SG350X layer 3 switch - please help

here is the running config

snmp-server location "8th Room"
snmp-server contact
ip name-server
ip telnet server
interface vlan 1
 no ip address dhcp
interface vlan 3
 name "Corp"
interface vlan 5
 name "Guest"
interface GigabitEthernet1/0/1
 switchport access vlan 5
interface GigabitEthernet1/0/2
 switchport access vlan 5
interface GigabitEthernet1/0/3
 switchport access vlan 5
interface GigabitEthernet1/0/4
 switchport access vlan 5
interface GigabitEthernet1/0/5
 switchport access vlan 5
interface GigabitEthernet1/0/6
 switchport access vlan 5
interface GigabitEthernet1/0/25
 switchport access vlan 5
interface GigabitEthernet1/0/26
 switchport access vlan 5
interface GigabitEthernet1/0/27
 switchport access vlan 5
interface GigabitEthernet1/0/28
 switchport access vlan 5
interface GigabitEthernet1/0/29
 switchport access vlan 5
interface GigabitEthernet1/0/30
 switchport access vlan 5
interface GigabitEthernet1/0/48
 dot1x reauthentication
 ip address
 no switchport
interface TengigabitEthernet1/0/1
 description UPLINK
 no spanning-tree portfast
 no switchport
 switchport mode trunk
 switchport trunk native vlan none
interface TengigabitEthernet1/0/2
 switchport access vlan none
interface TengigabitEthernet1/0/3
 switchport access vlan none
I assist a company that has 3 computers and a server.  Its a very basic setup.  Server is 2012 R2, and it manages AD, DNS, DHCP, Antivirus and FS.  2 computers have folder redirection enabled.
Lately we have been having a problem that I just cannot pin down.  2 of the computers in the morning and afternoon and fairly random times will just freeze.  Their mouse changes to the loading circle, and cannot really do anything.  This lasts from 30 seconds to 10 mins. These computers do not have folder redirection enabled.  The network switch is new, and there are no events in the servers logs, or the computer logs that correspond with the times.  One of the computers is quite new, running win 10, i5, 8GB, SSD.  

Some help is needed as this has been happening for months and I cannot find where the failure is.  Everything I see looks normal.  Hardware tests all pass.  

Please help!
Hi Folks,
How do I get AD to store macaddresses of all computers in a domain. It seems an obvious thing to do, and there is a macaddress attribute in the default schema, but it doesn't get populated. Do I have to somehow marry DHCP (which stores macaddresses) and AD ?
The reason I want to do this is I am using Veyon and want to be able to WOL a group of machines without having to manually gather all their macaddresses. Thanks in advance.
I am having a problem with Windows Deployment Services & DHCP.

I have installed and set up WDS on many many sites over the years - I have never encountered the problem that I am facing right now, and I have put hours of work into trying to solve it. I really hope someone here can help. I am using the same method i've used time and time again - but this time, something has gone wrong.

The issue:
Simply put, I cannot get a a Gen2 Hyper-V VM to boot through PXE. It sits at the "Performing DHCP Negotiation...." for a while, and then aborts.
I have also tried with a Physical PC in UEFI Mode - the same behaviour applies, it times out.

Legacy Mode, or Gen1 VM's will successfully boot via PXE, but not Gen2/UEFI.

The setup:
I am running Server 2016 fully up to date, with Hyper-V

On this, I have 3x Windows Server 2012 R2 VMs
  • DC01.ad.local
  • FS01.ad.local
  • WDS01.ad.local

DHCP Role is installed on DC01
WDS Role is installed on WDS01
Everything is in one subnet (

What I have tried, unsuccesfully:
  • Turning Off IPv6
  • Removing WDS from WDS01 and installing it on DC01
  • Building a 4th VM with Server 2016 (DC02) and installing DHCP and WDS Roles and setting up again from scratch
  • Manually creating DHCP Options (I've never had to do this in the past, and i've set it up like this many times)
I have DC and DR site for exchange server 2010.

DC site is working fine but now I am making a function to the DR site. But when I am adding DR site mailbox to same DAG i.e DAG 100 (from Manage DAG membership Section ).

It is a throwing error.

add-databaseavailabiltygroupserver started on machine DCMB1.
[2018-10-11T12:43:20] add-dagserver started
[2018-10-11T12:43:20] commandline:         $scriptCmd = {& $wrappedCmd @PSBoundParameters }
[2018-10-11T12:43:20] Option 'Identity' = 'DAG100'.
[2018-10-11T12:43:20] Option 'MailboxServer' = 'DRMB1'.
[2018-10-11T12:43:20] Option 'DatabaseAvailabilityGroupIpAddresses' = ''.
[2018-10-11T12:43:20] Option 'WhatIf' = ''.
[2018-10-11T12:43:20] Process: w3wp w3wp.exe:5972.
[2018-10-11T12:43:20] User context = 'NT AUTHORITY\SYSTEM'.
[2018-10-11T12:43:20]   Member of group 'Everyone'.
[2018-10-11T12:43:20]   Member of group 'BUILTIN\Users'.
[2018-10-11T12:43:20]   Member of group 'NT AUTHORITY\SERVICE'.
[2018-10-11T12:43:20]   Member of group 'CONSOLE LOGON'.
[2018-10-11T12:43:20]   Member of group 'NT AUTHORITY\Authenticated Users'.
[2018-10-11T12:43:20]   Member of group 'NT AUTHORITY\This Organization'.
[2018-10-11T12:43:20]   Member of group 'BUILTIN\IIS_IUSRS'.
[2018-10-11T12:43:20]   Member of group 'LOCAL'.
[2018-10-11T12:43:20]   Member of group 'IIS APPPOOL\MSExchangePowerShellAppPool'.
[2018-10-11T12:43:20]   Member of group 'BUILTIN\Administrators'.
[2018-10-11T12:43:20] Updated Progress 'Validating the …
Dear experts, if the Access switch is unconfigurable of DHCP snooping, can we do it on Core switch? (The Dhcp is on Core)

Otherwise, how can we mitigate the rogue DHCP? Thanks!
CompTIA Network+
LVL 12
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

Good morning all, I have a SBS 2008 server with some major issues (this is what wont work, IIS servcies, DHCP services. DNS services, many other services also wont run including windows backup, I cant log into the domain or access any IIS sites via any method ive tried. But here is my question., I just need some files that were stored on the companyweb hosted on the server but I have no idea where I can access them to just copy them off. Ive a new server doing everything the old one does and a new site will be hosted there but Im trying to find the local directories where some .xls files are that used to be accessed via the company web. Thanks in advance for any help. Chris. (the server is "running" but theres little I can actually do with it.

 I have 3COM BASELINE 2824-SFP switch and like to access it via IP address. But I don't see it in DHCP server and I have not assigned a static IP address to it in the past.
 I ran Advanced IP scanner and I see my two CISCO switches, but I don't see 3COM switch.
 What can I do to make it receive a dynamic IP address from DHCP server?

We have a Windows 2008 DHCP/DNS/AD server which I'm not pointing the blame at, but something is up with DHCP.  We retired some other servers and updated the DHCP scope to hand out new DNS server assignments.  Strange thing is, clients will still, randomly, have the old DNS servers assigned to them.  This happens during the workday when a DHCP lease is renewed.  Suddenly, a user will lose connectivity.  ipconfig /release and renew and problem is gone for the moment.  Prior to the ipconfig /release and renew, ipconfig /all shows the proper DHCP server, a legitimate IP, mask and gateway, but the 2 old DNS servers.

We've worked hard to ensure that there are no conflicts with the wifi controller, rogue APs and so forth.  ipconfig /all is consistently showing what I described above.  We do not find any rogue devices or anything of that nature.
Weird one - demoted a domain controller - 1 of our SSO applications failed to allow logon for "some" users. - until we put in the FQDN rather that just the server name

we had a dhcp scope of domain.com.au  being pushed out for 2 years - with no sso issues. - now however we had to change the DNS in the scope option to ad.domain.com.au to reflect the actual AD domain name this resolved the issue. - I understand that this is what it  should have always been - but why did this suddenly become an issue after dc demotion 2008 r2?
The BAD_ADDRESS  leases on dhcp server. Does this mean that he have a duplicate ip address somewhere?
We're looking to install the WDS role on a server to host the keys for BitLocker's network unlock feature.  Will only be using WDS for the unlock, nothing else.  Network unlock is our only option since pre-boot PINS are not an option.  We have about 50 desktops scattered throughout different locations and the goal is to enable network unlock with BitLocker.

We'd like to install the WDS role on multiple hosts to avoid a single point of failure.  If one WDS host goes down, this would prevent our desktops from booting which would be very bad.  What do folks do in this situation to allow for redundancy?

Next question.  
We're in AWS.  The concern is that WDS relies on DHCP and since DHCP is hosted in AWS, will this cause problems with WDS?  Keep in mind, we're only using WDS for network unlock.
We'd like to host a server on prem for WDS but this is not an option at this time.

thank you






The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).