[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x

DHCP

10K

Solutions

14K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).

Share tech news, updates, or what's on your mind.

Sign up to Post

I have just configured a LAMP on my 10.1.1.x network.

The LAMP hits the Internet but shows an IP address of 192.168.0.109/24 (eno1).

Cable (Arris) modem is providing DHCP.

How is it possible for this to happen?  I'm thinking that I want the LAMP to have a 10.1 address.
0
Bootstrap 4: Exploring New Features
LVL 12
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

I have Server 2008R2 and wish to change our DHCP scope from 192.168.1.100 - 192.168.1.200 to 192.168.1.50 - 192.168.1.200

Is there a way to do this?
0
OK, I am way out of my league here. I am working on a Novell 6 network and need to make some DHCP reservations. There is a DHCP app on one of the connected machines where the scope is setup but what we need to do is make our IP phones a different range other than our regular range that the scope is handing out. Because of that, we would like to take the MAC addresses and reserve them to a lower range to preserve the number of IPs we are able to give up.
I am familiar with Windows DHCP servers and don't see any of the usual steps to perform these tasks on the Novell app. I have the MAC addresses I need, just need to know where to make the settings.
Thanks.Screen shot of DHCP appScreen shot of DHCP app
0
Migrating the DHCP role from 2008 -> 2012R2 using the basic: netsh dhcp server import / export commands. The new server shows green over IPV4 and all the scope info moved over, and is authorized. I stopped the DHCP service on the source server as well but can't get the new server to issue addresses. Everything I've read makes it seem pretty seamless, so I'm not sure what step I'm missing
0
IP address shortage on Class C network.
The company is in manufacturing business. They have Windows servers, office PCs, production PCs, network switches, internal WiFi, IP phones, machines, etc. They all consume IP addresses. Now they wanna add 40 more production PCs while there are only 20 free IP addresses.
What should be done in order to release more IPs on this network?
One thing we are considering is to create a separate network for all 20 IP phones which are used in the "sub-site". (Please see the attached diagram). We are not good at VLAN, but we can learn. Will VLAN help in this situation?  
Are there any other things we can do?
Thanks!
Jack
Map-IP-Phone.png
0
Set up a new server 2016 yesterday.
Server 2016 Clients cannot open websites when DHCP assigned.
The server is assigning the right IP's.
The only way a client get to open web pages is if i put in a public DNS IP.
I can remote control clients using teamviewer, regardless the DNS settings,

Im quite sure, that there is a problem with the setup of the server, but I cannot find out where.
I have tried running the Routing and remote access wizard.

Can anyone help?
0
We have a brand new Win2016 Server standard and a new Sonicwall NSA2650.  DHCP and DNS seems to be working correctly.  Our computers were able to obtain IP addresses, such as local ip, default gateway and DNS servers.  However, none of our computers can get onto the internet.  Found out that  the computers were not able to ping the default gateway which is the Sonicwall appliance, and vice versa, the Sonicwall wasn't able to ping the workstations.   The windows servers were able to access the internet.
When we tried to ping from the Sonicwall appliance, there were a couple of PCs we were able to ping and then those PCs were able to get onto the internet.  According to Sonicwall techsupport, it has something to do with our Dlink enterprise switch cam table.   However, our client don't think it is because this switch is relatively new.
Any ideas why the PCs cannot access the default gateway?  These PCs are both on wifi and wired ethernet.
0
AD integrated DHCP, Can we achieve it as we can work with AD integrated DNS services.
0
Hello community,

I've no background on configuring VLAN over managed switch and would appreciate some clarification.

Situation is following:
Fortigate 80D Firewall - 3Com Baseline 2928 Layer 3 Switch - DLINK DAP-2360 - AccessPoint

Aim is to broadcast a SSID assign to configured VLAN 40 Interface on the Fortigate who would also act as a DHCP server to give specific IP range to SSID clients.

Options available on the switch:
For each port VLAN membership type are:
-Untagged
-Tagged
-Not a Member
-Link Type (Hybrid, trunk, access)
-PVID

AP configuration according to DLINK doc:
DLINK VLAN CONFIGURATION
On the Fortigate main network + VLAN 40 interface to be dedicated to SSID.

Questions are following:
- What should be the configuration on the Switch port where AP is connected? Default + VLAN40 untagged? Hybrid?
- Does it need a new management VLAN or is the "default network" enough?
- Hints on my specific configuration would be great

Any help would be appreciated!
Thank you,
Nicolas
0
I have a routing puzzle that I just can't figure out.

Here's my network:

SonicWALL TZ210
X0 interface:  192.168.0.2
- no DHCP, no VLAN
- two custom routing rules
Source    Destination                  Service   TOS/Mask     Gateway    Interface    Metric
Any          Partner fiber LAN1     Any         Any                 C3560        X0                1
Any          Partner fiber LAN2     Any         Any                 C3560        X0                1

Cisco C3560CX 8 port Catalyst Switch  <---- core switch used for internal routing
interface GigabitEthernet0/1           <-- this interface is plugged into the nearest SG300 series Cisco Switch
 description gvf-alt-lan
 switchport mode trunk
 speed 1000
 duplex full
 macro description cisco-desktop
 spanning-tree bpdufilter disable
 spanning-tree bpduguard disable

interface GigabitEthernet0/3   <--- this port is plugged into the SonicWALL X0 Interface
 switchport mode access

interface GigabitEthernet0/10  <--- my fiber uplink to partner company
 description FIBER CORE 3650 SWITCH
 no switchport
 ip address 172.31.1.2 255.255.255.248
 speed 10
 duplex full

Routing on gateway switch:
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
!
interface Vlan140
 ip address 192.168.210.1 255.255.255.0
!
interface Vlan150
 ip address 192.168.220.1 255.255.255.0
!
interface Vlan160
 ip address 192.168.230.1 255.255.255.0

ip default-gateway 192.168.0.2
ip route 0.0.0.0 0.0.0.0 …
0
HTML5 and CSS3 Fundamentals
LVL 12
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

I had a Hyper V host that wouldn't boot, but I had some backups of the VMs on another machine that I fired up.  Two of the VMs are DCs, one is the DHCP server and the other the DFS root.  Once the backup VMs booted, I was able to ping both of them.  Things seemed normal until I realized that users were not getting DHCP.   I tried clearing the arp cache on our switches, thinking that those machines couldn't find the DHCP server, but that didn't work.  I even reset one workstation's NICs, but that didn't work either.  Nothing I tried would cause the machine to get an IP assigned.  Only after I assigned a manual IP did that workstation seem to be back to normal.

I also noticed that some of our DFS mapped drives didn't work either, even though the DFS root was up and running and I could ping it.

In the meantime, I was able to get the original Hyper V host up and running again, so I shut down the backup VMs and started up the original VMs.  DHCP and DFS started working immediately!  Can someone help me understand why this happened, why the backup VM wouldn't hand out DHCP requests?  Or why the DFS root didn't seem to work either?  It's kind of useless to have backup VMs if they won't do the jobs they're supposed to...

I am fully up and running with all the original Hyper V host and VMs once more, so the fire has been put out for now.  But, I'm worried that the next time I actually need those backup VMs to work that I'll be in the same situation once more.  Help?
0
I need a documented formula for windows 2016 domain controller sizing.

I want to have three domain controllers running windows 2016. The servers will also run DNS, DHCP services on all domain controllers and and CA on one dc.

I want a documented formula for sizing if challenged in the design review.

I am proposing

4 cores for each dc
24 GB RAM
100 GB disk.

just want some documented formula.
0
I setup a new 2016 server to be our dhcp wifi server. I went through all the steps to export the dhcp file of the 2008 r2 server and then did the import to the 2016.
All seemed to be ok and I see all of the reservations and scope on the new server and the ipv4 and 6 both have green check marks but when I run the authorize managed servers, it says The DHCP server could not contact Active Directory.. I get this when I run Netsh dhcp show server..

Do I need to make any other changes?
0
Hi,
I'm having some problems regarding a Zyxel ZyWall USG 200. And let me be clear from the start; I am far away from being a network expert :-o

Anyways - on LAN1 I have connected a switch to which I have all the clients, AP's, printers etc in the company. On the DMZ-port I have connected our IP telephone system.

On the LAN side I have en Windows server working as a DHCP server - the subnet is 192.168.72.0/24.
On the DMZ side I'm using the build-in DHCP server on the specific port on the Zyxel USG - the subnet is 192.168.73.0/24

I have made some firewall rules which opens for telephone traffic from and to WAN. Besides that I have used the default settings from Zyxel.

My problem is that some clients gets an IP address from the DMZ zone - and NOT from the server on the LAN side.

Hope somebody can help - and please do ask questions if you have any :-D

Thanks in advance.

Best regards
Henrik
0
I have configured a Cisco 4321 router. A Windows PC can successfully access the internet when using dhcp, but when I configure the PC with Static IP, then it can only ping a website e.g. google.com, but cannot browse the internet. I do have a static route and NAT enabled but not sure why it will not resolve DNS request on the Cisco when not using dhcp. I'm new to this so I'll need clear guidance. Thank you.

Here is the config:
!
!
ip name-server 192.168.15.1 139.130.4.4 8.8.8.8
ip dhcp excluded-address 192.168.15.1 192.168.15.99
ip dhcp excluded-address 192.168.15.200 192.168.15.254
!
ip dhcp pool dhcp-pool-1
 import all
 network 192.168.15.0 255.255.255.0
 dns-server 192.168.15.1 139.130.4.4 8.8.8.8 
 default-router 192.168.15.1 
!
!
!
!
subscriber templating
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
diagnostic bootup level minimal
spanning-tree extend system-id
!
!
!
redundancy
 mode none
!
! 
! 
!
!
interface GigabitEthernet0/0/0
 description $ETH-WAN$
 ip address XXX.XXX.XXX.XXX 255.255.255.252 (X is the Static WAN IP assigned by the ISP)
 ip nat outside
 media-type rj45
 speed 1000
 no negotiation auto
!
interface GigabitEthernet0/0/1
 description MAIN LAN
 ip address 192.168.15.1 255.255.255.0
 ip nat inside
 ip nbar protocol-discovery
 negotiation auto
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 ip address 192.168.16.1 255.255.255.0
 negotiation auto
 no mop enabled
!
ip nat inside source list NAT-LIST-LAN interface GigabitEthernet0/0/0 

Open in new window

0
Hi,

We are running out of DHCP IP addresses, the lan is on a 192.168.23.0/24 network
default gateway 192.168.23.5
subnet mask 255.255.255.0

I am looking at supernetting using a 255.255.252.0 /22 subnet to give 1022 useable addresses.

Is it as straight forward as changing the subnet on the router to 255.255.252.0, deleting the DHCP scope on windows server, recreating the scope between 192.168.20.1-192.168.23.254?

And then changing any static devices such as servers , printers, waps, etc to have a subnet of 255.255.252.0 or is there more to it than this, or any special considerations?

Thanks
0
Need to purchase network switch for a school, and we are looking to implement vlans, with the switch doing dhcp for different vlans, on different ports. Prefer something with a friendly gui, as I am new to this, and CLI is not my strength. Any suggestions for hardware, for this criteria, will be appreciated.
0
Cisco 8811 phone. The old IP address is still showing in Call Manager and I don't know how to get Call Manager to shake it out, and grab the new IP address.

Cleared dhcp bindings. The MAC for the old phone is not showing. The phone is plugged directly into the wall jack and not daisy chained to the PC.

Additionally, configured the phone and tested it in the shop before brining it on site.
0
Dear Experts, I need suggestions on this network design. Is there anything we need to consider for improving HA, security, performance? Could you please help? Many thanks!

net.PNG
Core SW1, SW2: Cisco 3850 IP service
Access SW1, SW2: Cisco 2960 LANBase

- Between C1 and C2: EtherChannel Trunking native vlan 88
- Between C1 and C2, C1 and A1, A2, C2 and A1, A2: trunking interfaces native vlan 88
- C1: VTP Servers, other switches are VTP clients, version2
- VLAN 10 (LAN), 11 (LAN), 88 (management) synchronize between switches

- C1:
STP root primary for VLAN10, secodary for VLAN11
HSRP Active for  VLAN10, HSRP Standby for VLAN11 (standby .254)
DHCP pool VLAN10A, VLAN11A, default GW is .254, exclude address .1 - .50 and .53 - .254  (so 2 addresses .51, .52 are available, just for test)

- C2:
STP root primary for VLAN11, secodary for VLAN10
HSRP Active for  VLAN11, HSRP Standby for VLAN10
DHCP pool VLAN10B, VLAN11B, default GW is .254, exclude address .1 - .250 and .253 - .254  (so 2 addresses .251, .252 are available, just for test)

- Access switches: sw mode access / define VLAN on interfaces connected to PCs
0
Exploring ASP.NET Core: Fundamentals
LVL 12
Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

We are a small k-12 school with about 150 school devices plus personal staff devices. Students are not allowed on the network.

I have filters activated on the windows 2012 r2 standard server and need to approve and enter the mac address of permitted devices to receive an address from the DHCP server.

I connected to our dd-wrt router and found a few computers using more bandwidth than they should.

One of the computers using too many resources belonged to one of the staff members. I went to see what that person was doing and I found the laptop powered off and plugged into a charging cart. The teacher stated that the laptop had been off for 2-3 hours, yet the dd-wrt >> Status >> LAN >> Active Clients showed the device had over 500 connections to the internet.

Question:  Is that even possible to see a device showing active on the network but is powered off?  My expectation is NO unless the computer was not truly off.

And I do believe it was powered off. I stood there when she turned it on and booted it up.  I double checked the mac address and it did match. The next time I looked at the active devices, the laptop was no longer on the list.

Thank you.

Jerlo
0
We are a small k-12 school with about 150 school devices plus personal staff devices. Students are not allowed on the network.

I have filters activated on the windows 2012 r2 standard server and need to approve and enter the mac address of permitted devices to receive an address from the DHCP server.

Today the network was slow and a ping test showed 18% lost packets. I connected to our dd-wrt router and found a few computers using more bandwidth than they should.

On the router I can see the IP and the mac address of the devices. The ip address was on handed out by the DHCP server.

Yet when I went to the server >>DHCP>>Address leases, there were several addresses that I could see on the router but I could not see on the leases for the DHCP server.

I did find them using the mac address on the filter list, so they were approved to receive an address, but I could not specifically see them on the lease list.

I thought perhaps I had a second device handing out addresses, but DHCP function is disabled or not installed on the router and other servers. Therefore I do not believe another device was handing out addresses.

Question:  Is it possible to have an incomplete IP address list in the lease section of DHCP?

Thank you.

Jerlo
0
Dear experts, DHCP on Cisco core switch vs on Windows server 2012, which one is better? Can you please suggest pros and cons? We have 500 users, 2000 IP addresses and 20 subnets. Many thanks!
0
As always I would like to begin by thanking everyone who takes the time to answer this question with their expert insights.
I have a 2008R2 Domain Controller that hosts a variety of DHCP scopes that I need to migrate off it as we are demoting and replacing that server. However, no matter which command syntax (through power shell) I try for the netsh I cannot get it to export the settings from TGHDC2 (domain controller) and I continuously get an "Access Denied" error and it immediately stops the DHCP service and does not restart it but it does come back on if I restart it manually..

I have verified that the account (domain administrator account so it should have all required privileges) I am using is a member of the local servers administrator group, etc.

I have another 2008R2 DHCP server (member server only) and I tried to run the exact same command (same domain administrator account) on it and it ran without complaints and it did not stop the DHCP service at all.
 
The one on TGHDC2 also reports this error (1056) which is odd since neither of them have an account specified under this setting and yet it does not impact the other DHCP servers ability to export scopes using netsh.

 "The DHCP service has detected that it is running on a DC and has no credentials configured for use with Dynamic DNS registrations initiated by the DHCP service.   This is not a recommended security configuration.  Credentials for Dynamic DNS registrations may be configured using the …
0
We just switched to a different ISP provider a few days ago. Since then, there have been several Bad Address entries in the DHCP server (Windows server 2012). After deleting them, they'll appear again in an hour. Their Mac addresses are not shown in the address lease.

I used the DHCPFind to check if there's any other DHCP server on the network. The result is attached.

How do I find out what device(s) is causing the issue? Or How to fix this issue?
DHCPFindResult.JPG
0
If we were to setup two 2012 DHCP servers as a hot-standby scenario (see article below) we would also have to point the Cisco switch IP helper address to both servers and then both would get the unicast or broadcast message through the switch when a client (desktop) looks for an IP, because if we do not then the standby DHCP would never be notified of address needs when the active one goes down. However, if we do then what mechanism is in place to prevent both DHCP servers from replying? Would they consult each other first or how would that work, because if they both reply then it isn't standby, but rather load balancing which is not what we need. Pretty sure someone has tried this and made it work. As always very much appreciating all insights and time. Cheers
https://community.cisco.com/t5/other-network-architecture/multiple-ip-helper-address-on-a-single-interface/td-p/404497
http://thesolving.com/server-room/how-to-configure-dhcp-failover-on-windows-server-2012-r2/
0

DHCP

10K

Solutions

14K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).