We help IT Professionals succeed at work.

DHCP

10K

Solutions

15K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).

I had this question after viewing Can Ping Gateway but NOT DNS Server.

A client of mine has this same issue. The fix in "Can Ping Gateway but NOT DNS Server" did not work. I have applied all of the fix items noted in that thread, including the fix solution.

Some data:

Four computers in this office are just fine. They can ping the gateway located at 192.168.16.1. They can ping the DHCP Server located at 192.168.16.3. They can ping the DHS Server located at 192.168.16.3. I have attached the results of an ipconfig /all command here as the file ipconfig.good.txt.

One computer is having problems. It can ping the gateway at 192.168.16.1, but CANNOT ping the DHCP Server and DNS Server at 192.168.16.3. I have attached the results of an ipconfig /all command here as the file ipconfig.bad.txt

The problem happened out of the blue yesterday afternoon. The Windows error logs show no suspicious events during that time period. The machine has a clean registry and clean malware status.

All ideas invited.

-- stan

- - - - - -
Stanley Krute
Chief Technologist
Siskiyou Digital Inc.
stan@siskiyoudigital.com
530-905-0099
ipconfig.good.txt
ipconfig.bad.txt
0
Team,

I have a WDS set up on my network.
It is not on the same server as the DHCP.

I am not seeing option 60 appearing in my DHCP scope options.
Also, how do i get WDS to be discoverable across multiple subnets?
Is there anything for my network team to configure?
We already have ip helper-address configured to point the different subnets to the DHCP server.
0
Hi,

I just want to clarify something about scavenging and dhcp lease time. Does the scavenging Refresh and No Refresh settings have to be equal/or less than the dhcp lease time or does the scavenging period have to be equal/or less to the dhcp lease time? For example if my dhcp lease time is 4 days then should refresh and no refresh period be at most two days a piece? What should the scavenging period be for this amount of time, does it matter?

Thank you.
0
I have a 2016 Windows Essential server. I was onsite the other day and noticed that, although my laptop would obtain an IP address, I couldn't not browse the internet or ping anything on the Internet. The name would resolve and show the IP address DNS had provided, but the ping would time out. I also couldn't ping by IP to the internet. I could ping devices on the local network.
I then noticed the same issue on a computer I was adding to the network. The IP's I obtained were 192.168.10.107 and 192.168.10.109.

I gave both computers a static IP and the same gateway (Watchguard firebox, managed by an outside vendor) and DNS (DNS is the 2016 server) and was fully functional with the use of these static IP's. The IP's I assigned were 192.168.10.233 and 192.168.10.234

The DHCP scope on the 2016 Essentials server is 192.168.10.50-150 with Subnet mask of 255.255.255.0, gateway is 192.168.10.1 and DNS is 192.168.10.4 (the 2016 server)

There were approximately 48 leases out. At one point I got the computer I added to the network to obtain a different IP, which I believe was something below .100 and it worked fine thereafter. I dont know if the fact that it was below the .100 mark was why it worked, or just coindence.

So I was hoping someone might be able to enlighten me on what it may be that is causing me a problem. I wonder if there is some limitation on the 2016 Essentials server as to how many leases it will give out that have full functionality, although I haven't …
0
Say, I have a Ethernet IP camera connected to a Billion router and wish to create a wireless link to a second Billion router which connects to the network. I believe I have created "WPS connection" between the 2 devices. I'm unable to ping the IP camera. The configuration is as follows: IP camera has a fixed IP address on the range 192.168.1.0 /24. The 2 Billion devices each have unique IP addresses on the same range.
The Billion devices are as follows: An older device. The EIPAC BiPack 7300 NX. DHCP has been disabled on this device. A Billion Wireless-N product, model number BIPAC 3100 SN Ethrnet Access point. I would imagine it's something small that I'm doing incorrectly.
The network that these devices are connected to, is also on the same IP Range as above. There is no IP address conflict to my knowledge.
Please describe the basic principles. Kindly describe an alternate method to using the WPS system. It might be simpler if I configure some manual authentication process.  The overall set up is the one Billion device and the camera would be mounted at the inspection point, at the surveillance and the second Billion device would be connected  into the network. Currently I have tested all the devices at short range but to no avail.  Your assistance will be appreciated.
0
I am implementing an Aironet deployment, and I am not sure if I am seeing unnatural instability... or if these things just "do" this sort of thing. My infrastructure is solid, and I am using two subnets- 192.168.1.0/24 and 192.168.3.0/24. My wireless devices will all exist on the 192.168.3.0/24 subnet, so the access points are plugged in there, and I have also connected two of the ports on the WLC 3504 to the 192.168.3.0/24 subnet. I have also connected the service port on our 192.168.1.0/24 subnet, for a number of reasons I won't go into now. There is no DHCP server on the 192.168.1.0/24 subnet, but there is one on 192.168.3.0/24, and the subnets are physically connected via Cisco 2901 router. The service port is configured at 192.168.1.68 and the two other ports are statically set 192.168.3.68 and 192.168.3.69. Just letting things sit, I noticed the SSID's keep appearing and disappearing every few minutes and I consoled in to the AP to see this cycle:

[*08/13/2019 18:50:24.7198] AP has joined controller USMDWLC00
[*08/13/2019 18:50:24.7698] DOT11_DRV[0]: Stop Radio0
[*08/13/2019 18:50:24.7798] DOT11_DRV[0]: Start Radio0
[*08/13/2019 18:50:25.9294] DOT11_DRV[1]: Stop Radio1
[*08/13/2019 18:50:25.9394] DOT11_DRV[1]: Start Radio1
[*08/13/2019 18:50:27.3889] Password for user changed
[*08/13/2019 18:50:27.5989] save_on_failure is set to 1
[*08/13/2019 18:50:27.5989] save_on_failure is set to 1
[*08/13/2019 18:52:08.6904] Re-Tx Count=1, Max Re-Tx Value=5, …
0
Current Configuration:

Three DCs:
DC01 Running Server 2016 Standard, running AD, DNS, WINS
DC02 running Server 2012 R2, running AD, DNS, WINS and DHCP fail-over from DC03.
DC03 running Server 2012 R2, running AD, DNS, WINS, and DHCP with fail-over to DC02, and all FSMO roles
NAS containing User's Data and Roaming Profiles, redirected via GPO's. Some Public data is stored on DC01.
33 Users
4 User PC's - All users are required to have access all four PC's (hot desking).

All replication works fine for AD, DNS and WINS, as does the DHCP fail-over.

I need to update the whole network to native Windows Server 2016 Standard, or better still 2019, without turning the above servers into doorstops, and with the minimum of downtime.
At the end of this exercise, DC02 will be removed from the network completely, as it is not upgradeable, and will only run 2012 R2.
DC03 will also be removed from the network, but will have the Motherboard upgraded, and the system rebuilt as Server 2016 Standard or preferably 2019 Standard.

Can I do it like this?

01 Move all of the FSMO rolls from DC03 to DC01. This would make DC01 the Primary controller.
02 Remove DHCP from DC02 and DC03, and put it on DC01. Break the fail-over between the DC01 and DC02, and then add the DHCP role to DC01. Finally, do backup of DHCP from DC03, and then restore on to DC01.
03 Remove DNS, and WINS from servers DC02 and DC03, leaving DC01 as the only server running DNS and WINS.
04 Demote DC02 and …
0
We have two Cisco 5508X firewalls (one is for failover).  For VPN, we use the old Cisco VPN Client (5.7) and IPSEC.  In the configuration of the firewall, clients authenticate against the domain controller’s address.  The domain controller’s OS is MS Server 2016 Datacenter.

We have noticed in DNS (Microsoft) that some of the VPN clients have the same IP addresses.  There is not a DHCP scope (Microsoft) setup for the VPN network.  To ensure that each VPN client has a separate IP address, can I simply create the scope in DHCP (Microsoft), or is there more to it?
0
Have an HP Color LaserJet CP4025.

Believe the NIC card is bad but have not proven it to my complete satisfaction.

As I am nervous Ned, I want to be sure before the boss brings in the Printer Guy at $150 an hour and proves me the fool.

Printer lost connectivity to the switch.

Checked all the patch cables from the printer, through the wall, to the switch.

All good.

Checked the config on the switch.

All good.

Used other ports on the switch.

All good.

Still no connectivity.

Tried to connect an RJ45 cable from a computer NIC to the printer NIC.

The printer does not show any default 169 do IP address.

The JetDirect menu choice from the printer display is missing meaning I cannot set DHCP.

Did a factory reset.

Did a cold reset.

No go.

Should I grab a laptop and a serial cable and give it a go, or has Nervious Ned done everything he can do to prove the NIC is bad?
0
Dear Experts, we are configuring a new network of new office in next week and have some questions about security:

- How to prevent "rogue" DHCP servers in network?
- How to prevent "rogue" Wireless Access Point in the network? For example: my office's wifi network is "ABC.com" => we'd like to prevent the other SSID "ABC.com" from users' APs?
- Can we prevent ransonware in some network levels?

Our infrastructure is:
- 2 x Firewall Sophos XG310
- 2 x Core switch Cisco 3850 (will be DHCP servers for 20 VLANs)
- 30 x Access switch Cisco SG220 and SG350
- 30 x Wireless Access point Unify AC AP PRO
0
I need to add Option 66 to DHCP Server on FortiWiFi 61E Firewall.  I don't have that listed under "Additional DHCP Options".  Is it possible to do?
0
I have a windows 2000 R2 standard AD server which is doing DHCP. When a look at my leases I have a lot of "BAD ADDRESS IP IN USE". The clients are set for DHCP. The DHCP server is not keeping track of IP addresses leased. What could be causing this. Causing headaches.
0
I installed a new Cisco smart switch and the system light is solid, meaning it is using DHCP.  How do I find the IP?
0
Hello IT gurus

I have microsoft windows DHCP, DNS, and Active Directory servers in the clouds. but now I'm migrating them to newly built datacenter. I need to export them, or their database, and their settings to the new servers in the new datacenter.

Is that possible?
if it's yes, how?
0
Hi,

I have pc which has his IP reserved in DHCP server. The DHCP is configured to update DNS.

Now if I deleted the PC  A record name in DNS. When DHCP will recreate it in DNS?
0
We have multiple sites all on different subnets, we have one central DHCP server which I want to change (so I can do maintenance).

I want to add a second DHCP server (for redundancy) but I can only broadcast one helper address from the site routers.  I have read up on virtual IP's but am unsure if this is the correct way to go.

Notes.
We have multiple DC's in different geographical locations
Routers are part of our MPLS so I cannot make changes (I can have the helper add changed)
All servers are in the hosted data center (VM's)

All help/advice gratefully received.
Steven
0
I am trying to add a 2016 standard server as a DC to a 2008 R2 network.  Once it is added, it will become the only Domain controller on the network and the 2008 R2 will be removed.
I have joined the domain, and added Active Directory Domain Services, DHCP Server, DNS Server and the various roles.  When I go to promote the server, I get a " cannot find the domain controller  error and suggests I check the spelling of the domain.
The domain is chosen from the drop down menu, and is correct.
Should I tried to promote it to a domain controller prior to joining the network?
0
Last week we were shut down for factory maintenance.  We brought a new primary domain controller on line and demoted the old, and moved DHCP to the new PDC.  Since then our wireless devices have been picking up the wrong address.    For example, wireless devices should pick up an xxx.xxx.133.xxx address, but report they have an xxx.xxx.130.xxx address, and then they do not connect to the network.  We did not have an idea of the full impact, but the wireless network is basically down.  There are a hand- full of devices that have the proper address.  I don’t have a clue where to begin.  Normally, I would check the network switches, and I did briefly.  However, this started when we switched domain controllers.  So, I think it might a better use of time to look at the DHCP side, which I have briefly.  Where and what do you think I should start looking at?
0
Hello gents I have a new Cisco Aironet Mobility Express 1830 series POE AP connected to a port in my POE switch.   The AP is getting activity as there is currently a solid green light on the device.   I am looking in my DHCP scope and not seeing the unique ID show up for the device so I could locate the IP address.   Anyone know if they can advise if the port on the switch is assigning a dhcp IP to the device from the server since the device is getting activity and how I can see if the device is online other than CDT which is not picking it up
0
The old saying that "I do not want to start another elephant for just one elephant sandwich applies here. My knowledge of how the internet operates is a 2 on a 1-10 scale . For instance, I have no idea whatsoever what  purpose a subnet mask or a default gateway are for.  I have no idea what a TCP or a UDP port are for. Preferred DNS? Alternate DNS? Not a clue. I choose not to educate myself on these matters because my  interests are intense in other areas and my need for this new knowledge is infrequent. Why the need for a mini article? I am in the midst of installing an NVR and POE switch for a surveillance system for my residence and lab. I have only got eight cameras. Four of them at present are PTZ capable. The difficulty occurs when a camera fails or I wish to change camera models. It is not as simple as plugging in the new POE camera into the POE capable switch. When being helped by someone that knows how to do this they, for a moment turn on DHCP (whatever that is) and obtain different addresses or settings, then turn it off. It comes second nature to those with this knowledge and often takes ony 2 minutes to install any brand of camera  if it has ONVIV compatibility. What would be great is having a mini course or flowchart with which to install a new camera.

Perhaps such a set of "Dummied down" easy instructions already exists. If they do I do not know where they are. For all I know learning all the above may only take a couple hours, but I doubt that it is so …
0
Hello,

Currently we are trying to utilize PXE boot across subsets in our environment. Please read below for more information

Current network environment:
ubnt--enviornemnt.png
●      The USG Router and Switches are assigned static IP addresses listed above
●      The USG router has networks/vlans created on them via the UBNT controller UI (v5.10.23.0)
ip-scheme.png
●      The USG Router is responsible for DHCP for each network
●      Our WDS/MDT server is 10.10.1.26/24 sitting on vlan 100
●      We are able to PXEboot clients on the same subnet (10.10.1.x/24)
●      Issue: We are trying to have clients on the Techbench network vlan 3340 be able to communicate pxe boot to our wds server (10.10.1.26/24)

Current settings in DHCP TechBench4 network
DHCP-options.png
Advanced DHCP Options:
advanced-DHCP.png
Error on Client machine:
client-error.png
I will soon place wireshark traffic logs when i finish testing:
0
Team,

Two questions:-
1. Is there a way that i can automate the creation of reverse lookup zones when i create a scope in DHCP?
2. I have quite a large number of DHCP scopes created already, for which i have no reverse lookup zones configured. Is there a way that i could automate the creation of these zones in DNS
0
I'd like to disable netbios

I set
HKLM:SYSTEM\CurrentControlSet\services\NetBT\Parameters\Interfaces\ {GUID OF NIC} \NetbiosOptions = 2

for each NIC on my domain controllers and restarted.

this can also be done by powershell script
$key = "HKLM:SYSTEM\CurrentControlSet\services\NetBT\Parameters\Interfaces"
Get-ChildItem $key |
foreach { Set-ItemProperty -Path "$key\$($_.pschildname)" -Name NetbiosOptions -Value 2 -Verbose}

$key = "HKLM:SYSTEM\CurrentControlSet\services\NetBT\Parameters\Interfaces"

Open in new window


then removed netbios option on DHCP Scopes.

Now I'd like to create a GPO to disable "TCP/IP NetBIOS Helper" service as well as "NetBt" service as a test on some devices according to this

However, only the NetBT service does not appear in the list of services in order to add this one to a new GPO.  There is no display name for this service, however CLI responds appropriately when you Net Stop NetBT or set to disable via  sc config netbt start= disabled

I would rather just choose the service and disable it using the settings listed for group policy without scripting it, however this would appear to be impossible because NetBT is not listed.  Go to any machine and try finding it.  Why isn't it there?  permissions?
1
I am frequently required to set up a Windows DHCP server to service multiple subnets, typically on different VLANs. Many times I have the option of setting the server up with multiple NICs or to use a single IP address and configure DHCP relay(s) on the router to route the DHCP requests from the various VLANs to it.
I always go with DHCP relays, but I was just curious: are there any advantages to one option or the other? I'd imagine that if you are dealing with a very large number of VLANs then DHCP relays would be the way to go. But if you have 3-4 extra ports on the server, would it be advantageous to use the physical NICs instead?
0
I need to replace a D-Link Acess Point.  This device has particular characteristics that seem hard to replace:

- It must accept a fixed IP address for management on the LAN - as the LAN has no DHCP server.
- It must plug into a wired subnet and NOT be a DHCP server on the wire.
- It must have a DHCP server for the wireless clients - over a range that one can set in the range of the LAN it's connected to by wire.
- It should support IP address assignments in the DHCP server
While *I* don't need it, presumably if used on a network with DHCP service, one could turn off the APs DHCP and it will forward requests onto the LAN.

Finding an AP (or a Router with AP mode) with these characteristics seems difficult.
Any suggestions for devices that *will* do the job?
0

DHCP

10K

Solutions

15K

Contributors

The Dynamic Host Configuration Protocol (DHCP) is an auto configuration protocol used on IP networks and an extension of the Bootstrap Protocol. DHCP allows for computers to be configured automatically to communicate with each other over an IP network without the need for manual setup by a network administrator. The implementation of DHCP relies on a DHCP server to hand out network configuration information to DHCP-capable clients that request an IP address (and other information required or useful in communicating with other devices on an IP network). In addition to an IP address, common configuration information served over DHCP includes a default gateway, subnet mask and DNS sever(s).

Top Experts In
DHCP
<
Monthly
>